Re: dhcp issue

From: Gilles Fabre <fabre.gilles_at_voila.fr>
Date: Tue, 7 Aug 2012 11:01:07 +0200 (CEST)

tried shut/no shu on R2 & R3 interfaces ?

labbed it. works well (see below)

R2#

ip dhcp pool R1_ip
B network 180.1.31.0 255.255.255.0
!
interface Serial0/0
B description conn to R3
B ip address 180.1.23.2 255.255.255.0
B encapsulation ppp
!
ip route 0.0.0.0 0.0.0.0 180.1.23.3

--------------------------------------------------

R3#
ip dhcp-server 180.1.23.2
!
interface Serial0/0
B description conn to R2
B ip address 180.1.23.3 255.255.255.0
B encapsulation ppp
!
interface Serial0/1
B description conn to R1
B ip address 180.1.31.3 255.255.255.0
B ip accounting output-packets
B ip flow ingress
B ip flow egress
B encapsulation ppp
B peer default ip address dhcp
B
--------------------------------------------------

R1#
interface Serial0/1
B description con to R3
B ip address negotiated
B encapsulation ppp

--------------------------------------------------
--------------------------------------------------

R1(config-if)#do sh ip int s0/1
Serial0/1 is up, line protocol is up
B Internet address is 180.1.31.4/32
B Broadcast address is 255.255.255.255
B Address determined by IPCP
B Peer address is 180.1.31.3

R2(config)#do sh ip dhcp bin
Bindings from all pools not associated with VRF:
IP addressB B B B B B B B B Client-ID/B B B B B B B B B B B B B Lease
expirationB B B B B B B Type
B B B B B B B B B B B B B B B B B B B Hardware address/
B B B B B B B B B B B B B B B B B B B User name
180.1.31.4B B B B B B B B B 0063.6973.636f.2d31.B B B Mar 02 2002 01:36
AMB B B Automatic
B B B B B B B B B B B B B B B B B B B 3830.2e31.2e33.312e.
B B B B B B B B B B B B B B B B B B B 332d.5365.7269.616c.
B B B B B B B B B B B B B B B B B B B 302f.31

> Message du 07/08/12 C 10h55
> De : "swap m"
> A : "shekhar sharma"
> Copie C : "Cisco certification"
> Objet : Re: dhcp issue
>
> wht does "debug ppp negotiation" point to ? ID didnt match & TIMEout:
> State ACKsent?
>
> On Tue, Aug 7, 2012 at 12:37 PM, shekhar sharma
> wrote:
> >
> > same status :-
> >
> > R1#sh interfaces serial 0/1 | i add
> > Internet address will be negotiated using IPCP
> >
> > On Tue, Aug 7, 2012 at 12:35 PM, shekhar sharma
> > wrote:
> >>
> >> doesn't help ,,, same isse
> >>
> >>
> >> R3#sh running-config | sec dhcp
> >> ip address-pool dhcp-proxy-client
> >> ip dhcp-server 180.1.23.2
> >>
> >> R2#sh ip dhcp binding
> >> Bindings from all pools not associated with VRF:
> >> IP address Client-ID/ Lease expiration Type
> >> Hardware address/
> >> User name
> >> 180.1.31.1 0063.6973.636f.2d31. Jan 04 2010 12:06 PM
> >> Automatic
> >> 3830.2e31.2e33.312e.
> >> 332d.5365.7269.616c.
> >> 312f.32
> >> R2#ping 180.1.31.3
> >> Type escape sequence to abort.
> >> Sending 5, 100-byte ICMP Echos to 180.1.31.3, timeout is 2 seconds:
> >> !!!!!
> >> Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
> >> R2#sh ip ro
> >> R2#sh ip route 180.1.31.1
> >> Routing entry for 180.1.31.0/24
> >> Known via "eigrp 100", distance 90, metric 2681856, type internal
> >> Redistributing via eigrp 100, rip, ospf 1
> >> Advertised by rip metric 3
> >> ospf 1 subnets
> >> Last update from 180.1.23.3 on Serial0/1, 00:01:58 ago
> >> Routing Descriptor Blocks:
> >> * 180.1.23.3, from 180.1.23.3, 00:01:58 ago, via Serial0/1
> >> Route metric is 2681856, traffic share count is 1
> >> Total delay is 40000 microseconds, minimum bandwidth is 1544 Kbit
> >> Reliability 255/255, minimum MTU 1500 bytes
> >> Loading 1/255, Hops 1
> >>
> >>
> >> R1#sh interfaces serial 0/1 | i add
> >>
> >> Internet address will be negotiated using IPCP
> >>
> >> On Tue, Aug 7, 2012 at 12:11 PM, ccie19804_at_gmail.com
> >> wrote:
> >>>
> >>> Two things -
> >>> 1. change the DHCP server IP to physical IP
> >>> 2. make sure DHCP Server has route to reach pool ip (180.1.31.0/24 in
> >>> this case)
> >>>
> >>> HTH
> >>>
> >>> Swap
> >>> #19804
> >>>
> >>> Sent from my iPhone
> >>> Plaese ingore seplling mistkaes
> >>> ___________________________
> >>>
> >>> On Aug 7, 2012, at 10:42, shekhar sharma
> >>> wrote:
> >>>
> >>> > Hi,
> >>> >
> >>> > Anyone.....??
> >>> > I know I am missing something obvious......But not able to fiure it
> >>> > out.
> >>> >
> >>> >
> >>> > Regards,
> >>> > Shekhar
> >>> >
> >>> > On Sun, Aug 5, 2012 at 11:21 AM, shekhar sharma
> >>> > wrote:
> >>> >
> >>> >> Hi All,
> >>> >>
> >>> >> got stuck in a small issue of DHCP.please help
> >>> >>
> >>> >> *Scenario* :-
> >>> >>
> >>> >> R1 & R3 are connected back2back via serial link running PPP.
> >>> >> R1 is requesting ip via IPCP, R3 is a dhcp-proxy pointing to Dhcp
> >>> >> server
> >>> >> pointing to R2.
> >>> >>
> >>> >> R3 & R2 are also connected back2back via serial link .
> >>> >>
> >>> >> *Issue* :-
> >>> >>
> >>> >> R3 is forwarding dhcp request from R1 to R2. That is as expected.
> >>> >> R2 is receving the requet & allocating 1 Ip address (I can see in
> >>> >> "show ip
> >>> >> dhcp binding").That is as expected.
> >>> >> But on R1 status is still "Internet address will be negotiated using
> >>> >> IPCP"
> >>> >> ....??
> >>> >> Also on R1 not able to see any dhcp debug logs.
> >>> >>
> >>> >> *Configs*:-
> >>> >>
> >>> >> R2#sh running-config | sec dhcp
> >>> >> no ip dhcp use vrf connected
> >>> >> ip dhcp pool R1_ip
> >>> >> network 180.1.31.0 255.255.255.0
> >>> >>
> >>> >> R2#sh ip dhcp binding
> >>> >> Bindings from all pools not associated with VRF:
> >>> >> IP address Client-ID/ Lease expiration
> >>> >> Type
> >>> >> Hardware address/
> >>> >> User name
> >>> >> 180.1.31.1 0063.6973.636f.2d31. Jan 04 2010 12:12 PM
> >>> >> Automatic
> >>> >> 3830.2e31.2e33.312e.
> >>> >> 332d.5365.7269.616c.
> >>> >> 312f.32
> >>> >>
> >>> >> ===================================
> >>> >> R3#sh running-config int se1/2
> >>> >> Building configuration...
> >>> >> Current configuration : 200 bytes
> >>> >> !
> >>> >> interface Serial1/2
> >>> >> ip address 180.1.31.3 255.255.255.0
> >>> >> ip accounting output-packets
> >>> >> ip flow ingress
> >>> >> ip flow egress
> >>> >> encapsulation ppp
> >>> >> peer default ip address dhcp
> >>> >> serial restart-delay 0
> >>> >> end
> >>> >>
> >>> >> R3#sh running-config | sec dhcp
> >>> >> ip address-pool dhcp-proxy-client
> >>> >> ip dhcp-server 150.1.2.2
> >>> >>
> >>> >> ===================
> >>> >> R1#sh run int se0/1
> >>> >> Building configuration...
> >>> >> Current configuration : 69 bytes
> >>> >> !
> >>> >> interface Serial0/1
> >>> >> ip address negotiated
> >>> >> encapsulation ppp
> >>> >> end
> >>> >>
> >>> >> R1#sh int serial 0/1 | i add
> >>> >> Internet address will be negotiated using IPCP
> >>> >>
> >>> >> Regards,
> >>> >> Shekhar
> >>> >
> >>> >
> >>> > Blogs and organic groups at http://www.ccie.net
> >>> >
> >>> >
Received on Tue Aug 07 2012 - 11:01:07 ART

This archive was generated by hypermail 2.2.0 : Sat Sep 01 2012 - 08:41:18 ART