Re: OT: Catalys 6500 qos policing doubts

From: Juan <fferrer10_at_gmail.com>
Date: Tue, 22 May 2012 08:30:33 +0200

Hi Marc,

I am using something like this (at each input L2 interface i have only a
different type of traffic i need to mark, the config i sent you is a
simplified version ):

...
access-list 10 permit any

class-map class_in
 match access-group 10

policy-map pol_in1
 class class_in
  set dscp dscp1

policy-map pol_in2
 class class_in
  set dscp dscp2
policy-map pol_in3
 class class_in
  set dscp dscp3

interface TenGigabitEthernet2/3/14
 switchport
 switchport access vlan 200
 switchport mode access
 platform qos queue-mode mode-dscp
 service-policy input pol_in1

interface TenGigabitEthernet2/3/15
 switchport
 switchport access vlan 20
 switchport mode access
 platform qos queue-mode mode-dscp
 service-policy input pol_in2

interface TenGigabitEthernet2/3/16
 switchport
 switchport access vlan 2
 switchport mode access
 platform qos queue-mode mode-dscp
 service-policy input pol_in3
....

This is, i am using a different policy-map at each input interface to mark
with a different dscp value

Regards.

2012/5/22 marc edwards <renorider_at_gmail.com>

> This sounds accurate. You are attempting to use mutations in ingress then
> police the new markings outgoing. It is a very thoughtful question. It
> sounds like mutations are off missing or QoS isn't enabled. How are you
> remarking on ingress?
>
>
> On Mon, May 21, 2012 at 3:00 PM, marc edwards <renorider_at_gmail.com> wrote:
> > Is mls qos enabled.
> >
> > can you do a show mls qos?
> >
> > On Mon, May 21, 2012 at 2:37 PM, Juan <fferrer10_at_gmail.com> wrote:
> >> Carlos, maybe i am misunderstanding the 15.0.1 IOS for 6500 config
> notes ,
> >> but at:
> >>
> >>
> http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/15.0SY/configuration/guide/qos_class_mark_police.html
> >>
> >> you can see this note at "Overview of Policing":
> >>
> >> "For all policers, PFC QoS uses a configurable global table that maps
> the
> >> internal DSCP value to a marked-down DSCP value. When markdown occurs,
> >> PFC QoS gets the marked-down DSCP value from the table. You cannot
> specify
> >> marked-down DSCP values in individual policers."
> >> I am trying to do this:
> >>
> >> -mark some types of traffic entering Cat6500 layer 2 interfaces using
> >> different DSCP values
> >> -policing these same flows previously marked at a different output
> >> interface (layer 3 interface of the same 6500) , by matching them
> >> using dscp values "assigned" on the input. Then, i do not see clearly if
> >> the comment "You cannot specify marked-down DSCP values in individual
> >> policers." is a restriction for this type of config (i have done a SPAN
> of
> >> the output traffic, and i can not see the new dscp values... maybe this
> is
> >> normal because the dscp assigned at the input is only an "internal
> dscp" ??)
> >>
> >> Many thanks newly & Best Regards
> >>
> >>
> >>
> >>
> >> 2012/5/21 Carlos G Mendioroz <tron_at_huapi.ba.ar>
> >>
> >>> Where did you read that ?
> >>> AFAIK, you can mark on input and do congestion management on output
> even
> >>> on a 6k.
> >>> -Carlos
> >>>
> >>> JuanF @ 21/05/2012 15:40 -0300 dixit:
> >>>
> >>> Hi all,
> >>>>
> >>>> I have a 6509 Catalyst with:
> >>>> -Supervisor card 2T
> >>>> -Ios 15.0.SY1
> >>>>
> >>>> I need to do a QoS policing configuration on this hardware, with these
> >>>> conditions:
> >>>>
> >>>> -Mark Dscp value from some types of IP traffic on several layer2 INPUT
> >>>> Interfaces of the 6509
> >>>> -Use these DSCPs marks to aply different QoS policings to these flows
> >>>>
> >>>> Is it possible to do all this by configuring only the 6500 switch?
> (this
> >>>> is,
> >>>> without depending of matching the dscp value marked by a diferent
> >>>> device). I
> >>>> read you can not mark the Dscp on the 65000 and also manipulate the
> same
> >>>> traffic using these Dscps values locally asigned on the 65000.
> >>>>
> >>>> TIA and Best Regards
> >>>>
> >>>>
> >>>> Blogs and organic groups at http://www.ccie.net
> >>>>
> >>>> ______________________________**______________________________**
> >>>> ___________
> >>>> Subscription information may be found at:
> >>>> http://www.groupstudy.com/**list/CCIELab.html<
> http://www.groupstudy.com/list/CCIELab.html>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>
> >>> --
> >>> Carlos G Mendioroz <tron_at_huapi.ba.ar> LW7 EQI Argentina
> >>>
> >>
> >>
> >>
> >> --
> >> Juan Faure
> >>
> >>
> >> Blogs and organic groups at http://www.ccie.net
> >>
> >> _______________________________________________________________________
> >> Subscription information may be found at:
> >> http://www.groupstudy.com/list/CCIELab.html
> >>
> >>
> >>
> >>
> >>
> >>
> >>
>
>

-- 
Juan Faure
Blogs and organic groups at http://www.ccie.net
Received on Tue May 22 2012 - 08:30:33 ART

This archive was generated by hypermail 2.2.0 : Sun Jun 17 2012 - 09:04:20 ART