Yuri,
with Dennis help I was able to figure out that I was missing the ip pim
sparse-mode on the connection between R2 to R1.
after that I re-lab it up on GNS3 and despite that it doesn't work (even
reloading everything after the configuration).
I did the same lab on IOU and still the problem persists.
Dennis, very kindly, was able to fire up a lab on real equipment and it was
working.
at that point I'm giving up.. I guess it's something doesn't work on
gns3/iou.
tnx Dennis for your help!
btw the configs are: (only significant parts):
R1
interface FastEthernet0/0
ip address 10.1.12.1 255.255.255.0
ip rip v2-broadcast
router rip
version 2
network 1.0.0.0
network 10.0.0.0
no auto-summary
R2
interface FastEthernet0/0
ip address 10.1.12.2 255.255.255.0
ip pim sparse-mode
ip multicast helper-map broadcast 224.1.1.1 100 ttl 5
interface Serial0/0.23 point-to-point
ip address 10.1.23.2 255.255.255.0
ip pim sparse-mode
snmp trap link-status
frame-relay interface-dlci 203
ip forward-protocol nd
ip forward-protocol udp rip
access-list 100 permit udp host 10.1.12.1 eq rip host 255.255.255.255 eq
rip log
R4
interface FastEthernet0/0
ip address 10.1.45.4 255.255.255.0
ip directed-broadcast
interface Serial0/0.43 point-to-point
ip address 10.1.34.4 255.255.255.0
ip pim sparse-mode
ip multicast helper-map 224.1.1.1 10.1.45.255 100
snmp trap link-status
frame-relay interface-dlci 403
ip forward-protocol nd
ip forward-protocol udp rip
access-list 100 permit udp host 10.1.12.1 any eq rip
R5:
interface FastEthernet0/0
ip address 10.1.45.5 255.255.255.0
router rip
version 2
no validate-update-source
network 5.0.0.0
network 10.0.0.0
no auto-summary
On Sun, Apr 1, 2012 at 5:49 PM, Yuri Bank <yuribank_at_gmail.com> wrote:
> Can you post full configs? ( for R2 and R4 )
>
> -Yuri
>
>
> On Sat, Mar 31, 2012 at 1:29 AM, ccie99999 <ccie99999_at_googlemail.com>wrote:
>
>> thanks Dennis..
>>
>> you've pointed out probably the right point.
>>
>> anyway I've already tried to setup a ttl of 3 (that should be enough) but
>> nothing. I've also tried an higher number but still nothing :(
>>
>> R1 - R2 - R3 - R4 - R5
>>
>> on R2 if I debug the acl 100 I see this:
>>
>> *Mar 1 01:01:42.663: IP: s=10.1.12.1 (FastEthernet0/0),
>> d=255.255.255.255,
>> len 52, rcvd 2
>> *Mar 1 01:01:42.667: UDP src=520, dst=520
>> R2#
>> *Mar 1 01:02:05.111: %SEC-6-IPACCESSLOGP: list 100 permitted udp
>> 10.1.12.1(520) -> 255.255.255.255(520), 9 packets
>>
>> I should now expect the broadcast traffic becomes multicast with
>> "destination?" 224.1.1.1.
>>
>> Unluckily I don't see the join in R2 to group 224.1.1.1:
>>
>> (the helper map was: ip multicast helper-map broadcast 224.1.1.1 100 ttl
>> 5)
>>
>> R2#show ip mroute 224.1.1.1
>>
>> (*, 224.1.1.1), 01:02:09/00:03:27, RP 2.2.2.2, flags: S
>> Incoming interface: Null, RPF nbr 0.0.0.0
>> Outgoing interface list:
>> Serial0/0.23, Forward/Sparse, 01:02:09/00:03:27
>>
>> and I do a generic "debug ip packet detail" on R3 I don't get any traffic
>> regarding 224.1.1.1
>>
>> to me it looks like the helper-map is not converting from broadcast to
>> multicast..
>>
>> I don't understand why :(
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> On Fri, Mar 30, 2012 at 4:15 PM, Dennis Worth <dennis.worth_at_gmail.com
>> >wrote:
>>
>> > check out the end of your ip helper-map broadcast and do a ?
>> >
>> > Hint: hop count
>> >
>> > On Fri, Mar 30, 2012 at 1:35 AM, ccie99999 <ccie99999_at_googlemail.com
>> >wrote:
>> >
>> >> hello GS guys..
>> >>
>> >> I'm following this guide for doing a small lab regarding the use of a
>> >> multicast helper for connecting 2 broadcast networks..
>> >>
>> >> I'm reading this:
>> >>
>> >>
>> >>
>> http://www.cisco.com/en/US/docs/ios-xml/ios/ipmulti_igmp/configuration/12-4t/imc_interm_mc_helper.html
>> >>
>> >> I'm sure I've already done this lab times ago and it was working.. I'm
>> >> pretty sure I was using IOU at that time and now it's not working, nor
>> >> with
>> >> IOU nor with dynamips.
>> >>
>> >> the lab is small:
>> >>
>> >> R1 - R2 - R3 - R4 - R5
>> >>
>> >> from R2 to R4 it's a multicast enabled network and on R1 and R5 I've
>> >> enable
>> >> Rip v2.
>> >>
>> >> I've setup everything like it should be:
>> >>
>> >> ################
>> >> R1: rip enabled (v2) and on interface between R1 and R2 I've put ip rip
>> >> v2-broadcast
>> >> ################
>> >> R5: rip enabled (v2)
>> >> ################
>> >> R2: I've setup an helper-map like this one: ip multicast helper-map
>> >> broadcast 224.1.1.1 100
>> >> R2: I've setup an acl like this one: access-list 100 permit udp host
>> >> 10.1.12.1 eq rip host 255.255.255.255 eq rip log
>> >> R2: enabled this: ip forward-protocol udp rip
>> >> ################
>> >> R4: I've setup and helper-map that take the traffic from 224.1.1.1 and
>> >> send
>> >> to broadcast address of network between R4 and R5 if that matches acl
>> 100
>> >> ip multicast helper-map 224.1.1.1 10.1.45.255 100
>> >> R4: acl 100 of course: access-list 100 permit udp host 10.1.12.1 any eq
>> >> rip
>> >> log
>> >> R4: enabled this: ip forward-protocol udp rip
>> >> ################
>> >>
>> >> multicast-routing is enabled on R2,R3,R4 and R2 is the bsr candidate
>> and
>> >> MA
>> >> for the network.
>> >> on R3 and R4 I can see the rp mapping.
>> >>
>> >> ospf is enabled on R2,R3,R4
>> >>
>> >> everything looks fine (to me) but it doesn't work.
>> >>
>> >> If I do a capture I see the broadcast traffic coming from R1, matching
>> the
>> >> access-list 100 and then stop.
>> >> Despite this on R3 and R4 I see the mroute 224.1.1.1
>> >>
>> >> If I do a capture on R4 I don't get any traffic matching the acl 100.
>> >>
>> >> I've checked and re-checked the configuration guide (the link above)
>> and I
>> >> don't understand what I miss.
>> >>
>> >> Looks like the R2 is not able to convert the traffic from broadcast to
>> >> multicast and therefore the traffic is not reaching R4.
>> >>
>> >> anyone see an error in what I've done?
>> >>
>> >> tnx in advance
>> >>
>> >> --
>> >> ccie99999
>> >>
>> >>
>> >> Blogs and organic groups at http://www.ccie.net
>> >>
>> >> _______________________________________________________________________
>> >> Subscription information may be found at:
>> >> http://www.groupstudy.com/list/CCIELab.html
>> >>
>> >>
>> >>
>> >>
>> >>
>> >>
>> >>
>> >>
>> >
>> >
>> > --
>> > Dennis Worth
>> >
>> >
>> >
>> >
>>
>>
>> --
>> ccie99999
>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>>
>>
>>
>>
>>
>>
>>
>>
>
-- ccie99999 Blogs and organic groups at http://www.ccie.netReceived on Mon Apr 02 2012 - 03:33:23 ART
This archive was generated by hypermail 2.2.0 : Tue May 01 2012 - 08:20:45 ART