Okay, the logic as to why a route is accepted or not, and how RIP is
processing updates is making my brain melt! I'm hoping you guys can
give me an assist on this. Here is my current understanding of how
RIPv1 processes updates. Please correct any of the below statements
that are incorrect.
* RIPv1 sends updates for all RIP-enabled networks with the full
network, but no subnet mask information.
* So, for example, 10.20.30.0/24 will be advertised as 10.20.30.0 with no mask.
* If the router has a connected interface in the same classful network
as the update, it will use that interface's mask for the update.
* For example, if the interface the above update was received on is
10.20.40.0/28, the route will be installed as 10.20.30.0/28.
* This also applies to connected interfaces that are active in RIP but
were not actually involved in the receiving the route.
* So, if the update is received on link 20.30.40.0/24, but there is a
connected loopback that is 10.99.99.0/25, the route will be installed
as 10.20.30.0/25.
I'm especially confused by the loopback part, as I have a router that
has a loopback assigned 150.1.10.0/24, and it will not accept a RIPv1
update of 150.1.0.0 (as seen via 'debug ip rip') into its routing
table. If I shutdown the loopback, the route is installed. To
compound my confusion, I don't really understand why SW2 is
advertising 150.1.0.0 instead of the component subnets (as seen in the
show output below). It advertises other networks that are not on
their classful boundaries (advertises 155.1.37.0/24 as 155.1.37.0,
even though it's a Class B), why not the loopback network?
Here are the relevant configs:
***SW2***
router rip
network 150.1.0.0
network 155.1.0.0
no auto-summary
!
interface Port-channel1
no switchport
ip address 155.1.108.8 255.255.255.0
ip rip send version 1
ip rip receive version 1
SW2#show ip route | inc 150.1.
150.1.0.0/16 is variably subnetted, 9 subnets, 2 masks
R 150.1.7.0/24 [120/3] via 155.1.58.5, 00:00:07, Vlan58
R 150.1.6.0/24 [120/3] via 155.1.58.5, 00:00:07, Vlan58
R 150.1.5.0/24 [120/1] via 155.1.58.5, 00:00:07, Vlan58
R 150.1.3.0/24 [120/2] via 155.1.58.5, 00:00:07, Vlan58
R 150.1.2.0/24 [120/2] via 155.1.58.5, 00:00:07, Vlan58
R 150.1.1.0/24 [120/2] via 155.1.58.5, 00:00:07, Vlan58
R 150.1.0.0/16 [120/2] via 155.1.58.5, 00:00:07, Vlan58
R 150.1.9.0/24 [120/4] via 155.1.58.5, 00:00:07, Vlan58
C 150.1.8.0/24 is directly connected, Loopback0
***SW4***
router rip
network 150.1.0.0
network 155.1.0.0
no auto-summary
!
interface Port-channel1
no switchport
ip address 155.1.108.10 255.255.255.0
!
SW4#show ip route | inc 150.
150.1.0.0/24 is subnetted, 1 subnets
C 150.1.10.0 is directly connected, Loopback0
SW4#show ip rip database | inc 150.
150.1.0.0/16 auto-summary
150.1.10.0/24 directly connected, Loopback0
Any input, thoughts, or other corrections of my understanding are
greatly appreciated!
Keller Giacomarro
keller.g_at_gmail.com
Blogs and organic groups at http://www.ccie.net
Received on Mon Jan 30 2012 - 06:08:31 ART
This archive was generated by hypermail 2.2.0 : Thu Feb 02 2012 - 11:52:52 ART