This is what i was referring to:
R1s F0/0 is connected to SW1s port F0/1
R2s F0/1 is connected to SW2s port F0/2
SW1s F0/19 is connected to SW2s F0/19
*SW1#sh run int f0/19 | B inter*
interface FastEthernet0/19
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport mode trunk
end
*
*
*SW2#sh run int f0/19 | B inter*
interface FastEthernet0/19
switchport trunk encapsulation dot1q
switchport mode trunk
end
*NOTE: The trunk is UP*
*SW1#Show int trunk*
Port Mode Encapsulation Status Native vlan
Fa0/19 on 802.1q trunking 10
Port Vlans allowed on trunk
Fa0/19 1-4094
Port Vlans allowed and active in management domain
Fa0/19 1,10,80
Port Vlans in spanning tree forwarding state and not pruned
Fa0/19 1,10,80
*SW2#sh spanning-tree blockedports *
Name Blocked Interfaces List
-------------------- ------------------------------------
VLAN0001 Fa0/19
VLAN0010 Fa0/19
Number of blocked ports (segments) in the system : 2
*All Traffic is blocked for the two Vlans.*
*And sure you can get around it, and one way to do this is to filter BPDUs
that carry the VLANs as you mentioned:*
SW1(config)#int f0/19
SW1(config-if)#spanning-tree bpdufilter en
*SW1#sh spannin blockedports *
Name Blocked Interfaces List
-------------------- ------------------------------------
Number of blocked ports (segments) in the system : 0
*And I am sure there are other ways. But remember this is the default
behavior BUT not on all IOSes, on some IOSes, it will complain that there
is a Native VLAN mismatch, but it will NOT block the VLANs configured as
Native*
On Thu, Dec 8, 2011 at 10:35 AM, Narbik Kocharians <narbikk_at_gmail.com>wrote:
> Yes, you are correct, you can get around it, i was referring to the
> default behavior.
>
>
> On Thu, Dec 8, 2011 at 9:23 AM, Paul Cocker <paul.cocker_at_gmx.com> wrote:
>
>> Spanning-tree...
>>
>> I'm guessing the vlan is in the bpdu.
>>
>> with this config...
>>
>> SW1
>> interface FastEthernet0/13
>> switchport trunk encapsulation dot1q
>> switchport trunk native vlan 10
>> switchport mode trunk
>> switchport nonegotiate
>>
>> SW2
>> interface FastEthernet0/13
>> switchport access vlan 20
>> switchport trunk encapsulation dot1q
>> switchport trunk native vlan 20
>> switchport mode trunk
>> switchport nonegotiate
>> no cdp enable
>>
>>
>> you get this...
>>
>> *Mar 1 00:18:26.994: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with
>> inconsistent peer vlan id 10 on FastEthernet0/13 VLAN20.
>> *Mar 1 00:18:26.994: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking
>> FastEthernet0/13 on VLAN0020. Inconsistent local vlan.
>>
>> You can disable spanning tree, or use bpdufilter to get around it.
>>
>>
>> On 08/12/2011 16:58, Carlos G Mendioroz wrote:
>>
>>> What mechanism is responsible for such blocking ?
>>>
>>> -Carlos
>>>
>>> Narbik Kocharians @ 08/12/2011 13:34 -0300 dixit:
>>>
>>>> Between any two switch if the Native VLAN is mismatched the trunk will
>>>> come up but you won't be able to pass any traffic through it, and you
can
>>>> see that with a "Show spanning block".
>>>> On Thu, Dec 8, 2011 at 4:31 AM, David Bass
<davidbass570_at_gmail.com<mailto:
>>>> davidbass570_at_gmail.com**>> wrote:
>>>>
>>>> We are talking about CCIE lab, so best practice and "working" status
>>>> all go out the window :). In his scenario he's talking about router
>>>> to switch trunk, so no VTP or STP (if you do this switch to switch
>>>> you'll definitely have issues though, so very good to know)...CDP
>>>> will definitely bark non-stop though which is very irritating.
>>>>
>>>>
>>>>
>>>> On Dec 8, 2011, at 6:08 AM, Carlos G Mendioroz wrote:
>>>>
>>>> > May be depending on the equipment, the trunk will "form" just fine,
>>>> > if VLAN hopping is not considered to be a problem :)
>>>> > CDP may barf. If VLAN 1 is involved, other griefs will pop.
>>>> >
>>>> > Different problems:
>>>> > -framing: no problem, but "native VLAN" frames do not signal
>>>> which VLAN
>>>> > they belong to, so if they do not match, frames will hop from one
>>>> VLAN
>>>> > to the other.
>>>> >
>>>> > -signalling (DTP): AFAIK, VLANs are not part of the info
>>>> interchanged, so the trunk will form even if native is not the same.
>>>> >
>>>> > -control: (CDP/VTP/STP/...): well, you may have a problem here.
>>>> > In particular, CDP/VTP go on VLAN 1, so if this is one of the VLANs
>>>> > involved in the crossing, it won't work.
>>>> >
>>>> > -Others ?
>>>> >
>>>> > -Carlos
>>>> >
>>>> >
>>>> > David Bass @ 08/12/2011 08:25 -0300 dixit:
>>>> >> The trunk will come up fine, but you won't have IP connectivity
>>>> between the 2 devices on the VLANs/subnets you are expecting because
>>>> the 2 native VLANs are being bridged. Do some research on how dot1q
>>>> trunks work and you should be able to figure it out. On Dec 7, 2011,
>>>> at 11:40 PM, CCIE KID <eliteccie_at_gmail.com
>>>> <mailto:eliteccie_at_gmail.com>> wrote:
>>>> >>> Hi fellas,
>>>> >>>
>>>> >>> I tested a scenario where the Native vlan differs from the
>>>> router port to
>>>> >>> the switch port. I understood that if the NAtive vlan
>>>> mismatches on a trunk
>>>> >>> port , then appropriate trunking wont be formed.
>>>> >>> But when i connect my router to a switch and in the router
>>>> subinterface . I
>>>> >>> am having a native vlan of 20 and in the switch port it is
>>>> having a native
>>>> >>> vlan of 10 , but still the trunk is forming perfectly
>>>> >>>
>>>> >>> Can someone correct me
>>>> >>> fa0/1.1 fa0/1
>>>> >>> Router1-----------------------**------------------------Switch 1
>>>> >>>
>>>> >>> Router 1
>>>> >>>
>>>> >>> inter fa 0/1.1
>>>> >>> encap dot1q 20 native
>>>> >>> ip add 10.1.1.1 255.255.255.0
>>>> >>> no sh
>>>> >>>
>>>> >>>
>>>> >>> Switch 1
>>>> >>>
>>>> >>> int fa 0/1
>>>> >>> enc dot1q 10 native
>>>> >>> swi trunk enc dot
>>>> >>> swi mo trunk
>>>> >>> no sh
>>>> >>>
>>>> >>>
>>>> >>> But s
>>>> >>>
>>>> >>> --
>>>> >>> With Warmest Regards,
>>>> >>>
>>>> >>> CCIE KID
>>>> >>> CCIE#29992 (Security)
>>>> >>>
>>>> >>>
>>>> >>> Blogs and organic groups at http://www.ccie.net
>>>> >>>
>>>> >>>
>>>> ______________________________**______________________________**
>>>> ___________
>>>> >>> Subscription information may be found at:
>>>>
http://www.groupstudy.com/**list/CCIELab.html<http://www.groupstudy.com/list/
CCIELab.html>
>>>> >> Blogs and organic groups at http://www.ccie.net
>>>> >>
>>>> ______________________________**______________________________**
>>>> ___________
>>>> >> Subscription information may be found at:
>>>>
http://www.groupstudy.com/**list/CCIELab.html<http://www.groupstudy.com/list/
CCIELab.html>
>>>> >
>>>> > --
>>>> > Carlos G Mendioroz <tron_at_huapi.ba.ar <mailto:tron_at_huapi.ba.ar>>
>>>> LW7 EQI Argentina
>>>>
>>>>
>>>> Blogs and organic groups at http://www.ccie.net
>>>>
>>>> ______________________________**______________________________**
>>>> ___________
>>>> Subscription information may be found at:
>>>>
http://www.groupstudy.com/**list/CCIELab.html<http://www.groupstudy.com/list/
CCIELab.html>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> *Narbik Kocharians
>>>> *CCSI#30832, CCIE# 12410 (R&S, SP, Security)
>>>> *www.MicronicsTraining.com*
<http://www.micronicstraining.**com/<http://www.micronicstraining.com/>
>>>> >
>>>> Sr. Technical Instructor
>>>> YES! We take Cisco Learning Credits!
>>>> Training & Remote Racks available
>>>>
>>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> ______________________________**______________________________**
>> ___________
>> Subscription information may be found at: http://www.groupstudy.com/**
>> list/CCIELab.html <http://www.groupstudy.com/list/CCIELab.html>
>>
>>
>>
>>
>>
>>
>>
>>
>
>
> --
> *Narbik Kocharians
> *
> CCSI#30832, CCIE# 12410 (R&S, SP, Security)
> *www.MicronicsTraining.com* <http://www.micronicstraining.com/>
> Sr. Technical Instructor
> YES! We take Cisco Learning Credits!
> Training & Remote Racks available
>
>
-- *Narbik Kocharians *CCSI#30832, CCIE# 12410 (R&S, SP, Security) *www.MicronicsTraining.com* <http://www.micronicstraining.com/> Sr. Technical Instructor YES! We take Cisco Learning Credits! Training & Remote Racks available Blogs and organic groups at http://www.ccie.netReceived on Thu Dec 08 2011 - 11:28:03 ART
This archive was generated by hypermail 2.2.0 : Sun Jan 01 2012 - 08:27:00 ART