Just did this last night -
R1.Fa0/0<----------->R2F0/0
R1:
!
hostname R1
!
interface FastEthernet0/0
ip address 192.1.1.1 255.255.255.0
duplex auto
speed auto
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 192.1.1.2 remote-as 2
no auto-summary
!
!
end
R2:
!
hostname R2
!
interface Loopback100
ip address 10.10.10.10 255.255.255.255
!
interface FastEthernet0/0
ip address 192.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 77
no synchronization
bgp log-neighbor-changes
network 10.10.10.10 mask 255.255.255.255
neighbor 192.1.1.1 remote-as 1
neighbor 192.1.1.1 local-as 2
no auto-summary
!
!
end
R1 Output:
R1# show ip bgp
BGP table version is 2, local router ID is 192.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.10.10.10/32 192.1.1.2 0 0 2 77 i
******************************************************************************
Now change R2-
neighbor 192.1.1.1 local-as 2 no-prepend replace-as
******************************************************************************
R1 Output:
R1# show ip bgp
BGP table version is 6, local router ID is 192.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.10.10.10/32 192.1.1.2 0 0 2 i
R1#
HTH,
On Wed, Jul 20, 2011 at 2:42 PM, Vladimir Osipenko <tiffolk_at_gmail.com>wrote:
> And can you replace AS number with any other AS number?
>
> On 20 July 2011 16:49, Persio Pucci <persio_at_gmail.com> wrote:
> > right on the money!
> >
> > worst part is now that you have mentioned I remember I have even used
> that
> > command before... :/
> >
> > tks again :)
> >
> > On Wed, Jul 20, 2011 at 9:34 AM, Daniel Dib <daniel.dib_at_reaper.nu>
> wrote:
> >
> >> On on, jul 20, 2011 at 14:19:43, Persio Pucci wrote:
> >> > Subject: Removing public ASN from path
> >> >
> >> > Hi folks,
> >> >
> >> > I have a connection to a financial service where they will only allow
> >> > to receive routes from the private ASN (e.g. 65000) they have assigned
> >> > me. My problem is that I am generating these routes from one router
> >> > that is already running my public ASN (e.g. 100). I am using "neighbor
> >> > local-as 65000" to establish connection to the financial service, but
> >> > they are dropping my routes because they have the AS_PATH as "100
> >> > 65000". I need them to go as "65000" only.
> >> >
> >> > Is there anyway to force IOS send this particular route as if it was
> >> > generated by the ASN I am *pretending* to be on the "local-as"
> command?
> >> > I have tried aggregate-address but it does not seems to help here.
> >> >
> >> > Persio
> >>
> >> Hi Persio,
> >>
> >> Try using the replace-as command. Neighbor x.x.x.x local-as 65000
> >> replace-as. You can find the documentation for this @
> >>
> >>
> http://www.cisco.com/en/US/partner/docs/ios/iproute_bgp/command/reference/ir
> >> g_bgp3.html#wp1107625
> >>
> >> HTH
> >>
> >> Daniel
> >
> >
> > Blogs and organic groups at http://www.ccie.net
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Wed Jul 20 2011 - 15:22:08 ART
This archive was generated by hypermail 2.2.0 : Mon Aug 01 2011 - 06:30:06 ART