sorry forget to add even though it says in the doccd it is to be a standard
access-list, and the example shows using a wildcard mask in the standard
numbered list:
Examples
The following example shows how to originate a default route (0.0.0.0/0)
over a certain interface when 172.17.0.0/16 is present. In this example a
route map condition is applied.
router rip
version 2
network 172.17.16.0
default-information originate route-map condition
!
route-map condition permit 10
match ip address 10
set interface s1/0
!
access-list 10 permit 172.17.16.0 0.0.0.255
"The route map referenced in the *default-information originate* command
cannot use an extended access list; it can use a standard access list."
http://www.cisco.com/en/US/docs/ios/iproute_rip/command/reference/irr_rip.html#wp1025768
--
Garry L. Baker
"With sufficient thrust, pigs fly just fine..." - RFC 1925
On Thu, Jul 14, 2011 at 12:59 PM, garry baker <baker.garry_at_gmail.com> wrote:
> try extended instead to match the subnet:
> ip access-list extended rip-default-condition
> permit ip 172.10.124.128 0.0.0.127 any
>
> R2#sh ip access-lists
> Extended IP access list rip-default-condition
> 10 permit ip 172.10.124.128 0.0.0.127 any (7 matches)
>
> R2#sh ip route 172.10.124.128
> Routing entry for 172.10.124.128/25
> Known via "ospf 1", distance 110, metric 11, type intra area
> Last update from 12.12.12.1 on FastEthernet0/0, 00:05:04 ago
> Routing Descriptor Blocks:
> * 12.12.12.1, from 172.10.124.129, 00:05:04 ago, via FastEthernet0/0
> Route metric is 11, traffic share count is 1
>
> R3#
> *Mar 1 00:15:13.763: RT: NET-RED 0.0.0.0/0
>
> R3#sh ip rip data
> 0.0.0.0/0 auto-summary
> 0.0.0.0/0
> [1] via 23.23.23.2, 00:00:13, FastEthernet0/1
> 23.0.0.0/8 auto-summary
> 23.23.23.0/24 directly connected, FastEthernet0/1
>
> R3#sh ip route
> Gateway of last resort is 23.23.23.2 to network 0.0.0.0
> 23.0.0.0/24 is subnetted, 1 subnets
> C 23.23.23.0 is directly connected, FastEthernet0/1
> R* 0.0.0.0/0 [120/1] via 23.23.23.2, 00:00:14, FastEthernet0/1
>
>
> NETWORK SETUP FOR TEST ABOVE:
>
> en
> conf t
> host R1
> int f0/0
> ip add 12.12.12.1 255.255.255.0
> no shut
> int loop 172
> ip add 172.10.124.129 255.255.255.128
> router ospf 1
> network 0.0.0.0 0.0.0.0 area 0
>
> en
> conf t
> host R2
> int f0/0
> ip add 12.12.12.2 255.255.255.0
> no shut
> int f0/1
> ip add 23.23.23.2 255.255.255.0
> no shut
> router ospf 1
> network 12.12.12.2 0.0.0.0 area 0
> router rip
> ver 2
> network 23.23.23.2
>
> default-information originate route-map rip-default-condition
> ip access-list extended rip-default-condition
> permit ip 172.10.124.128 0.0.0.127 any
> route-map rip-default-condition permit 10
> match ip address rip-default-condition
>
>
> en
> conf t
> host R3
> int f0/1
> ip add 23.23.23.3 255.255.255.0
> no shut
> router rip
> ver 2
> network 23.23.23.3
> --
> Garry L. Baker
>
> "With sufficient thrust, pigs fly just fine..." - RFC 1925
>
>
>
> On Wed, Jul 13, 2011 at 11:32 PM, marc edwards <renorider_at_gmail.com>wrote:
>
>> Hello experts:
>> So the concept makes plenty of sense. Only advertise a default route
>> if this prefix is int he routing table. I have R5 receiving routes via
>> redistribution (most specifically a 172.10.124.0/25 prefix) this
>> should fufill the condition to advertise onto switch 2 but not seeing
>> it happen see below configurations:
>>
>> R5
>>
>>
>> router rip
>> version 2
>> passive-interface default
>> no passive-interface FastEthernet0/0.20
>> network 172.10.0.0
>> default-information originate route-map rip-default-condition
>> no auto-summary
>> --
>> ip access-list standard rip-default-condition
>> permit 172.10.124.128
>> --
>> route-map rip-default-condition permit 10
>> match ip address rip-default-condition
>>
>> R5#sh ip route
>> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
>> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>> E1 - OSPF external type 1, E2 - OSPF external type 2
>> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
>> level-2
>> ia - IS-IS inter area, * - candidate default, U - per-user static
>> route
>> o - ODR, P - periodic downloaded static route
>>
>> Gateway of last resort is not set
>>
>> 1.0.0.0/24 is subnetted, 1 subnets
>> O E2 1.1.1.0 [110/20] via 172.10.35.3, 00:06:46, FastEthernet0/0.30
>> 4.0.0.0/24 is subnetted, 1 subnets
>> O E2 4.4.4.0 [110/20] via 172.10.35.3, 00:06:46, FastEthernet0/0.30
>> 172.10.0.0/16 is variably subnetted, 18 subnets, 5 masks
>> ---- route exists---
>> O E2 172.10.124.128/25
>> [110/20] via 172.10.35.3, 00:06:46, FastEthernet0/0.30
>> --------------------------
>> C 172.10.35.0/24 is directly connected, FastEthernet0/0.30
>> O E2 172.10.32.0/24 [110/20] via 172.10.35.3, 00:06:46,
>> FastEthernet0/0.30
>> O E2 172.10.43.0/24 [110/20] via 172.10.35.3, 00:06:47,
>> FastEthernet0/0.30
>> O E2 172.10.23.0/24 [110/20] via 172.10.35.3, 00:06:47,
>> FastEthernet0/0.30
>> O E2 172.10.102.0/24 [110/20] via 172.10.35.3, 00:06:47,
>> FastEthernet0/0.30
>> O E2 172.10.103.0/24 [110/20] via 172.10.35.3, 00:06:47,
>> FastEthernet0/0.30
>> O E2 172.10.101.0/24 [110/20] via 172.10.35.3, 00:06:48,
>> FastEthernet0/0.30
>> O IA 172.10.106.0/24 [110/2] via 172.10.65.6, 01:10:50,
>> FastEthernet0/0.20
>> O E2 172.10.104.0/24 [110/20] via 172.10.35.3, 00:06:48,
>> FastEthernet0/0.30
>> C 172.10.105.0/24 is directly connected, Loopback105
>> R 172.10.120.0/24 [120/1] via 172.10.65.10, 00:00:01,
>> FastEthernet0/0.20
>> O E2 172.10.25.96/30 [110/20] via 172.10.35.3, 00:06:48,
>> FastEthernet0/0.30
>> O 172.10.65.6/32 [110/1] via 172.10.65.6, 01:15:16,
>> FastEthernet0/0.20
>> O E2 172.10.25.92/30 [110/20] via 172.10.35.3, 00:06:48,
>> FastEthernet0/0.30
>> C 172.10.65.0/24 is directly connected, FastEthernet0/0.20
>> O E2 172.10.25.88/30 [110/20] via 172.10.35.3, 00:06:48,
>> FastEthernet0/0.30
>> O E2 172.10.25.64/26 [110/20] via 172.10.35.3, 00:06:48,
>> FastEthernet0/0.30
>>
>> ----I have a match in my access list---
>>
>> R5#sh access-lists
>> Standard IP access list rip-default-condition
>> 10 permit 172.10.124.128 (1 match)
>>
>>
>> SW2
>>
>>
>> router rip
>> version 2
>> passive-interface default
>> no passive-interface Vlan20
>> network 172.10.0.0
>> no auto-summary
>>
>>
>>
>> SW2#sh ip route
>> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
>> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>> E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
>> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
>> level-2
>> ia - IS-IS inter area, * - candidate default, U - per-user static
>> route
>> o - ODR, P - periodic downloaded static route
>>
>> Gateway of last resort is not set
>>
>> 172.10.0.0/24 is subnetted, 4 subnets
>> R 172.10.35.0 [120/1] via 172.10.65.5, 00:00:06, Vlan20
>> R 172.10.105.0 [120/1] via 172.10.65.5, 00:00:06, Vlan20
>> C 172.10.120.0 is directly connected, Loopback120
>> C 172.10.65.0 is directly connected, Vlan20
>> SW2#
>>
>> Thanks for the input.
>>
>> Marc Edwards
>> http://cisco-voyage.blogspot.com
>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Thu Jul 14 2011 - 13:06:12 ART
This archive was generated by hypermail 2.2.0 : Mon Aug 01 2011 - 06:30:05 ART