Hi All,
I am labbing up a sham-link to prefer MPLS path over backdoor OSPF route.
The lab set-up is simple as below:
R5 -> R4 (RR) -> R6
I am creating a sham-link from R5 to R6, so I followed the below steps:
1. Create loopback 200 on both routers and assign to vrf
R5
interface Loopback200
ip vrf forwarding VPN_A
ip address 1.1.1.1 255.255.255.255
R6
interface Loopback200
ip vrf forwarding VPN_A
ip address 2.2.2.2 255.255.255.255
2. Advertise /32 loopback other than OSPF, so advertised via BGP
R5
router bgp 100
address-family ipv4 vrf VPN_A
network 1.1.1.1 mask 255.255.255.255
R6
router bgp 100
address-family ipv4 vrf VPN_A
network 2.2.2.2 mask 255.255.255.255
3. create sham-link
R5
router ospf 10 vrf VPN_A
area 1 sham-link 1.1.1.1 2.2.2.2 cost 1
R6
router ospf 10 vrf VPN_A
area 1 sham-link 2.2.2.2 1.1.1.1 cost 1
Once I enabled sham-link command, the link starts to flaps. The OSPF_SL
interface comes up and than within seconds it shows Interface down or
detached. Please see full configuration as below with error messages
R5
interface Loopback200
ip vrf forwarding VPN_A
ip address 1.1.1.1 255.255.255.255
router ospf 10 vrf VPN_A
log-adjacency-changes
redistribute bgp 100 subnets tag 667
network 155.1.58.5 0.0.0.0 area 1
area 1 sham-link 1.1.1.1 2.2.2.2 cost 1
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 150.1.4.4 remote-as 100
neighbor 150.1.4.4 update-source Loopback0
!
address-family vpnv4
neighbor 150.1.4.4 activate
neighbor 150.1.4.4 send-community extended
exit-address-family
address-family ipv4 vrf VPN_A
redistribute connected
redistribute static
redistribute ospf 10 vrf VPN_A
no synchronization
network 1.1.1.1 mask 255.255.255.255
exit-address-family
R6
interface Loopback200
ip vrf forwarding VPN_A
ip address 2.2.2.2 255.255.255.255
router ospf 10 vrf VPN_A
log-adjacency-changes
summary-address 172.16.0.0 255.255.0.0
redistribute bgp 100 subnets tag 666
network 155.1.67.6 0.0.0.0 area 1
area 1 sham-link 2.2.2.2 1.1.1.1 cost 1
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 150.1.4.4 remote-as 100
neighbor 150.1.4.4 update-source Loopback0
!
address-family vpnv4
neighbor 150.1.4.4 activate
neighbor 150.1.4.4 send-community extended
exit-address-family
address-family ipv4 vrf VPN_A
redistribute connected
redistribute static
redistribute ospf 10 vrf VPN_A
no synchronization
network 2.2.2.2 mask 255.255.255.255
exit-address-family
Mar 1 00:56:20.951: %OSPF-5-ADJCHG: Process 10, Nbr 172.16.5.5 on OSPF_SL0
from LOADING to FULL, Loading Done
*Mar 1 00:56:22.103: %OSPF-5-ADJCHG: Process 10, Nbr 172.16.5.5 on OSPF_SL0
from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar 1 00:56:40.835: %OSPF-5-ADJCHG: Process 10, Nbr 172.16.5.5 on OSPF_SL0
from LOADING to FULL, Loading Done
*Mar 1 00:56:42.099: %OSPF-5-ADJCHG: Process 10, Nbr 172.16.5.5 on OSPF_SL0
from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar 1 00:57:01.427: %OSPF-5-ADJCHG: Process 10, Nbr 172.16.5.5 on OSPF_SL0
from LOADING to FULL, Loading Done
*Mar 1 00:57:02.103: %OSPF-5-ADJCHG: Process 10, Nbr 172.16.5.5 on OSPF_SL0
from FULL to DOWN, Neighbor Down: Interface down or detached
Blogs and organic groups at http://www.ccie.net
Received on Fri Jul 01 2011 - 21:53:53 ART
This archive was generated by hypermail 2.2.0 : Mon Aug 01 2011 - 06:30:05 ART