Re: OSPF quiz

From: Marko Milivojevic <markom_at_ipexpert.com>
Date: Tue, 31 May 2011 12:30:47 -0700

OK, let me continue with my teasing then.

Here is the setup I have:

R2 and R4 are "borders" and R5 is the branch office. Here is the configuration:

R2:
interface GigabitEthernet0/0
 ip address 192.168.24.2 255.255.255.0
!
interface Serial0/2/0
 ip address 192.168.25.2 255.255.255.0
!
ip route 192.168.42.0 255.255.255.0 192.168.24.254
!
router ospf 1
 redistribute static subnets route-map STA-to-OSP
 network 192.168.25.0 0.0.0.255 area 0
!
route-map STA-to-OSP permit 10
 set metric 20
 set metric-type type-1
!

R4:
interface FastEthernet0/0
 ip address 192.168.24.4 255.255.255.0
!
interface Serial0/1/0
 ip address 192.168.45.4 255.255.255.0
!
ip route 192.168.42.0 255.255.255.0 192.168.24.254
!
router ospf 1
 redistribute static subnets route-map STA-to-OSP
 network 192.168.45.0 0.0.0.255 area 0
!
route-map STA-to-OSP permit 10
 set metric 40
 set metric-type type-1
!

R5:
interface Serial0/0/0
 ip address 192.168.45.5 255.255.255.0
!
interface Serial0/2/0
 ip address 192.168.25.5 255.255.255.0
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
!

So, the result is as follows:

R5#sh ip ro ospf
O E1 192.168.42.0/24 [110/84] via 192.168.25.2, 01:22:13, Serial0/2/0

Now, let me change ... just one thing on R2 and R4:

R2 and R4:
router ospf 1
 network 192.168.24.0 0.0.0.255 area 0
!

R5:

R5#sh ip ro os
O E1 192.168.42.0/24 [110/85] via 192.168.45.4, 00:00:01, Serial0/0/0
                     [110/85] via 192.168.25.2, 00:00:01, Serial0/2/0
O 192.168.24.0/24 [110/65] via 192.168.45.4, 00:31:14, Serial0/0/0
                     [110/65] via 192.168.25.2, 00:26:27, Serial0/2/0

How's that for fun? [ and trust me, this is just the beginning of it all :-) ]

--
Marko Milivojevic - CCIE #18427
Senior Technical Instructor - IPexpert
FREE CCIE training: http://bit.ly/vLecture
Mailto: markom_at_ipexpert.com
Telephone: +1.810.326.1444
Web: http://www.ipexpert.com/
On Tue, May 31, 2011 at 12:18, Joe Astorino <joeastorino1982_at_gmail.com> wrote:
> Now you are just being a tease ;) I will be labbing this today if I get time!
>
>
> Sent from my Verizon Wireless BlackBerry
>
> Regards,
>
> Joe Astorino
> CCIE #24347
>
> "He not busy being born is busy dying" - Dylan
>
> -----Original Message-----
> From: Marko Milivojevic <markom_at_ipexpert.com>
> Sender: nobody_at_groupstudy.com
> Date: Tue, 31 May 2011 12:05:47
> To: Scott Morris<swm_at_emanon.com>
> Reply-To: Marko Milivojevic <markom_at_ipexpert.com>
> Cc: <ccielab_at_groupstudy.com>
> Subject: Re: OSPF quiz
>
> Oh B ... and what I found just blew me away, I must admit. I haven't
> had so much fun rediscovering something in a long time.
>
> Carlos - THANK YOU for the entertainment this morning! :-)
>
> --
> Marko Milivojevic - CCIE #18427
> Senior Technical Instructor - IPexpert
>
> FREE CCIE training: http://bit.ly/vLecture
>
> Mailto: markom_at_ipexpert.com
> Telephone: +1.810.326.1444
> Web: http://www.ipexpert.com/
>
> On Tue, May 31, 2011 at 11:48, Scott Morris <swm_at_emanon.com> wrote:
>> You went all "What if..." and had to lab it up, didn't you? B B ;)
>> That's so CCIE.... B heheheheh
>>
>>
>>
>>
>> *Scott Morris*, CCIE/x4/ (R&S/ISP-Dial/Security/Service Provider) #4713,
>>
>> CCDE #2009::D, JNCIE-M #153, JNCIE-ER #102, CISSP, et al.
>>
>> CCSI #21903, JNCI-M, JNCI-ER
>>
>> swm_at_emanon.com
>>
>>
>> Knowledge is power.
>>
>> Power corrupts.
>>
>> Study hard and be Eeeeviiiil......
>>
>>
>> On 5/31/11 2:43 PM, Marko Milivojevic wrote:
>>> I concur and I cheated and have the lab proof of it all ;-)
>>>
>>> --
>>> Marko Milivojevic - CCIE #18427
>>> Senior Technical Instructor - IPexpert
>>>
>>> FREE CCIE training: http://bit.ly/vLecture
>>>
>>> Mailto: markom_at_ipexpert.com
>>> Telephone: +1.810.326.1444
>>> Web: http://www.ipexpert.com/
>>>
>>> On Tue, May 31, 2011 at 11:37, Joe Astorino <joeastorino1982_at_gmail.com> wrote:
>>>> Agreed.B B Unless there is something I am missing, the E1 route from B1 would
>>>> be the preferred route and only OSPF route in the routing table on the
>>>> branch router. The Q stated that B1 redistributed in with a metric of 20 and
>>>> B2 redistributed in with a metric of 50.B B Unless there is some "ip ospf
>>>> cost" happening on the inbound links of the branch router, that should be
>>>> the answer at first glance
>>>
>>> Blogs and organic groups at http://www.ccie.net
>>>
>>> _______________________________________________________________________
>>> Subscription information may be found at:
>>> http://www.groupstudy.com/list/CCIELab.html
>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Tue May 31 2011 - 12:30:47 ART

This archive was generated by hypermail 2.2.0 : Wed Jun 01 2011 - 09:01:12 ART