does this setup match your scenario, in my configs R1 being the branch
router and B1 and B2 having HSRP configured and 200.200.200.0 being your X
network:
en
conf t
host B1
int s0/0
ip add 1.1.1.1 255.255.255.0
no shut
ip address 100.100.100.1 255.255.255.0
standby 1 ip 100.100.100.254
no shut
router ospf 1
log-adjacency-changes
redistribute static metric 20 metric-type 1 subnets
network 0.0.0.0 255.255.255.255 area 0
ip route 200.200.200.0 255.255.255.0 100.100.100.100
en
conf t
host B2
int s0/0
ip add 2.2.2.1 255.255.255.0
no shut
interface FastEthernet0/0
ip address 100.100.100.2 255.255.255.0
standby 1 ip 100.100.100.254
no shut
router ospf 1
log-adjacency-changes
redistribute static metric 50 metric-type 1 subnets
network 0.0.0.0 255.255.255.255 area 0
ip route 200.200.200.0 255.255.255.0 100.100.100.100
en
conf t
host R1
int s0/0
ip add 1.1.1.2 255.255.255.0
no shut
int s0/1
ip add 2.2.2.2 255.255.255.0
no shut
router ospf 1
network 0.0.0.0 0.0.0.0 area 0
--
Garry L. Baker
"With sufficient thrust, pigs fly just fine..." - RFC 1925
On Tue, May 31, 2011 at 9:26 PM, Carlos G Mendioroz <tron_at_huapi.ba.ar>wrote:
> :)
> That after having worked some time, I had the idea that you would receive 1
> such route. It surprised me, and I guess I'm not the only one
> that is going to be surprised.
>
> In fact, your response takes for granted that the two borders are
> adjacent, something that is not given as data, nor implied by
> "OSPF single area in the WAN". If they are not adyacent, then only one
> route will be present.
>
> Such a simple scenario with so many quircks motivated me to post it.
> It is also linked to another quirk with distribute list filtering,
> that you may be aware of to: for external routes, you need to "learn"
> the forwarding address too, or else the external won't pass.
> (i.e. if you put a distribute-list in just letting the E1 route,
> it won't make it to the RIB).
>
> -Carlos
>
> garry baker @ 31/05/2011 15:15 -0300 dixit:
>
>> 2 E1 routes with the metric of 20 + 'cost of wan link' to get to the
>> forwarding address of the redistributed route
>> what is the catch?
>> --
>> Garry L. Baker
>>
>> "With sufficient thrust, pigs fly just fine..." - RFC 1925
>>
>>
>>
>> On Tue, May 31, 2011 at 6:15 PM, Carlos G Mendioroz <tron_at_huapi.ba.ar<mailto:
>> tron_at_huapi.ba.ar>> wrote:
>>
>> Just wanted to share a small quiz. Try to answer w/o labbing this up.
>>
>> Topology: Central site with a firewall connected by a lan to two
>> borders (B1 and B2) using HSRP for DG (FHRP). Borders run serial
>> links to
>> branches. OSPF single area in the WAN.
>>
>> B1 and B2 have a static route to an internal network X poining to the
>> FW. B1 redidtributes X with metric 20 metric type 1. B2 does the same
>> thing with metric 50.
>>
>> At a branch,, how many routes do you see, assuming same bandwidth on
>> both serial links ?
>>
>> -- Carlos G Mendioroz <tron_at_huapi.ba.ar <mailto:tron_at_huapi.ba.ar
>> >>
>> LW7 EQI Argentina
>>
>>
>> Blogs and organic groups at http://www.ccie.net <http://www.ccie.net/>
>>
>>
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>>
>>
>>
>>
>>
>>
>>
>>
>>
> --
> Carlos G Mendioroz <tron_at_huapi.ba.ar> LW7 EQI Argentina
Blogs and organic groups at http://www.ccie.net
Received on Tue May 31 2011 - 22:04:03 ART
This archive was generated by hypermail 2.2.0 : Wed Jun 01 2011 - 09:01:12 ART