Re: IPv6 Dual Stacking question

From: Bryan Stair <uptown.ccie_at_gmail.com>
Date: Sun, 8 May 2011 11:47:56 -0400

Marko,
It's your blog from IPExpert. I am using IOU setup, but the config is
the same. I'll paste it below keeping it brief. Still not sure why she
won't ping. It must be something simple.

TOPOLOGY
ISP1---------------PE1---------P---------PE2-------------CE
                        |
ISP2---------------- |

P ROUTER

interface Loopback0
 ip address 192.168.0.3 255.255.255.255
 ip ospf network point-to-point
!
interface Ethernet0/0
 ip address 192.168.13.3 255.255.255.0
 mpls ip
!
interface Ethernet0/1
 ip address 192.168.23.3 255.255.255.0
 mpls ip
!
router ospf 1
 router-id 192.168.0.3
 log-adjacency-changes
 passive-interface Loopback0
 network 192.168.0.0 0.0.255.255 area 0
!
mpls ldp router-id Loopback0 force

PE1 ROUTER
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.255
 ip ospf network point-to-point
!
interface Ethernet0/0
 ip address 192.168.13.1 255.255.255.0
 mpls ip
!
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay lmi-type ansi
!
interface Serial2/0.1 point-to-point
 snmp trap link-status
 ipv6 address FE80::1 link-local
 ipv6 address FDA5:2072:2864:A05C::1/64
 frame-relay interface-dlci 104
!
interface Serial2/0.2 point-to-point
 snmp trap link-status
 ipv6 address FE80::1 link-local
 ipv6 address FDCD:1D34:16C6:800B::1/64
 frame-relay interface-dlci 105
!
!
router ospf 1
 log-adjacency-changes
 passive-interface Loopback0
 network 192.168.0.0 0.0.255.255 area 0
!
router bgp 65123
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 192.168.0.2 remote-as 65123
 neighbor 192.168.0.2 update-source Loopback0
 neighbor FDA5:2072:2864:A05C::11 remote-as 65001
 neighbor FDCD:1D34:16C6:800B::22 remote-as 65002
 !
 address-family ipv6
  neighbor 192.168.0.2 activate
  neighbor 192.168.0.2 next-hop-self
  neighbor 192.168.0.2 send-label
  neighbor FDA5:2072:2864:A05C::11 activate
  neighbor FDCD:1D34:16C6:800B::22 activate
  no synchronization
 exit-address-family
!
mpls ldp router-id Loopback0 force

PE2 ROUTER
!
interface Loopback0
 ip address 192.168.0.2 255.255.255.255
 ip ospf network point-to-point
!
interface Ethernet0/0
 ip address 192.168.23.2 255.255.255.0
 mpls ip
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 ipv6 address FE80::2 link-local
 ipv6 address FD41:5A1C:1A2D:3EB7::2/64
 serial restart-delay 0
 frame-relay map ipv6 FE80::6 206
 frame-relay map ipv6 FD41:5A1C:1A2D:3EB7::CE 206 broadcast
 frame-relay lmi-type ansi
!
router ospf 1
 log-adjacency-changes
 passive-interface Loopback0
 network 192.168.0.0 0.0.255.255 area 0
!
router bgp 65123
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 192.168.0.1 remote-as 65123
 neighbor 192.168.0.1 update-source Loopback0
 neighbor FD41:5A1C:1A2D:3EB7::CE remote-as 65003
 !
 address-family ipv6
  neighbor 192.168.0.1 activate
  neighbor 192.168.0.1 next-hop-self
  neighbor 192.168.0.1 send-label
  neighbor FD41:5A1C:1A2D:3EB7::CE activate
  neighbor FD41:5A1C:1A2D:3EB7::CE default-originate
  neighbor FD41:5A1C:1A2D:3EB7::CE route-map CE-out out
  no synchronization
 exit-address-family
!
mpls ldp router-id Loopback0 force

ISP1 ROUTER
!
interface Loopback6
 no ip address
 ipv6 address FDD2:D801:3D4D:3446::11/64
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 ipv6 address FE80::4 link-local
 ipv6 address FDA5:2072:2864:A05C::11/64
 serial restart-delay 0
 frame-relay map ipv6 FE80::1 401
 frame-relay map ipv6 FDA5:2072:2864:A05C::1 401 broadcast
 frame-relay lmi-type ansi
!
router bgp 65001
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor FDA5:2072:2864:A05C::1 remote-as 65123
 !
 address-family ipv6
  neighbor FDA5:2072:2864:A05C::1 activate
  network FDD2:D801:3D4D:3446::/64
  no synchronization
 exit-address-family

ISP2 ROUTER
!
interface Loopback6
 no ip address
 ipv6 address FDB7:802D:4A6F:741B::22/64
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 ipv6 address FE80::5 link-local
 ipv6 address FDCD:1D34:16C6:800B::22/64
 serial restart-delay 0
 frame-relay map ipv6 FE80::1 501
 frame-relay map ipv6 FDCD:1D34:16C6:800B::1 501 broadcast
 frame-relay lmi-type ansi
!
router bgp 65002
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor FDCD:1D34:16C6:800B::1 remote-as 65123
 !
 address-family ipv6
  neighbor FDCD:1D34:16C6:800B::1 activate
  network FDB7:802D:4A6F:741B::/64
  no synchronization
 exit-address-family

CE ROUTER
!
interface Loopback6
 no ip address
 ipv6 address FD99:8649:B59D:420C::CE/64
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 ipv6 address FE80::6 link-local
 ipv6 address FD41:5A1C:1A2D:3EB7::CE/64
 serial restart-delay 0
 frame-relay map ipv6 FE80::2 602
 frame-relay map ipv6 FD41:5A1C:1A2D:3EB7::2 602 broadcast
 frame-relay lmi-type ansi
!
router bgp 65003
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor FD41:5A1C:1A2D:3EB7::2 remote-as 65123
 !
 address-family ipv6
  neighbor FD41:5A1C:1A2D:3EB7::2 activate
  network FD99:8649:B59D:420C::/64
  no synchronization
 exit-address-family

ROUTE TABLES

CE

SH IPV6 ROUTE
IPv6 Routing Table - Default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B ::/0 [20/0]
     via FE80::2, Serial2/0
C FD41:5A1C:1A2D:3EB7::/64 [0/0]
     via Serial2/0, directly connected
L FD41:5A1C:1A2D:3EB7::CE/128 [0/0]
     via Serial2/0, receive
C FD99:8649:B59D:420C::/64 [0/0]
     via Loopback6, directly connected
L FD99:8649:B59D:420C::CE/128 [0/0]
     via Loopback6, receive
L FF00::/8 [0/0]
     via Null0, receive

ISP1 ROUTE TABLE

SH IPV6 ROUTE
IPv6 Routing Table - Default - 7 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B FD99:8649:B59D:420C::/64 [20/0]
     via FE80::1, Serial2/0
C FDA5:2072:2864:A05C::/64 [0/0]
     via Serial2/0, directly connected
L FDA5:2072:2864:A05C::11/128 [0/0]
     via Serial2/0, receive
B FDB7:802D:4A6F:741B::/64 [20/0]
     via FE80::1, Serial2/0
C FDD2:D801:3D4D:3446::/64 [0/0]
     via Loopback6, directly connected
L FDD2:D801:3D4D:3446::11/128 [0/0]
     via Loopback6, receive
L FF00::/8 [0/0]
     via Null0, receive

ISP2 ROUTE TABLE

IPv6 Routing Table - Default - 7 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B FD99:8649:B59D:420C::/64 [20/0]
     via FE80::1, Serial2/0
C FDB7:802D:4A6F:741B::/64 [0/0]
     via Loopback6, directly connected
L FDB7:802D:4A6F:741B::22/128 [0/0]
     via Loopback6, receive
C FDCD:1D34:16C6:800B::/64 [0/0]
     via Serial2/0, directly connected
L FDCD:1D34:16C6:800B::22/128 [0/0]
     via Serial2/0, receive
B FDD2:D801:3D4D:3446::/64 [20/0]
     via FE80::1, Serial2/0
L FF00::/8 [0/0]
     via Null0, receive

PE1 ROUTE TABLE

IPv6 Routing Table - Default - 8 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B FD99:8649:B59D:420C::/64 [200/0]
     via 192.168.0.2%Default-IP-Routing-Table, indirectly connected
C FDA5:2072:2864:A05C::/64 [0/0]
     via Serial2/0.1, directly connected
L FDA5:2072:2864:A05C::1/128 [0/0]
     via Serial2/0.1, receive
B FDB7:802D:4A6F:741B::/64 [20/0]
     via FE80::5, Serial2/0.2
C FDCD:1D34:16C6:800B::/64 [0/0]
     via Serial2/0.2, directly connected
L FDCD:1D34:16C6:800B::1/128 [0/0]
     via Serial2/0.2, receive
B FDD2:D801:3D4D:3446::/64 [20/0]
     via FE80::4, Serial2/0.1
L FF00::/8 [0/0]
     via Null0, receive

PE2 ROUTE TABLE

IPv6 Routing Table - Default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C FD41:5A1C:1A2D:3EB7::/64 [0/0]
     via Serial2/0, directly connected
L FD41:5A1C:1A2D:3EB7::2/128 [0/0]
     via Serial2/0, receive
B FD99:8649:B59D:420C::/64 [20/0]
     via FE80::6, Serial2/0
B FDB7:802D:4A6F:741B::/64 [200/0]
     via 192.168.0.1%Default-IP-Routing-Table, indirectly connected
B FDD2:D801:3D4D:3446::/64 [200/0]
     via 192.168.0.1%Default-IP-Routing-Table, indirectly connected
L FF00::/8 [0/0]
     via Null0, receive

On 5/7/11, Marko Milivojevic <markom_at_ipexpert.com> wrote:
> What equipment are you using? Can you please describe the topology and paste
> your configurations?
>
> --
> Marko Milivojevic - CCIE #18427
> Senior Technical Instructor - IPexpert
>
> Free CCIE Training: http://bit.ly/vLecture
>
> Mailto: markom_at_ipexpert.com
> Telephone: +1.810.326.1444
> Community: http://www.ipexpert.com/communities
>
> :: Sent from my phone. Apologies for errors and brevity. ::
>
>
> On May 7, 2011, at 16:08, Bryan Stair <uptown.ccie_at_gmail.com> wrote:
>
>> OSPF....I set it up exactly the way Marko posted it. OSPF core dual stack
>> at
>> the edge running 6PE. My home lab was already up so I used frame at the
>> edge
>> and ethernet in the core. I can see the routes in the table, but ping
>> won't
>> work. The documentation said IPv6 ICMP control message will not work. My
>> question simply is do I need to setup any type of tunnel to get it
>> working.
>>
>> On Sat, May 7, 2011 at 6:24 PM, Paul Negron <negron.paul_at_gmail.com> wrote:
>>
>>> What r u using for the core IGP?
>>>
>>> Paul
>>> --
>>> Paul Negron
>>> CCIE# 14856 CCSI# 22752
>>> Senior Technical Instructor
>>> www.micronicstraining.com
>>>
>>>
>>>
>>>> From: Bryan Stair <uptown.ccie_at_gmail.com>
>>>> Reply-To: Bryan Stair <uptown.ccie_at_gmail.com>
>>>> Date: Sat, 7 May 2011 09:12:55 -0400
>>>> To: <ccielab_at_groupstudy.com>
>>>> Subject: Fwd: IPv6 Dual Stacking question
>>>>
>>>> question never made it to the list
>>>>
>>>> ---------- Forwarded message ----------
>>>> From: Bryan Stair <uptown.ccie_at_gmail.com>
>>>> Date: Fri, May 6, 2011 at 9:57 AM
>>>> Subject: Re: IPv6 Dual Stacking question
>>>> To: Marko Milivojevic <markom_at_ipexpert.com>
>>>> Cc: Juan <fferrer10_at_gmail.com>, "ccielab_at_groupstudy.com" <
>>>> ccielab_at_groupstudy.com>
>>>>
>>>>
>>>> Marko,
>>>>
>>>> I have one question please forgive me if I seem like a novice. I read up
>>> on
>>>> the technology which I believe is 6PE, second I followed your setup
>>> scenario
>>>> posted on your blog. However I was not allowed to ping from IPv6 CE to
>>>> CE
>>> of
>>>> course it worked from PE to CE. In reading the Cisco docs one caveat was
>>>> IPv6 ICMP control message will not be passed at the edge. Is this the
>>> case
>>>> or have I missed something? One thing I failed to mentioned was I set
>>> this
>>>> up over Frame just to see what would happen.
>>>>
>>>> On Wed, Apr 27, 2011 at 6:04 AM, Marko Milivojevic <markom_at_ipexpert.com
>>>> wrote:
>>>>
>>>>> You've seen the configuration :-). Other than LSPs, are there any
>>> tunnels
>>>>> configured? :-)
>>>>>
>>>>> --
>>>>> Marko Milivojevic - CCIE #18427
>>>>> Senior Technical Instructor - IPexpert
>>>>>
>>>>> Free CCIE Training: http://bit.ly/vLecture
>>>>>
>>>>> Mailto: markom_at_ipexpert.com
>>>>> Telephone: +1.810.326.1444
>>>>> Community: http://www.ipexpert.com/communities
>>>>>
>>>>> :: Sent from my phone. Apologies for errors and brevity. ::
>>>>>
>>>>>
>>>>> On Apr 27, 2011, at 1:11, Juan <fferrer10_at_gmail.com> wrote:
>>>>>
>>>>>> Many thanks Marko...
>>>>>>
>>>>>> Anyway, i have some doubts... If you configure dual stacking at the
>>>>>> CEs
>>>>> you
>>>>> have on the ends of the ipv4....do you need to have a tunnel between
>>>>> the
>>>>> PEs
>>>>> to permit the ipv6 prefixes to pass the ipv4 core?
>>>>>>
>>>>>> Best Regards
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> 2011/4/26 Marko Milivojevic <markom_at_ipexpert.com>
>>>>>> You can use the same session with multiple address families - "ipv4
>>>>>> unicast" and "ipv6 unicast". Just to give you an example of this, you
>>>>>> can read the short blog I wrote on the subject couple of years ago:
>>>>>>
>>>>>> http://blog.ipexpert.com/2010/06/09/ipv6-in-carrier-networks/
>>>>>>
>>>>>>
>>>>>> --
>>>>>> Marko Milivojevic - CCIE #18427
>>>>>> Senior Technical Instructor - IPexpert
>>>>>>
>>>>>> FREE CCIE training: http://bit.ly/vLecture
>>>>>>
>>>>>> Mailto: markom_at_ipexpert.com
>>>>>> Telephone: +1.810.326.1444
>>>>>> Web: http://www.ipexpert.com/
>>>>>>
>>>>>> Disclaimer: Opinions expressed in this message are mine and my only
>>>>>> and not the official or unofficial opinion of, or affiliated with
>>>>>> IPexpert and its owners in any way.
>>>>>>
>>>>>>
>>>>>> On Tue, Apr 26, 2011 at 12:34, <fferrer10_at_gmail.com> wrote:
>>>>>>> Hi guys,
>>>>>>>
>>>>>>> Can you provide some help about how to pass with the same bgp session
>>>>> IPv4
>>>>> &
>>>>>>> IPv6 prefixes through an IPv4 Mpls network? I read something about
>>>>>>> the
>>>>> ipv6
>>>>>>> dual stacking capability of Cisco routers, but i am not sure if you
>>> can
>>>>> have a
>>>>>>> bgp session passing the 2 types of prefixes at the same time (suppose
>>>>> we
>>>>> need
>>>>>>> to comunicate 2 mixed environments, with ipv4 & ipv6 hosts at both
>>>>> ends)
>>>>>>>
>>>>>>> TIA and best regards.
>>>>>>>
>>>>>>>
>>>>>>> Blogs and organic groups at http://www.ccie.net
>>>>>>>
>>>>>>>
>>> _______________________________________________________________________
>>>>>>> Subscription information may be found at:
>>>>>>> http://www.groupstudy.com/list/CCIELab.html
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>> Juan Faure
>>>>>
>>>>>
>>>>> Blogs and organic groups at http://www.ccie.net
>>>>>
>>>>> _______________________________________________________________________
>>>>> Subscription information may be found at:
>>>>> http://www.groupstudy.com/list/CCIELab.html
>>>>
>>>>
>>>> Blogs and organic groups at http://www.ccie.net
>>>>
>>>> _______________________________________________________________________
>>>> Subscription information may be found at:
>>>> http://www.groupstudy.com/list/CCIELab.html
>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Sun May 08 2011 - 11:47:56 ART

This archive was generated by hypermail 2.2.0 : Wed Jun 01 2011 - 09:01:11 ART