RE: MPLS Question

From: Vishal Rane <vishal.rane_at_hotmail.co.in>
Date: Fri, 6 May 2011 20:34:59 +0530

 Hello

I attached diagram and config specific to MPLS cloud.
Experts kindly advice.

As per previous Email you can refer -
A = MA_DC1
B = MA_DC2
C = JM

MA_DC1_BB = BackBone
MA_DC1_MPLS = MPLS_EDGE_Router

MA_DC2_BB = BackBone
MA_DC2_MPLS = MPLS_EDGE_Router

JM = JM_MPLS

-----------------------------------------------------------------
hostname JM_MPLS

interface fastEthernet 0/0
description "LAN_Interface"
ip addresss 192.168.1.1 255.255.255.0

interface fastEthernet 0/1
description "To MPLS-Cloud"
ip address 172.33.185.250 255.255.255.252

router ospf 11
network 192.168.1.1 0.0.0.0 area 0
redistribute bgp 67991 subnets

router bgp 67991
no synchronization
redistribute ospf 11
neighbor 172.33.185.250 remote-as 67000

-----------------------------------------------------------------

++++++++++++++++++++++++++++++++++++++++++

hostname MA_DC1_BB

interface vlan 1
ip address 10.0.0.1 255.255.255.0

interface vlan 2
description " P-2-P to MA_DC2"
ip address 10.0.84.1 255.255.255.248

interface vlan 3
description " TO MPLS Router "
ip address 10.0.83.1 255.255.255.248
ip ospf cost 100

interface vlan 4
descrption " USERS "
ip address 172.16.16.1 255.255.255.0
ip helper-address 192.168.200.10

interface vlan 5
ip address 172.16.17.1 255.255.255.0

interface vlan 6
ip address 172.16.18.1 255.255.255.0

interface vlan 7
ip address 192.168.200.1 255.255.255.0

interface vlan 8
description " To Firewall "
ip address 10.100.200.1 255.255.255.252

router ospf 11
network 10.0.0.1 0.0.0.0 area 0
network 10.0.84.1 0.0.0.0 area 0
network 10.0.83.1 0.0.0.0 area 0
network 172.16.16.1 0.0.0.0 area 0
network 172.16.17.1 0.0.0.0 area 0
network 172.16.18.1 0.0.0.0 area 0
network 192.168.200.1 0.0.0.0 area 0
network 10.100.200.1 0.0.0.0 area 0

ip route 0.0.0.0 0.0.0.0 10.100.200.2

+++++++++++++++++++++++++++++++++++++++++++++

=========================================
hostname MA_DC1_MPLS

interface fastEthernet 0/0
description "To LAN BackBone"
ip addresss 10.0.83.2 255.255.255.248

interface fastEthernet 0/1
no shut

interface fastEthernet 0/1.226
description "To Provider MPLS Cloud"
encapsulation dot1q 226
ip address 172.33.185.226 255.255.255.252

router ospf 11
network 10.0.83.2 0.0.0.0 area 0
redistribute bgp 67991 subnets
passive-interface default
no passive interface FastEthernet 0/0

router bgp 67991
no synchronization
redistribute ospf 11 match internal external 1 external 2
neighbor 172.33.185.225 remote-as 67000
==========================================

-----------------------------------------------------------------------------
-----------------------

hostname MA_DC2_BB

interface vlan 1
ip address 10.10.10.1 255.255.255.0

interface vlan 2
description " P-2-P to MA_DC1"
ip address 10.0.84.2 255.255.255.248

interface vlan 3
description " TO MPLS Router "
ip address 10.0.85.1 255.255.255.248
ip ospf cost 100

interface vlan 4
descrption " USERS "
ip address 172.20.1.1 255.255.255.0
ip helper-address 192.168.210.10

interface vlan 5
ip address 172.20.2.1 255.255.255.0

interface vlan 6
ip address 172.20.3.1 255.255.255.0

interface vlan 7
ip address 192.168.210.1 255.255.255.0

interface vlan 8
description " To Firewall "
ip address 10.100.252.1 255.255.255.252

router ospf 11
network 10.10.10.1 0.0.0.0 area 0
network 10.0.84.2 0.0.0.0 area 0
network 10.0.85.1 0.0.0.0 area 0
network 172.20.1.1 0.0.0.0 area 0
network 172.20.2.1 0.0.0.0 area 0
network 172.20.3.1 0.0.0.0 area 0
network 192.168.210.1 0.0.0.0 area 0
network 10.100.252.1 0.0.0.0 area 0

ip route 0.0.0.0 0.0.0.0 10.100.252.2

-----------------------------------------------------------------------------
---------------------------------------

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
hostname MA_DC2_MPLS

interface fastEthernet 0/0
description "To LAN BackBone"
ip addresss 10.0.85.2 255.255.255.248

interface fastEthernet 0/1
description "To MPLS-Cloud"
ip address 172.130.58.18 255.255.255.252

router ospf 11
network 10.0.85.2 0.0.0.0 area 0
redistribute bgp 67991 subnets
passive-interface default
no passive interface FastEthernet 0/0

router bgp 67991
no synchronization
redistribute ospf 11 match internal external 1 external 2
neighbor 172.130.58.17 remote-as 67000

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

thanks

> Date: Fri, 6 May 2011 10:54:09 +0300
> Subject: Re: MPLS Question
> From: pottaharry_at_gmail.com
> To: vishal.rane_at_hotmail.co.in
> CC: ccielab_at_groupstudy.com
>
> can you put a diagram on how the routers are connected and what protocols
> used and where you do redistribution with the subnets?
>
> relevant configs on the routers will help a lot.
>
> On Thu, May 5, 2011 at 10:31 PM, Vishal Rane
<vishal.rane_at_hotmail.co.in>wrote:
>
> > Hello
> > I got this setup, facing issues after "B" got MPLS link lately. Consider
> > "A",
> > "B", "C" as different sites
> > A-------connects------------B via point-to-point as primary link and
> > backup
> > via service-provider MPLS Link.
> >
> > Point-to-Point link is terminated on BackBone_RTR and MPLS link
terminated
> > on
> > Edge_RTR.
> >
> > "C" is connected to same MPLS Cloud. Time-to-Time we notice packet drops
> > from
> > "C" reaching to "A" or "B"
> >
> > on shutting MPLS interface on "B" pointing to service provider - no
packet
> > drop noticed on "C"
> >
> > Routing protocol on LAN - "OSPF"
> > Service Provider config on MPLS-Edge Router (CE) - "BGP"
> >
> > Redistribution is performed between ospf & bgp on MPLS Edge-RTR on both
"A"
> > and "B"
> >
> >
> > Any Suggestion
> >
> >
> >
> > thanks
> > (Vishal)
> >
> >
> > Blogs and organic groups at http://www.ccie.net
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Fri May 06 2011 - 20:34:59 ART

This archive was generated by hypermail 2.2.0 : Wed Jun 01 2011 - 09:01:11 ART