EIGRPv6 Redistribution and include-connected

From: Gavin Schokman <g_schokman_at_yahoo.com.au>
Date: Tue, 15 Mar 2011 19:38:45 -0000

Hi all,
 
I've come across some strange behaviour when redistributing into and out of
EIGRPv6 with "include-connected". For some reason, EIGRP is not
redistributing the connected subnet, but it does redistribute all other
routes correctly.
 
To see the behaviour, a simple 3-router connected in a triangle demonstrates
the problem.
 
 
fa0/0.2-R1-se1/1.1 <--> se1/0.1-R5-se1/1 <--> se1/1-R4-fa0/0
 ^ ^
 +-------------------------------------------------------+
 
 
R1/R2 running OSPFv3
R2/R3 running RIPng
R3/R1 running EIGRPv6
(mutually redistribute between all of them, using "include-connected" only
all redistribution statements)
 
 
When I shut down R1's fa0/0.2, I expect to see the subnet via the path
R4-R5-R1
i.e. redist'd by R4 (EIGRPv6->RIPng) and then redist'd by R5
(RIPng->OSPFv3).
But for some reason, R4 is not redist'ing the subnet into RIPng.
 
The same problem is true in the opposite direction,
i.e. shutdown R4's fa0/0, we expect R4 to see the subnet via path R1-R5-R4,
but R1 is not redist'ing into OSPFv3.
 
This problem doesn't affect RIPng or OSPFv3. For example, I can shutdown
R5's se1/1, and R54 will learn the path via R4-R1-R5.
 
 
Any idea what is going on here with EIGRPv6 and "include-connected"?
What am I missing here because this doesn't make sense.
 
 
I've included configs below for reference.
 
 
Configs:
 
####
## R1
####
 
interface Serial1/0.1 multipoint
 snmp trap link-status
 ipv6 address FE80::1 link-local
 ipv6 address FC00:0:0:CE7D::1/64
 ipv6 ospf network point-to-multipoint
 ipv6 ospf 1 area 125
 frame-relay map ipv6 FC00:0:0:CE7D::5 105
 frame-relay map ipv6 FE80::5 105 broadcast

interface FastEthernet0/0.2
 encapsulation dot1Q 14
 ipv6 address FE80::1 link-local
 ipv6 address FC00:0:0:E0E::1/64
 ipv6 eigrp 10

 
ipv6 router eigrp 10
 eigrp neighbor FE80::4 FastEthernet0/0.2
 no shutdown
 redistribute ospf 1 metric 1 1 1 1 1500 route-map o2e include-connected
!
ipv6 router ospf 1
 router-id 150.14.1.1
 log-adjacency-changes
 area 125 virtual-link 150.14.5.5
 redistribute eigrp 10 route-map e2o include-connected
 
route-map e2o deny 10
 match tag 110
!
route-map e2o permit 20
 match tag 120
 set tag 120
!
route-map e2o permit 30
 set tag 90
!
route-map o2e deny 10
 match tag 90
!
route-map o2e permit 20
 match tag 120
 set tag 120
!
route-map o2e permit 30
 set tag 110
!

 
####
## R5
####
 
interface Serial1/0.1 multipoint
 snmp trap link-status
 ipv6 address FE80::5 link-local
 ipv6 address FC00:0:0:CE7D::5/64
 ipv6 ospf network point-to-multipoint
 ipv6 ospf 1 area 125
 frame-relay map ipv6 FC00:0:0:CE7D::1 501
 frame-relay map ipv6 FE80::1 501 broadcast

interface Serial1/1
 no ip address
 encapsulation ppp
 ipv6 address FE80::5 link-local
 ipv6 address FC00:0:0:E2D::5/64
 ipv6 rip test enable
 serial restart-delay 0

ipv6 router ospf 1
 router-id 150.14.5.5
 log-adjacency-changes
 area 125 virtual-link 150.14.1.1
 redistribute rip test route-map r2o include-connected
!
ipv6 router rip test
 redistribute ospf 1 metric 5 route-map o2r include-connected
!
!
!
route-map o2r deny 10
 match tag 120
!
route-map o2r permit 20
 match tag 90
 set tag 90
!
route-map o2r permit 30
 set tag 110
!
route-map r2o deny 10
 match tag 110
!
route-map r2o permit 20
 match tag 90
 set tag 90
!
route-map r2o permit 30
 set tag 120
!

 
 
####
## R4
####
 
interface Serial1/1
 no ip address
 encapsulation ppp
 ipv6 address FE80::4 link-local
 ipv6 address FC00:0:0:E2D::4/64
 ipv6 rip ccie enable
 serial restart-delay 0

 
interface FastEthernet0/0
 ip address 128.14.14.4 255.255.255.0
 duplex full
 speed 100
 ipv6 address FE80::4 link-local
 ipv6 address FC00:0:0:E0E::4/64
 ipv6 eigrp 10

ipv6 router eigrp 10
 eigrp neighbor FE80::1 FastEthernet0/0
 no shutdown
 redistribute rip ccie metric 1 1 1 1 1500 route-map r2e include-connected
!
ipv6 router rip ccie
 redistribute eigrp 10 metric 5 route-map e2r include-connected
!
!!
route-map r2e deny 10
 match tag 90
!
route-map r2e permit 20
 match tag 110
 set tag 110
!
route-map r2e permit 30
 set tag 120
!
route-map e2r deny 10
 match tag 120
!
route-map e2r permit 20
 match tag 110
 set tag 110
!
route-map e2r permit 30
 set tag 90
!

Blogs and organic groups at http://www.ccie.net
Received on Tue Mar 15 2011 - 19:38:45 ART

This archive was generated by hypermail 2.2.0 : Fri Apr 01 2011 - 06:35:41 ART