Re: RIPv2 Vs EIGRP Autosummarization

From: Narbik Kocharians <narbikk_at_gmail.com>
Date: Mon, 7 Mar 2011 08:45:11 -0800

I wish i had access to a rack of routers, but this is how it works, and
please lab it up and see it for your self:

R1 (F0/0 - 10.1.12.1 /24) --------------------------------------- (F0/0 -
10.1.12.2 /24) R2 (F0/1 - 10.1.23.2 /24)
------------------------------------------------ (F0/1 - 10.1.23.3 /24) R3

So what you should do is the following:
Create a loopback 0 interface on R3, and assign an ip addr of 3.3.3.3 /24--
Advertise it in RIPv2
Create a loopback 0 interface on R2, and assign an ip addr of 2.2.2.2 /24--
advertise it in RIPv2
On R2, create a loopback 99 and assign an ip addr of 99.9.9.9 /24 and
redistribute connected

So this is what it should look like:

On R1
router rip
ver 2
netw 10.0.0.0

On R2
router rip
ver 2
netw 10.0.0.0
netw 2.0.0.0
redistri connected route-map 99 metric 1

route-map 99
matc inter lo99

On R3
router rip
netw 10.0.0.0
netw 3.0.0.0
ver 2

On R1
you should see the following:
2.0.0.0 /8
3.0.0.0 /8
99.0.0.0 /8
10.1.23.0 /24 ----- because this subnet is contiguous.

Now....On R3
router rip
no au

The above change in R3's configuration will not make a difference, because
R2 will summarize it to 3.0.0.0 /8.

If you change the configuration to eigrp, things should look a little
better:

On R1
router eigrp 100
netw 10.1.12.1 0.0.0.0

On R2
router eigrp 100
netw 10.1.12.2 0.0.0.0
netw 10.1.23.2 0.0.0.0
redistr connected route-map 99 metric 1 1 1 1 1

route-map 99
match int lo99

On R3
router eigrp 100
netw 3.3.3.3 0.0.0.0
netw 10.1.23.3 0.0.0.0

You should see the following on R1:
2.0.0.0 /8
3.0.0.0 /8
99.9.9.0 /24 ---- Unlike RIPv2, Eigrp does not summarize the redistributed
routes.
10.1.23.0 /24

NOW....Let's go to R3 and do the following:

On R3
router eigrp 100
no au

On R1 you should see the following:
2.0.0.0 /8
99.9.9.0 /24
3.3.3.0 /24 --- So you see eigrp will not summarize what's advertised to it
in this case, whereas, Ripv2 will.
10.1.23.0 /24

I hope this helped.

On Mon, Mar 7, 2011 at 3:22 AM, hady tannous <hadytannous_at_hotmail.com>wrote:

> Hi Nabrik,
>
> Forget about my previous mail.
>
> It doesn't make much sense technically since that network will be
> participating in RIP and wouldn't need redistribution
>
> Back to the original question :
>
> 1- What's the difference between autosummarization on RIPv2 and EIGRP in
> case we are crossing major network or in the caseof the same major network
> but different subnet masks like the one below
>
>
> LAN 1 <----------> R1 <----- serial -----> R2 <----- serial -----> R3
> 10.10.10.1/24 10.0.12.0/30 10.0.23.0/30
>
>
>
> TIA
>
> ------------------------------
> From: hadytannous_at_hotmail.com
> To: narbikk_at_gmail.com
>
> CC: aaron1_at_gvtc.com; ccielab_at_groupstudy.com
> Subject: RE: RIPv2 Vs EIGRP Autosummarization
> Date: Mon, 7 Mar 2011 10:50:28 +0000
>
>
> Hi Nabrik,
>
> Is that while crossing major networks or the same major network but
> different subnet masks length
>
> let's say i have the following topology :
>
> LAN 1 <----------> R1 <----- serial -----> R2 <----- serial -----> R3
> 10.10.10.1/24 10.0.12.0/30 10.0.23.0/30
>
>
>
>
>
>
> If i redistribute connected on R1 into RIP. How will R3 see the routes ?
>
> Thx
>
> > Date: Sun, 6 Mar 2011 23:18:44 -0800
> > Subject: Re: RIPv2 Vs EIGRP Autosummarization
> > From: narbikk_at_gmail.com
> > To: hadytannous_at_hotmail.com
> > CC: aaron1_at_gvtc.com; ccielab_at_groupstudy.com
> >
> > Just to add to whats been said.
> > RIPv2 (With auto summary) will summarize the redistributed routes to
> their
> > major network boundary, whereas, Eigrp (With Auto summary) will NOT do
> that.
> >
> > That's if i am reading your question correcly.
> > On Sun, Mar 6, 2011 at 10:48 PM, hady tannous <hadytannous_at_hotmail.com
> >wrote:
> >
> > > Thx Aaron
> > >
> > >
> > > Does RIPv2 summarizes accross discontiguous subnet masks ?
> > >
> > >
> > > TIA
> > >
> > > > CC: ccielab_at_groupstudy.com
> > > > From: aaron1_at_gvtc.com
> > > > Subject: Re: RIPv2 Vs EIGRP Autosummarization
> > > > Date: Sun, 6 Mar 2011 21:00:47 -0600
> > > > To: hadytannous_at_hotmail.com
> > > >
> > > > One thing I know is eigrp installs summary route to null0; I don't
> think
> > > ripv2 does that.... AD difference I think is 5 and 120
> > > >
> > > > Aaron
> > > >
> > > > On Mar 6, 2011, at 2:57 AM, hady tannous <hadytannous_at_hotmail.com>
> > > wrote:
> > > >
> > > > > Hi,
> > > > >
> > > > >
> > > > > What's the difference between RIPv2 Vs EIGRP Autosummarization ?
> > > > >
> > > > >
> > > > >
> > > > > TIA
> > > > >
> > > > >
> > > > > Blogs and organic groups at http://www.ccie.net
> > > > >
> > > > >
> _______________________________________________________________________
> > > > > Subscription information may be found at:
> > > > > http://www.groupstudy.com/list/CCIELab.html
> > >
> > >
> > > Blogs and organic groups at http://www.ccie.net
> > >
> > > _______________________________________________________________________
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> >
> >
> > --
> > *Narbik Kocharians
> > *CCSI#30832, CCIE# 12410 (R&S, SP, Security)
> > www.MicronicsTraining.com <http://www.micronicstraining.com/> <
> http://www.micronicstraining.com/>
> > Sr. Technical Instructor
> > *Ask about our FREE Lab Voucher with our Boot Camps*
> > YES! We take Cisco Learning Credits!
> > Training & Remote Racks available
> >
> >
> > Blogs and organic groups at http://www.ccie.net
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> >
> >
> >
> >
> >
> >
>

-- 
*Narbik Kocharians
*CCSI#30832, CCIE# 12410 (R&S, SP, Security)
www.MicronicsTraining.com <http://www.micronicstraining.com/>
Sr. Technical Instructor
*Ask about our FREE Lab Voucher with our Boot Camps*
YES! We take Cisco Learning Credits!
Training & Remote Racks available
Blogs and organic groups at http://www.ccie.net
Received on Mon Mar 07 2011 - 08:45:11 ART

This archive was generated by hypermail 2.2.0 : Fri Apr 01 2011 - 06:35:41 ART