Re: Ip Tracking question

From: Naufal Jamal <naufalccie_at_yahoo.in>
Date: Thu, 2 Dec 2010 13:02:23 +0530 (IST)

Hi ,

WIll this delete the static route from my routing table for 2.2.2.2 when
2.2.2.2 becomes unreachable?

--- On Wed, 1/12/10, Adam Booth <adam.booth_at_gmail.com> wrote:

From: Adam Booth <adam.booth_at_gmail.com>
Subject: Re: Ip Tracking question
To: "garry baker" <baker.garry_at_gmail.com>
Cc: "Naufal Jamal" <naufalccie_at_yahoo.in>, ccielab_at_groupstudy.com
Date: Wednesday, 1 December, 2010, 9:40 PM

Perhaps something like this could help?

ip sla 1
 icmp-echo 1.1.1.2 source-interface FastEthernet0/0
 timeout 500
 frequency 3
ip sla schedule 100 life forever start-time now
!
ip route 2.2.2.2 255.255.255.255.255 1.1.1.2 track 1

It's tracking the next-hop reachability using ip sla and withdraws the route
if it cant reach the next hop.

Like Gary, I'm pretty sure that recursively tracking something isn't quite the
right idea - which is why I am tracking something that is learnt from source
(a connected route in this case)

Cheers,
Adam

On Thu, Dec 2, 2010 at 4:50 AM, garry baker <baker.garry_at_gmail.com> wrote:

your track says to install that route if you have that route, so when you

add that route it comes up and when you do not have the route it does not

install it...

see this example, i have a BGP route to 4.4.4.4/32 in my routing table and

when i add a track to track that the route is up and then i add a tracked

static route to null 0 it installs the route, because it is up via BGP:

R1#sh ip route 4.4.4.4

Routing entry for 4.4.4.4/32

  Known via "bgp 1", distance 20, metric 0

  Tag 2, type external

  Last update from 12.12.12.2 00:00:09 ago

  Routing Descriptor Blocks:

  * 12.12.12.2, from 12.12.12.2, 00:00:09 ago

      Route metric is 0, traffic share count is 1

      AS Hops 2

      Route tag 2

R1#sh track 1

Track 1

  IP route 4.4.4.4 255.255.255.255 reachability

  Reachability is Up (BGP)

    1 change, last change 00:02:59

  First-hop interface is FastEthernet0/0

R1#conf t

Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#ip route 4.4.4.4 255.255.255.255 Null0 track 1

R1(config)#do sh track 1

Track 1

  IP route 4.4.4.4 255.255.255.255 reachability

  Reachability is Up (static)

    1 change, last change 00:03:18

  First-hop interface is Null0

  Tracked by:

    STATIC-IP-ROUTING 0

R1(config)#do sh ip route 4.4.4.4

Routing entry for 4.4.4.4/32

  Known via "static", distance 1, metric 0 (connected)

  Routing Descriptor Blocks:

  * directly connected, via Null0

      Route metric is 0, traffic share count is 1

--
Garry L. Baker
"There is no 'patch' for stupidity." - www.sqlsecurity.com
On Wed, Dec 1, 2010 at 12:25 PM, Naufal Jamal <naufalccie_at_yahoo.in> wrote:
> I am trying to configure ip route tracking on a router.
>
> R1 and R2 are connected point to point. I am configuring  a track on R1
for
> reachablity for R2's loopback0  ip. I have given a static route in R1 for
> reaching loopback0 of R2. I want this static route to be disappeared from
> my
> R1 routing table when this loopback is unreachable. This is not
happeneing.
>
> R1
>
> track 1 ip route 2.2.2.2 255.255.255.255 reachability
> delay down 2 up 2
>
> interface FastEthernet0/0
> ip address 1.1.1.1 255.255.255.252
> duplex auto
> speed auto
>
> ip route 2.2.2.2 255.255.255.255 1.1.1.2 track 1
>
> ip route 2.2.2.2 255.255.255.255 1.1.1.2 (The track comes up only after
> entering this statement,Is it neccessary to add this route as well.)
>
> R2
>
> interface FastEthernet0/0
> ip address 1.1.1.2 255.255.255.252
> duplex auto
> speed auto
>
> interface loopback0
> ip address 2.2.2.2 255.255.255.255
>
> when I shut down loopback0 on R2 the track doesnt go down in R1
>
> R1(config)#do ping 2.2.2.2
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
> U.U.U
> Success rate is 0 percent (0/5)
>
> R1(config)#do sh track
> Track 1
>  IP route 2.2.2.2 255.255.255.255 reachability
>  Reachability is Up (static)
>    8 changes, last change 00:02:27
>  Delay up 2 secs, down 2 secs
>  First-hop interface is FastEthernet0/0
>  Tracked by:
>    STATIC-IP-ROUTING 0
>
> Why it is showing up when 2.2.2.2 is no more reachable
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Thu Dec 02 2010 - 13:02:23 ART

This archive was generated by hypermail 2.2.0 : Sat Jan 01 2011 - 09:37:49 ART