Re: Unable to import routes from one vrf to another vrf

From: garry baker <baker.garry_at_gmail.com>
Date: Wed, 17 Nov 2010 08:49:52 -0600

seems to work on a single router setup? can you check your rt communities to
make sure they are coming in with the markings you think they are, if they
are coming from another router?

ip vrf SITEL
 rd 10:10
 route-target export 100:100
 route-target import 200:200
!
ip vrf VXI
 rd 20:20
 route-target export 200:200
!
interface Loopback10
 ip vrf forwarding VXI
 ip address 10.10.10.1 255.255.255.255
!
interface Loopback20
 ip vrf forwarding VXI
 ip address 20.20.20.1 255.255.255.255
!
interface Loopback30
 ip vrf forwarding VXI
 ip address 30.30.30.1 255.255.255.255
!
router bgp 1
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 no auto-summary
 !
 address-family ipv4 vrf VXI
  no synchronization
  network 10.10.10.1 mask 255.255.255.255
  network 20.20.20.1 mask 255.255.255.255
  network 30.30.30.1 mask 255.255.255.255
 exit-address-family
!
ip extcommunity-list 1 permit rt 200:200
!
ip prefix-list VXI seq 5 permit 30.30.30.1/32
!
route-map VXI-SITEL permit 10
 match ip address prefix-list VXI
 match extcommunity 1

WITH import map VXI-SITEL:

Router#sh bgp vpnv4 unicast all
BGP table version is 8, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 10:10 (default for vrf SITEL)
*> 30.30.30.1/32 0.0.0.0 0 32768 i
Route Distinguisher: 20:20 (default for vrf VXI)
*> 10.10.10.1/32 0.0.0.0 0 32768 i
*> 20.20.20.1/32 0.0.0.0 0 32768 i
*> 30.30.30.1/32 0.0.0.0 0 32768 i

Router#sh ip route vrf SITEL
Routing Table: SITEL
     30.0.0.0/32 is subnetted, 1 subnets
B 30.30.30.1 is directly connected, 00:02:46, Loopback30

WITHOUT import map VXI-SITEL:

Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ip vrf SITEL
Router(config-vrf)#no import map VXI-SITEL
Router(config-vrf)#do clear bgp all 1
%BGP: No peer is configured with AS 1

Router(config-vrf)#do sh bgp vpnv4 unicast all
BGP table version is 10, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 10:10 (default for vrf SITEL)
*> 10.10.10.1/32 0.0.0.0 0 32768 i
*> 20.20.20.1/32 0.0.0.0 0 32768 i
*> 30.30.30.1/32 0.0.0.0 0 32768 i
Route Distinguisher: 20:20 (default for vrf VXI)
*> 10.10.10.1/32 0.0.0.0 0 32768 i
*> 20.20.20.1/32 0.0.0.0 0 32768 i
*> 30.30.30.1/32 0.0.0.0 0 32768 i

Router(config)#do sh ip route vrf SITEL

Routing Table: SITEL
     20.0.0.0/32 is subnetted, 1 subnets
B 20.20.20.1 is directly connected, 00:00:38, Loopback20
     10.0.0.0/32 is subnetted, 1 subnets
B 10.10.10.1 is directly connected, 00:00:38, Loopback10
     30.0.0.0/32 is subnetted, 1 subnets
B 30.30.30.1 is directly connected, 00:04:56, Loopback30

--
Garry L. Baker
"There is no 'patch' for stupidity." - www.sqlsecurity.com
On Tue, Nov 16, 2010 at 6:54 PM, Naufal Jamal <naufalccie_at_yahoo.in> wrote:
> Hi,
>
> I am trying to import a specific subnet 30.30.30.1/32 subnet routes from
> VXI
> to SITEL VRF.
> I am able to import all the routes from VXI to SITEL but unable to import
> specific one route.
>
> Can any one look into the below config and help out please?
>
> ip vrf SITEL
>  rd 10:10
>  import map VXI-SITEL
>  route-target export 100:100
>  route-target import 200:200
> !
> ip vrf VXI
>  rd 20:20
>  route-target export 200:200
>
>
> ip extcommunity-list 1 permit rt 200:200
>
> ip prefix-list VXI seq 5 permit 30.30.30.1/32
> !
> !
> !
> route-map VXI-SITEL permit 10
>  match ip address prefix-list VXI
>  match extcommunity 1
>
>
>
> MDCXRC#sh ip bgp vpnv4 vrf SITEL
> BGP table version is 43, local router ID is 1.1.1.1
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal,
>              r RIB-failure, S Stale
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
>   Network          Next Hop            Metric LocPrf Weight Path
> Route Distinguisher: 10:10 (default for vrf SITEL)
> *> 20.20.20.1/32    1.1.1.2                  0             0 200 i
>
>
> MDCXRC#sh ip bgp vpnv4 vrf VXI
> BGP table version is 43, local router ID is 1.1.1.1
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal,
>              r RIB-failure, S Stale
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
>   Network          Next Hop            Metric LocPrf Weight Path
> Route Distinguisher: 20:20 (default for vrf VXI)
> *> 10.10.10.1/32    2.2.2.2                  0             0 200 i
> *> 30.30.30.1/32    2.2.2.2                  0             0 200 i
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Wed Nov 17 2010 - 08:49:52 ART

This archive was generated by hypermail 2.2.0 : Sun Dec 05 2010 - 22:14:56 ART