I have two routers R1 and R2 connected over f0/0
R1 has one vrf TEST which f0/0 is part of and R2 has no vrf.
The eigrp is up between R1 and R2 on the vrf TEST
R1 has a loopback interface, I want R2 to reach that loopback through the vrf
TEST
I advertised it in eigrp. I dont want loopback to be part of any VRF.
Here is my config
R1
ip vrf TEST
rd 10:10
import ipv4 unicast map TEST
route-target import 10:101
interface FastEthernet0/0
ip vrf forwarding TEST
ip address 1.1.1.2 255.255.255.0
duplex auto
speed auto
interface Loopback1
ip address 3.3.3.3 255.255.255.0
router eigrp 1965
no auto-summary
!
address-family ipv4 vrf TEST
redistribute connected
network 1.1.1.2 0.0.0.0
network 3.3.3.3 0.0.0.0
auto-summary
autonomous-system 1965
exit-address-family
access-list 20 permit 3.3.3.0 0.0.0.255
route-map TEST permit 10
match ip address 20
show ip route
R1(config-router-af)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback1
R1(config-router-af)#do sh ip route vrf TEST
Routing Table: TEST
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, FastEthernet0/0
===============================================
R2 Config
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.0
duplex auto
speed auto
router eigrp 1965
network 1.1.1.1 0.0.0.0
no auto-summary
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, FastEthernet0/0
Can anyone assist me in this config, I want to import a connected route from
global to vrf of R1's routing table table
Blogs and organic groups at http://www.ccie.net
Received on Sat Nov 13 2010 - 07:58:27 ART
This archive was generated by hypermail 2.2.0 : Sun Dec 05 2010 - 22:14:56 ART