OK i am sorry i was tired here is the Puzzle:
R1 (10.1.1.1/24 - F0/0) ----------------------------------------- (F0/0
10.1.1.2/24) R2
*R1 is configured to inject two candidate default routes:*
*On R1*
* *
*R1#Show run int lo0 | B inter*
interface Loopback0
ip address 1.1.1.1 255.0.0.0
*R1#Show run int lo1 | B inter*
interface Loopback1
ip address 2.2.2.2 255.0.0.0
*R1#Show run | Inc ip default*
ip default-network 1.0.0.0
ip default-network 2.0.0.0
*R1#Show run | s eigrp*
router eigrp 100
network 1.0.0.0
network 2.0.0.0
network 10.1.1.1 0.0.0.0
no auto-summary
*R2 sees two Candidate default routes:*
*On R2*
*R2#Show ip route eigrp*
D* 1.0.0.0/8 [90/156160] via 10.1.1.1, 00:04:37, FastEthernet0/0
D* 2.0.0.0/8 [90/156160] via 10.1.1.1, 00:04:37, FastEthernet0/0
* *
*Puzzle *
R2 should be configured to see Both (1.0.0.0/8 and 2.0.0.0/8) networks, but
it should ONLY use network 2.0.0.0 as candidate default.
* *
*Restrictions:*
R2 should have networks 1.0.0.0/8 and 2.0.0.0/8 in its routing table
reachable via R1.
DO NOT configure R1.
You should use an access-list as part of the solution on R2 to accomplish
this task.
DO NOT use another global config command on R2 besides the access-list.
DO NOT use PBR, or IP SLA.
DO NOT configure another interface on R2.
On Mon, Nov 8, 2010 at 6:52 PM, Narbik Kocharians <narbikk_at_gmail.com> wrote:
> No problems, as long as we are learning, it's cool.
>
> NOW, R2 is using network 2.0.0.0 as the candidate default correct?
>
> *Puzzle #2*
>
> Configure R2 such that it does NOT use network 2.0.0.0 as the candidate
> default.
>
> *Restrictions:*
>
> R2 should have network 2.0.0.0 in its routing table reachable via R1.
> DO NOT configure R1.
> You should use an access-list on R2.
> DO NOT use another global config command on R2 besides the access-list to
> accomplish this task.
> DO NOT use PBR, or IP SLA.
> DO NOT configure another interface on R2.
>
>
>
>
> On Mon, Nov 8, 2010 at 5:58 PM, Jay McMickle <jay.mcmickle_at_yahoo.com>wrote:
>
>> Very nicely done. I've learned something new. Thanks!
>> I guess I didn't take the statement that redistribute static to be literal
>> and a requirement, therefore, I was thinking of redist connected.
>> Thanks again!
>>
>>
>> Regards,
>> Jay McMickle- CCNP,CCSP,CCDP
>> Sent from my iPhone
>> http://mycciepursuit.wordpress.com
>>
>>
>> On Nov 8, 2010, at 6:43 PM, Narbik Kocharians <narbikk_at_gmail.com> wrote:
>>
>> OK, the answer:
>>
>>
>>
>> When configuring IP default-network you can reference a major network or
>> a subnetted network.
>>
>>
>>
>> If a major network is referenced, and the network that you are referencing
>> in the ip default-network command is advertised, it goes out as the
>> candidate default.
>>
>>
>>
>> If a subnetted network is referenced, the IOS will inject a static route
>> in your running configuration, and this was the behavior that I was
looking
>> for. BTW, the network will not be advertised as the candidate default.
>>
>>
>>
>> Therefore, the answer to the puzzle is:
>>
>>
>>
>> Ip default-network 2.2.0.0
>>
>>
>>
>> Router eigrp 100
>>
>> Redistribute static
>>
>>
>> On Mon, Nov 8, 2010 at 3:16 PM, Jay McMickle
<jay.mcmickle_at_yahoo.com>wrote:
>>
>>> The statement was that R1 MUST redist static but you CANNOT use a
>>> static route.
>>> My answer still stands.
>>> Now I guess we wait for Narbik to get back online!
>>>
>>>
>>> Regards,
>>> Jay McMickle- CCNP,CCSP,CCDP
>>> Sent from my iPhone
>>> http://mycciepursuit.wordpress.com
>>>
>>>
>>> On Nov 8, 2010, at 9:45 AM, Vladimir Michalec <
>>> vladimir.michalec_at_gmail.com> wrote:
>>>
>>> But that will rule out Narbik's point of using redistribute static -
>>> only thing I came up with is the default-network statement as well (and
it
>>> works, although like garry said the netmask will change this way).
>>>
>>> Vladimir Michalec
>>> CCNP
>>>
>>> 2010/11/8 Jay McMickle < <jay.mcmickle_at_yahoo.com>jay.mcmickle_at_yahoo.com>
>>>
>>>> I think the answer is actually redistribute connected. This will make it
>>>> an external route in eigrp (170) without any static's. I don't think
eigrp
>>>> will pickup on a layer two gateway network statement.
>>>>
>>>> Regards,
>>>> Jay McMickle- CCNP,CCSP,CCDP
>>>> Sent from my iPhone
>>>> <http://mycciepursuit.wordpress.com/>http://mycciepursuit.wordpress.com
>>>>
>>>>
>>>> On Nov 8, 2010, at 7:35 AM, garry baker < <baker.garry_at_gmail.com>
>>>> baker.garry_at_gmail.com> wrote:
>>>>
>>>> > yeah but i was/am thrown by this statement:
>>>> >
>>>> > "DO NOT configure a static route on R1"
>>>> >
>>>> > 'ip default-network' will create a static route, maybe just semantics
>>>> at
>>>> > that point, but if that is the answer, which i believe it is, should
>>>> of been
>>>> > do not use the command 'ip route' to enter a static route into the
>>>> routing
>>>> > table
>>>> >
>>>> > and i don't think the mask will be right either, maybe just another
>>>> too
>>>> > small detail, and i am over thinking it but that will advertise a
>>>> 2.0.0.0/8route
>>>> >
>>>> >
>>>> >
>>>> > --
>>>> > Garry L. Baker
>>>> >
>>>> > "There is no 'patch' for stupidity." - <http://www.sqlsecurity.com/>
>>>> www.sqlsecurity.com
>>>> >
>>>> >
>>>> > On Sun, Nov 7, 2010 at 8:50 PM, Dave Serra < <maybeedave_at_yahoo.com>
>>>> maybeedave_at_yahoo.com> wrote:
>>>> >
>>>> >> This may sound dumb but I do want to thank you for posting that. I
>>>> was
>>>> >> spinning
>>>> >> my wheels for a while with it.
>>>> >>
>>>> >> Make a small loan, Make a big
>>>> >> difference - <http://kiva.org/>Kiva.org
<http://kiva.org/><http://kiva.org/>
>>>> >>
>>>> >>
>>>> >>
>>>> >>
>>>> >> ________________________________
>>>> >> From: Sarad
>>>> >> < <tosara_at_gmail.com>tosara_at_gmail.com>
>>>> >> To: Narbik Kocharians < <narbikk_at_gmail.com>narbikk_at_gmail.com>
>>>> >> Cc: CCIE
>>>> >> Groupstudy < <ccielab_at_groupstudy.com>ccielab_at_groupstudy.com>
>>>> >> Sent: Sat, November 6, 2010 12:02:33 PM
>>>> >> Subject: Re: OT - Fridays Puzzle
>>>> >>
>>>> >> its easy....
>>>> >>
>>>> >> On R1
>>>> >>
>>>> >> ip default-network
>>>> >> 2.2.0.0
>>>> >>
>>>> >> Cheers
>>>> >> Sara
>>>> >>
>>>> >>
>>>> >>
>>>> >>
>>>> >> On Fri, Nov 5, 2010 at 9:34 PM, Narbik Kocharians
>>>> >> < <narbikk_at_gmail.com>narbikk_at_gmail.com> wrote:
>>>> >>
>>>> >>> I will be teaching for the next few weeks, so I
>>>> >> will not post any puzzle
>>>> >>> till I get back. Have fun.
>>>> >>>
>>>> >>>
>>>> >>>
>>>> >>> R1 (F0/0
>>>> >> 10.1.1.1 /24) ----------------------------------- (10.1.1.2 /24
>>>> >>> F0/0) R2
>>>> >>>
>>>> >>>
>>>> >>>
>>>> >>> The two routers are running Eigrp, let s say in AS 100.
>>>> >>>
>>>> >>>
>>>> >>>
>>>> >>> Configure
>>>> >> the following Loopback interface on R1
>>>> >>>
>>>> >>> Loopback 1 - 2.2.2.2 255.255.0.0
>>>> >>>
>>>> >>>
>>>> >>>
>>>> >>>
>>>> >>>
>>>> >>> R1 should advertise this Loopback such that R2 sees the route as an
>>>> >>> external
>>>> >>> route.
>>>> >>>
>>>> >>> R1 MUST redistribute static to make this happen.
>>>> >>>
>>>> >>>
>>>> >>>
>>>> >> DO NOT configure a static route on R1.
>>>> >>> DO NOT configure R2 at all.
>>>> >>> NO EEM,
>>>> >> NO route-maps, NO ACLs or Prefix-lists.
>>>> >>> --
>>>> >>> *Narbik Kocharians
>>>> >>>
>>>> >> *CCSI#30832, CCIE# 12410 (R&S, SP, Security)
>>>> >>>
<http://www.micronicstraining.com/>www.MicronicsTraining.com<http://www.micro
nicstraining.com/><http://www.micronicstraining.com/>
>>>> >> < <http://www.micronicstraining.com/>
>>>> http://www.micronicstraining.com/> <
>>>> >>> <http://www.micronicstraining.com/>
>>>> http://www.micronicstraining.com/>
>>>> >>>
>>>> >> Sr. Technical Instructor
>>>> >>> *Ask about our FREE Lab Voucher with our Boot
>>>> >> Camps*
>>>> >>> YES! We take Cisco Learning Credits!
>>>> >>> Training & Remote Racks
>>>> >> available
>>>> >>>
>>>> >>>
>>>> >>> Blogs and organic groups at <http://www.ccie.net/>
>>>> http://www.ccie.net
>>>> >>>
>>>> >>>
>>>> >>
>>>> _______________________________________________________________________
>>>> >>>
>>>> >> Subscription information may be found at:
>>>> >>>
>>>> >> <http://www.groupstudy.com/list/CCIELab.html>
>>>> http://www.groupstudy.com/list/CCIELab.html
>>>> >>
>>>> >>
>>>> >> Blogs and organic groups at
>>>> >> <http://www.ccie.net/>http://www.ccie.net
>>>> >>
>>>> _______________________________________________________________________
>>>> >> Subscription information may be found at:
>>>> >> <http://www.groupstudy.com/list/CCIELab.html>
>>>> http://www.groupstudy.com/list/CCIELab.html
>>>> >>
>>>> >>
>>>> >> Blogs and organic groups at <http://www.ccie.net/>
>>>> http://www.ccie.net
>>>> >>
>>>> >>
>>>> _______________________________________________________________________
>>>> >> Subscription information may be found at:
>>>> >> <http://www.groupstudy.com/list/CCIELab.html>
>>>> http://www.groupstudy.com/list/CCIELab.html
>>>> >
>>>> >
>>>> > Blogs and organic groups at <http://www.ccie.net/>http://www.ccie.net
>>>> >
>>>> >
>>>> _______________________________________________________________________
>>>> > Subscription information may be found at:
>>>> > <http://www.groupstudy.com/list/CCIELab.html>
>>>> http://www.groupstudy.com/list/CCIELab.html
>>>>
>>>>
>>>> Blogs and organic groups at <http://www.ccie.net/>http://www.ccie.net
>>>>
>>>> _______________________________________________________________________
>>>> Subscription information may be found at:
>>>> <http://www.groupstudy.com/list/CCIELab.html>
>>>> http://www.groupstudy.com/list/CCIELab.html
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>
>>
>>
>> --
>> *Narbik Kocharians
>> *CCSI#30832, CCIE# 12410 (R&S, SP, Security)
>> www.MicronicsTraining.com
<http://www.micronicstraining.com/><http://www.micronicstraining.com/>
>> Sr. Technical Instructor
>> *Ask about our FREE Lab Voucher with our Boot Camps*
>> YES! We take Cisco Learning Credits!
>> Training & Remote Racks available
>>
>>
>
>
> --
> *Narbik Kocharians
> *CCSI#30832, CCIE# 12410 (R&S, SP, Security)
> www.MicronicsTraining.com <http://www.micronicstraining.com/>
> Sr. Technical Instructor
> *Ask about our FREE Lab Voucher with our Boot Camps*
> YES! We take Cisco Learning Credits!
> Training & Remote Racks available
>
>
-- *Narbik Kocharians *CCSI#30832, CCIE# 12410 (R&S, SP, Security) www.MicronicsTraining.com <http://www.micronicstraining.com/> Sr. Technical Instructor *Ask about our FREE Lab Voucher with our Boot Camps* YES! We take Cisco Learning Credits! Training & Remote Racks available Blogs and organic groups at http://www.ccie.netReceived on Tue Nov 09 2010 - 09:53:39 ART
This archive was generated by hypermail 2.2.0 : Sun Dec 05 2010 - 22:14:55 ART