Re: MPLS TE ( Affinity)

From: Prakash Kalsaria <kalsaria.prakash_at_gmail.com>
Date: Wed, 3 Nov 2010 11:09:42 +0530

hence you have used affinity VALUE OF 0x11 AND MASK OF Ox11
AND the affinity value with a mask specified

and use that Result value of AND under physical interface
*mpls traffic-eng attribute-flags 0x11* {result of AND of two vuales 0x11
& 0x11}

             R2
         + +
     + +
R1 +
     + +
          + R3

ON R2
interface Tunnel23
 ip unnumbered Loopback1
 tunnel source 172.8.0.2
 tunnel destination 172.8.0.3
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth 5000
 *tunnel mpls traffic-eng affinity 0x11 mask 0x11*
 tunnel mpls traffic-eng path-option 1 explicit name CISCO

interface GigabitEthernet1/0
 ip address 8.8.12.2 255.255.255.0
 mpls traffic-eng tunnels
 *mpls traffic-eng attribute-flags 0x11*
 mpls ip
 no clns route-cache
 ip rsvp bandwidth 45000 5000 sub-pool 2000

ip explicit-path name CISCO enable
 next-address 8.8.12.1
 next-address 8.8.13.3

on R3
interface Tunnel23
 ip unnumbered Loopback1
 tunnel source 172.8.0.3
 tunnel destination 172.8.0.2
 tunnel mode mpls traffic-eng
 tunnel mpls traffic-eng priority 7 7
 tunnel mpls traffic-eng bandwidth 5000
 tunnel mpls traffic-eng affinity 0x11 mask 0x11
 tunnel mpls traffic-eng path-option 1 explicit name CISCO

!
interface GigabitEthernet1/0
 ip address 8.8.13.3 255.255.255.0
 negotiation auto
 mpls traffic-eng tunnels
 *mpls traffic-eng attribute-flags 0x11*
 mpls ip
 no clns route-cache
 ip rsvp bandwidth 45000 5000 sub-pool 2000
!
!
ip explicit-path name CISCO enable
 next-address 8.8.13.1
 next-address 8.8.12.2

on R1

interface GigabitEthernet1/0
 ip address 8.8.12.1 255.255.255.0
 negotiation auto
 mpls traffic-eng tunnels
 *mpls traffic-eng attribute-flags 0x11*
 mpls ip
 no clns route-cache
 ip rsvp bandwidth 45000 5000 sub-pool 2000
!
interface GigabitEthernet2/0
 ip address 8.8.13.1 255.255.255.0
 negotiation auto
 mpls traffic-eng tunnels
* mpls traffic-eng attribute-flags 0x11*
 mpls ip
 no clns route-cache
 ip rsvp bandwidth 45000 5000 sub-pool 2000

R2#sh mpls tr tun

Name: R2_t23 (Tunnel23) Destination: 172.8.0.3
  Status:
    *Admin: up Oper: up Path: valid Signalling: connected*

    path option 1, type explicit CISCO (Basis for Setup, path weight 2)

  Config Parameters:
    Bandwidth: 5000 kbps (Global) Priority: 7 7 *Affinity: 0x11/0x11
*
    Metric Type: TE (default)
    AutoRoute: disabled LockDown: disabled Loadshare: 5000 bw-based
    auto-bw: disabled

R3# sh mpls tr tun

Name: R3_t23 (Tunnel23) Destination: 172.8.0.2
  Status:
    Admin: up Oper: up Path: valid Signalling: connected

    path option 1, type explicit CISCO (Basis for Setup, path weight 2)

  Config Parameters:
    Bandwidth: 5000 kbps (Global) Priority: 7 7 Affinity: 0x11/0x11
    Metric Type: TE (default)

Regards;
PRAKASH KALSARIA
http://prakashkalsaria.wordpress.com

On Wed, Nov 3, 2010 at 10:06 AM, Gaurav Thukral <pearlgaurav_at_gmail.com>wrote:

> Hi
>
> I have done the following testing
>
> 1. Both Tunnels does not came up after shutting down the link between R8 &
> R9.
> 2. Both Tunnels does not came up increasing the metric between R8 & R9.
>
> Regards,
> Gaurav
>
> On Wed, Nov 3, 2010 at 9:54 AM, Tyson Scott <tscott_at_ipexpert.com> wrote:
>
> > Guarav,
> >
> >
> >
> > You said it is up in one direction but it shows down in both directions.
> > You have configured affinity on the path from R8 to R7 to R9 but have it
> set
> > to dynamic. The dynamic path I am assuming is more preferred directly
> > between R8 and R9.
> >
> >
> >
> > Dynamic means it is going to follow the path of your RIB. Force your RIB
> > to be less preferred for the direct connection
> >
> >
> >
> > R8 and R9
> >
> > E3/2
> >
> > isis metric 1000
> >
> > E2/0
> >
> > isis metric 1000
> >
> >
> >
> > You could also shutdown that connection to see it come up when the other
> > path becomes the preferred route in the RIB.
> >
> >
> >
> > Your next option is to configure an explicit path to force the traffic
> thru
> > R7. You could then in that case have it fail over to the other path if
> you
> > configure your affinity on both paths.
> >
> >
> >
> > Regards,
> >
> >
> >
> > Tyson Scott - CCIE #13513 R&S, Security, and SP
> >
> > Managing Partner / Sr. Instructor - IPexpert, Inc.
> >
> > Mailto: tscott_at_ipexpert.com
> >
> >
> >
> >
> >
> > *From:* Gaurav Thukral [mailto:pearlgaurav_at_gmail.com]
> > *Sent:* Wednesday, November 03, 2010 12:09 AM
> > *To:* Tyson Scott
> > *Cc:* Group study; groupstudy_at_cconlinelabs.com
> >
> > *Subject:* Re: MPLS TE ( Affinity)
> >
> >
> >
> > Hi Guys,
> >
> >
> > Please find attached the full config of all the three devices.
> >
> > R8
> >
> > mpls traffic-eng tunnels
> >
> > interface Loopback2
> > ip address 5.5.88.8 255.255.255.255
> >
> > interface Loopback0
> > ip address 5.5.8.8 255.255.255.255
> > ip router isis
> > ip pim sparse-mode
> > isis circuit-type level-2-only
> >
> >
> > interface Ethernet3/2
> > ip address 5.5.89.8 255.255.255.0
> > ip router isis
> > ip pim sparse-mode
> > full-duplex
> > mpls traffic-eng tunnels
> > tag-switching ip
> > isis circuit-type level-2-only
> > isis network point-to-point
> > ip rsvp bandwidth 100000 50000 sub-pool 20000
> >
> > interface Ethernet3/0
> > ip address 5.5.78.8 255.255.255.0
> > ip router isis
> > ip pim sparse-mode
> > full-duplex
> > mpls traffic-eng tunnels
> > mpls traffic-eng attribute-flags 0x11
> > tag-switching ip
> > isis circuit-type level-2-only
> > ip rsvp bandwidth 100000 50000 sub-pool 20000
> >
> > interface Tunnel89
> > ip unnumbered Loopback2
> > tunnel destination 5.5.99.9
> > tunnel mode mpls traffic-eng
> > tunnel mpls traffic-eng priority 7 7
> > tunnel mpls traffic-eng bandwidth sub-pool 5000
> > tunnel mpls traffic-eng affinity 0x11 mask 0x11
> > tunnel mpls traffic-eng path-option 1 dynamic
> >
> > router isis
> > net 49.0005.0000.0000.0008.00
> > is-type level-2-only
> > metric-style wide level-2
> > log-adjacency-changes
> > mpls traffic-eng router-id Loopback2
> > mpls traffic-eng level-2
> >
> > R7
> >
> > mpls traffic-eng tunnels
> >
> > interface Ethernet3/1
> > ip address 5.5.79.7 255.255.255.0
> > ip router isis
> > ip pim sparse-mode
> > full-duplex
> > mpls traffic-eng tunnels
> > tag-switching ip
> > isis circuit-type level-2-only
> > isis priority 127
> > ip rsvp bandwidth 100000 50000 sub-pool 20000
> >
> > interface Ethernet3/0
> > ip address 5.5.78.7 255.255.255.0
> > ip router isis
> > ip pim sparse-mode
> > full-duplex
> > mpls traffic-eng tunnels
> > tag-switching ip
> > isis circuit-type level-2-only
> > isis priority 127
> > ip rsvp bandwidth 100000 50000 sub-pool 20000
> >
> > router isis
> > net 49.0005.0000.0000.0007.00
> > is-type level-2-only
> > metric-style wide level-2
> > log-adjacency-changes
> > mpls traffic-eng router-id Loopback0
> > mpls traffic-eng level-2
> >
> > R9
> >
> > mpls traffic-eng tunnels
> >
> > interface Loopback0
> > ip address 5.5.9.9 255.255.255.255
> > ip router isis
> > ip pim sparse-mode
> > isis circuit-type level-2-only
> >
> > interface Loopback2
> > ip address 5.5.99.9 255.255.255.255
> >
> >
> > interface FastEthernet2/0
> > ip address 5.5.89.9 255.255.255.0
> > ip router isis
> > ip pim sparse-mode
> > duplex auto
> > speed auto
> > mpls traffic-eng tunnels
> > tag-switching ip
> > isis circuit-type level-2-only
> > isis network point-to-point
> > ip rsvp bandwidth 100000 50000 sub-pool 20000
> >
> > interface FastEthernet1/0
> > ip address 5.5.79.9 255.255.255.0
> > ip router isis
> > ip pim sparse-mode
> > duplex auto
> > speed auto
> > mpls traffic-eng tunnels
> > mpls traffic-eng attribute-flags 0x11
> > tag-switching ip
> > isis circuit-type level-2-only
> > ip rsvp bandwidth 100000 50000 sub-pool 20000
> >
> > router isis
> > net 49.0005.0000.0000.0009.00
> > is-type level-2-only
> > metric-style wide level-2
> > log-adjacency-changes
> > mpls traffic-eng router-id Loopback2
> > mpls traffic-eng level-2
> >
> > interface Tunnel98
> > ip unnumbered Loopback2
> > tunnel destination 5.5.88.8
> > tunnel mode mpls traffic-eng
> > tunnel mpls traffic-eng priority 7 7
> > tunnel mpls traffic-eng bandwidth sub-pool 5000
> > tunnel mpls traffic-eng affinity 0x11 mask 0x11
> > tunnel mpls traffic-eng path-option 1 dynamic
> >
> > BOTH TUNNELS ARE DOWN NOW.
> >
> > R9#sh mpls traffic-eng tunnels
> >
> > Name: R9_t98 (Tunnel98) Destination:
> 5.5.88.8
> > Status:
> > Admin: up Oper: down Path: not valid Signalling: Down
> > path option 1, type dynamic
> >
> > Config Parameters:
> > Bandwidth: 5000 kbps (Sub) Priority: 7 7 Affinity: 0x11/0x11
> > Metric Type: TE (default)
> > AutoRoute: disabled LockDown: disabled Loadshare: 5000
> bw-based
> > auto-bw: disabled
> >
> > History:
> > Tunnel:
> > Time since created: 1 hours, 42 minutes
> > Time since path change: 10 minutes, 1 seconds
> > Prior LSP:
> > ID: path option 1 [6]
> > Removal Trigger: configuration changed
> > Last Error: PCALC:: No path to destination, 0000.0000.0008.00
> >
> > R8#sh mpls traffic-eng tunnels
> >
> > Name: R8_t89 (Tunnel89) Destination:
> 5.5.99.9
> > Status:
> > Admin: up Oper: down Path: not valid Signalling: Down
> > path option 1, type dynamic
> >
> > Config Parameters:
> > Bandwidth: 5000 kbps (Sub) Priority: 7 7 Affinity: 0x11/0x11
> > Metric Type: TE (default)
> > AutoRoute: disabled LockDown: disabled Loadshare: 5000
> bw-based
> > auto-bw: disabled
> >
> > History:
> > Tunnel:
> > Time since created: 56 minutes, 25 seconds
> > Time since path change: 35 minutes, 40 seconds
> > Prior LSP:
> > ID: path option 1 [31]
> > Removal Trigger: configuration changed
> > Last Error: PCALC:: No path to destination, 0000.0000.0009.00
> >
> >
> > Regards,
> > Gaurav
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Wed Nov 03 2010 - 11:09:42 ART

This archive was generated by hypermail 2.2.0 : Sun Dec 05 2010 - 22:14:55 ART