Re: Multicast-Helper MAP

From: garry baker <baker.garry_at_gmail.com>
Date: Fri, 8 Oct 2010 15:11:32 -0500

i didnt really see anything wrong in your configs, maybe just double check
your multicast and unicast is working as you would expect first, and i had
never attempted this configuration before, so i did a quick lab in GNS3,
seems to work, i followed the configuration guide on the doccd:

http://www.cisco.com/en/US/customer/docs/ios/ipmulti/configuration/guide/imc_inter_mc_helper_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1056647

i changed up the addresses a little bit but followed pretty close, used
dense-mode instead of sparse mode also and use DNS as my 'broadcast' which
is forwarded by default and changed the broadcast address on my 'host' R4 to
be the local subnet, to get it to go across the multicast...

below are the debugs showing it working from what i can tell, and the
configs i used, R4 <-> R1 <-> R2 <-> R3 <-> R5 back to back with
fastethernets:

R4#ping www

Translating "www"...domain server (255.255.255.255)
*Mar 1 00:21:41.803: IP: s=126.1.22.4 (local), d=126.1.22.255
(FastEthernet0/0), len 49, sending broad/multicast
*Mar 1 00:21:41.807: UDP src=53786, dst=53
*Mar 1 00:21:44.807: IP: s=126.1.22.4 (local), d=126.1.22.255
(FastEthernet0/0), len 49, sending broad/multicast
*Mar 1 00:21:44.807: UDP src=53786, dst=53
*Mar 1 00:21:47.811: IP: s=126.1.22.4 (local), d=126.1.22.255
(FastEthernet0/0), len 49, sending broad/multicast
*Mar 1 00:21:47.811: UDP src=53786, dst=53
% Unrecognized host or address, or protocol not running.

R3(config)#
*Mar 1 00:21:42.043: IP(0): MAC sa=c401.0fc0.0001 (FastEthernet0/1)
*Mar 1 00:21:42.047: IP(0): IP tos=0x0, len=49, id=0, ttl=252, prot=17
*Mar 1 00:21:42.047: IP(0): s=126.1.22.4 (FastEthernet0/1) d=239.254.2.5
id=0, ttl=252, prot=17, len=63(49), mroute olist null
*Mar 1 00:21:44.863: IP(0): MAC sa=c401.0fc0.0001 (FastEthernet0/1)
*Mar 1 00:21:44.863: IP(0): IP tos=0x0, len=49, id=1, ttl=252, prot=17
*Mar 1 00:21:44.867: IP(0): s=126.1.22.4 (FastEthernet0/1) d=239.254.2.5
id=1, ttl=252, prot=17, len=63(49), mroute olist null
*Mar 1 00:21:47.859: IP(0): MAC sa=c401.0fc0.0001 (FastEthernet0/1)
*Mar 1 00:21:47.863: IP(0): IP tos=0x0, len=49, id=2, ttl=252, prot=17
*Mar 1 00:21:47.863: IP(0): s=126.1.22.4 (FastEthernet0/1) d=239.254.2.5
id=2, ttl=252, prot=17, len=63(49), mroute olist null

R5#
*Mar 1 00:21:42.127: IP: s=126.1.22.4 (FastEthernet0/0), d=255.255.255.255,
len 49, rcvd 2
*Mar 1 00:21:42.127: UDP src=53786, dst=53
*Mar 1 00:21:44.903: IP: s=126.1.22.4 (FastEthernet0/0), d=255.255.255.255,
len 49, rcvd 2
*Mar 1 00:21:44.903: UDP src=53786, dst=53
*Mar 1 00:21:47.927: IP: s=126.1.22.4 (FastEthernet0/0), d=255.255.255.255,
len 49, rcvd 2
*Mar 1 00:21:47.931: UDP src=53786, dst=53

en
conf t
host R4
interface FastEthernet0/0
 ip address 126.1.22.4 255.255.255.0
 ip broadcast-address 126.1.22.255
no shut
ip route 0.0.0.0 0.0.0.0 126.1.22.1

en
conf t
host R1
int f0/1
ip address 126.1.22.1 255.255.255.0
 ip pim dense-mode
 ip multicast helper-map broadcast 239.254.2.5 105
access-list 105 permit udp host 126.1.22.4 host 126.1.22.255 eq domain

int f0/0
ip add 10.12.12.1 255.255.255.0
ip pim dense-mode

en
conf t
host R2
int f0/0
ip add 10.12.12.2 255.255.255.0
no shut
ip pim dense-mode
int f0/1
ip add 126.1.26.2 255.255.255.0
no shut
ip pim dense-mode
router ospf 1
network 10.12.12.2 0.0.0.0 area 0
network 126.1.26.2 0.0.0.0 area 0

en
conf t
host R3
int f0/0
 ip address 126.1.28.1 255.255.255.0
 ip directed-broadcast
access-list 105 permit udp host 126.1.22.4 any eq 53
int f0/1
 ip address 126.1.26.1 255.255.255.0
 ip pim dense-mode
 ip multicast helper-map 239.254.2.5 126.1.28.255 105

en
conf t
host R5
int f0/0
ip add 126.1.28.5 255.255.255.0
no shut
ip route 0.0.0.0 0.0.0.0 126.1.28.1

--
Garry L. Baker
"There is no 'patch' for stupidity." - www.sqlsecurity.com
On Fri, Oct 8, 2010 at 9:43 AM, Jack Router <pan.router_at_gmail.com> wrote:
> I would suggest to allow all in access list or eliminate it to make sure
> that everything else is OK. If it works you can narrow requirements with
> access lists. This method worked for me.
>
> -----Original Message-----
> From: nobody_at_groupstudy.com [mailto:nobody_at_groupstudy.com] On Behalf Of
> masroor ali
> Sent: 8-Oct-10 06:14
> To: mohmmad imran
> Cc: Cisco certification
> Subject: Re: Multicast-Helper MAP
>
> hi,
>
> R3---F0/0.34-------R4---F0/0.14---------R1----F0/0.12-------R2
>
> R4 and R1 is running multicast, R3 and R2 is running RIP ver 1
>
> same happening to me, R2 is not receiving Rip updates generated by R3,
> please help!!!!
>
> configuration is given below.
>
> R1
> interface FastEthernet0/0.14
>  encapsulation dot1Q 14
>  ip address 10.14.14.1 255.255.255.0
>  ip pim dense-mode
>  ip multicast helper-map 224.1.1.1 10.12.12.255 101
> ip forward-protocol udp rip
> !
> access-list 101 permit udp any any eq rip log
>
> interface FastEthernet0/0.12
>  encapsulation dot1Q 12
>  ip address 10.12.12.1 255.255.255.0
>  ip directed-broadcast
>  ip pim dense-mode
>
> R4
> interface FastEthernet0/0.34
>  encapsulation dot1Q 34
>  ip address 10.34.34.4 255.255.255.0
>  ip pim dense-mode
>  ip multicast helper-map broadcast 224.1.1.1 101 ttl 4
> !
> access-list 101 permit udp any any eq rip log
>
>
>
> On Thu, Oct 7, 2010 at 10:15 PM, mohmmad imran
> <imran_mohmmad_at_yahoo.com>wrote:
>
> > Hi Experts,
> >
> > I am trying to understand Mutlicast-helper map:-
> >
> > Fa0/0--R3--S0/1-----S0/0--R5--S0/1-------S0/0--R2--Fa0/0
> >
> > Pim is enabled on between serial interface along with R2 Fa0/0.
> > R2 Fa0/0 has joined a IGMP group 224.1.1.1
> > I can ping it from R3
> >
> >
> > Host Connected to R3 Fa0/0 supports only broadcast, if I want to use UDP
> > port 2000 to support receive and send multicast traffic what can we do.
> >
> > I tried to break it flow wise:-
> >
> > 1)destination as Broadcast from R3 Fa0/0 connected hosts: -
> > 2)destination as multicast from R2 Fa0/0 connected hosts: -
> >
> > for case 1:-
> > we can Convert the broadcast traffic into multicast on R3 ingress
> interface
> > (fa0/0) and then convert it into back to Multicast on R2 (Ingress
> interface
> > Se0/0).
> >
> > R3#
> > Int fa 0/0
> >  ip address 192.168.3.3 255.255.255.0
> >  ip multicast helper-map broadcast 224.1.1.1 100
> > !
> > ip forward-protocol udp 2000
> > access-list 100 permit udp any any eq 2000
> >
> > R2#
> > Int se0/0
> > En ppp
> > Ip address 192.168.5.2 255.255.255.252
> > Ip pim sparse-mode
> > ip multicast helper-map 224.1.2.3 173.20.18.255 100
> > !
> > ip forward-protocol udp 2000
> > access-list 100 permit udp any any eq 2000
> >
> > int fa 0/0
> > ip directed-broadcast
> >
> > From above the config broadcast traffic send by host will be delivered to
> > Host connected on R2 Fa0/0 as broadcast.
> >
> > I am not able to figure out what can be done to take the multicast
> traffic
> > from R2 connected host and delivered it as broadcast to R3 connected
> hosts.
> >
> > Please let me know if its possible, if yes how can I configure that.
> >
> >
> > - Imran
> >
> >
> > Blogs and organic groups at http://www.ccie.net
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> >
> >
> >
> >
> >
> >
> >
>
>
> --
> Regards,
> Masroor Ali
> P Please don't print this e-mail unless you really need to.
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Fri Oct 08 2010 - 15:11:32 ART

This archive was generated by hypermail 2.2.0 : Mon Nov 01 2010 - 06:42:05 ART