Policy Based VRF selection

From: Edward John <edwardjohn2020_at_googlemail.com>
Date: Mon, 13 Sep 2010 01:27:40 +0300

Hi,

Can we use Policy based VRF selection for any MPLS VPN solution in the lab?

I am doing INE-SP lab 8, section 5.10, VPN Internet Access.
I did this part using the method of VRF selection, but solution guide is
shown with route-map and filtering.
I thought VRF selection method will be the best practice one!!!

Following is my config...
!
ip vrf AS200
 rd 100:200
 route-target export 10.1.6.6:200
 route-target import 10.1.7.7:200
 route-target import 10.1.8.8:200
 route-target import 158.1.3.3:54
!
ip vrf INTERNET
 rd 158.1.3.3:54
 route-target export 158.1.3.3:54
 route-target import 158.1.3.3:100
 route-target import 158.1.4.4:100
 route-target import 10.1.6.6:200
 route-target import 10.1.7.7:200
 route-target import 10.1.8.8:200
 route-target import 158.1.5.5:100
 route-target import 158.1.1.1:300

!
!
interface Ethernet0/0
 ip vrf receive AS200
 ip vrf receive INTERNET
 ip address 204.12.1.3 255.255.255.0
 ip policy route-map VRF-SELECTION
 full-duplex
!

router bgp 100
!
 address-family ipv4 vrf INTERNET
 neighbor 204.12.1.254 remote-as 54
 neighbor 204.12.1.254 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf AS200
 neighbor 204.12.1.6 remote-as 200
 neighbor 204.12.1.6 activate
 neighbor 204.12.1.6 route-map MED-OUT out
 no auto-summary
 no synchronization
 exit-address-family
!
ip access-list standard FROM-R6
 permit 10.1.6.6
 permit 204.12.1.6
 permit 200.0.0.0 0.0.3.255
 permit 54.1.1.0 0.0.0.255
!

route-map MED-OUT permit 10
 match ip address prefix-list R8
!
route-map MED-OUT permit 20
 set metric 1000
!
route-map VRF-SELECTION permit 10
 match ip address FROM-R6
 set vrf AS200
!
route-map VRF-SELECTION permit 20
 set vrf INTERNET
!
!

I verified that all my VPN are working and also internet. I couldn't find
any demerit in this?

-- 
*Regards,*
*John*
Blogs and organic groups at http://www.ccie.net
Received on Mon Sep 13 2010 - 01:27:40 ART

This archive was generated by hypermail 2.2.0 : Fri Oct 01 2010 - 05:58:05 ART