Re: bgp soo and route-maps

From: Piotr Malarski <piotr.malarski.99_at_gmail.com>
Date: Fri, 10 Sep 2010 14:01:28 -0400

They show in R5. For clarity I did remove interfaces not directly
related to soo question. L0 on R1 is up now and advertising 1.0.0.0.
Expended diagram looks like this:

R1(CE)-------R3(PE)----MPLS_CLOUD----R4(PE)=====R5(CE)
AS65015 AS65001 AS65001 AS65015

R1 advertises 1.0.0.0
R5 advertises 5.0.0.0

Following BGP tables in R1 and R5 are OK. There is NO routing loop on
R5. My concern is that there should be a routing loop in R5. There is
no yet route-map on R4 that prevents routes coming from R5 to be
adverised back to R5.

R1 BGP table:
R1#sh ip bgp | b Network
   Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 0.0.0.0 0 32768 i
*> 5.0.0.0 10.1.13.3 0 65001 65015 i

R5 BGP table:
R5#sh ip bgp | b Network
   Network Next Hop Metric LocPrf Weight Path
*> 1.0.0.0 10.1.45.4 0 65001 65015 i
* 10.1.100.4 0 65001 65015 i
*> 5.0.0.0 0.0.0.0 0 32768 i

>>>>>> Full BGP R4 config:
router bgp 65001
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 3.3.3.3 remote-as 65001
 neighbor 3.3.3.3 update-source Loopback0
 !
 address-family ipv4
  neighbor 3.3.3.3 activate
  no auto-summary
  no synchronization
 exit-address-family
 !
 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community both
  neighbor 3.3.3.3 next-hop-self
 exit-address-family
 !
 address-family ipv4 vrf CB
  neighbor 10.1.45.5 remote-as 65015
  neighbor 10.1.45.5 activate
  neighbor 10.1.45.5 route-map SOO-IN in
  neighbor 10.1.100.5 remote-as 65015
  neighbor 10.1.100.5 activate
  neighbor 10.1.100.5 route-map SOO-IN in
  no synchronization
 exit-address-family

route-map SOO-IN permit 10
 set extcommunity soo 1:100

>>>>>> Full BGP R5 config:
router bgp 65015
 no synchronization
 bgp log-neighbor-changes
 network 5.0.0.0
 neighbor 10.1.45.4 remote-as 65001
 neighbor 10.1.45.4 allowas-in
 neighbor 10.1.100.4 remote-as 65001
 neighbor 10.1.100.4 allowas-in
 no auto-summary

On Fri, Sep 10, 2010 at 12:57 PM, Narbik Kocharians <narbikk_at_gmail.com> wrote:
> What happened to prefixes coming from R1?
>
> On Fri, Sep 10, 2010 at 9:54 AM, Piotr Malarski
> <piotr.malarski.99_at_gmail.com> wrote:
>>
>> Hello,
>>
>> I need a clarification about bgp soo. In the example below R4 and R5
>> are connected with two links 10.1.45.0/24 and 10.1.100.0/24:
>>
>> R4 (PE)===========R5 (CE)
>> AS65001 AS6015
>>
>> R5 (CE) advertises network 5.0.0.0.
>> The problem is that R5 (CE) receives it's own route redistributed back
>> from R4:
>> R5#
>> R5#sh ip bgp | b Network
>> Network Next Hop Metric LocPrf Weight Path
>> * 5.0.0.0 10.1.100.4 0 65001 65001 i
>> *> 0.0.0.0 0 32768 i
>> R5#
>>
>> To remediate, SOO is configured on R4:
>>
>> 1. Route-map is configured:
>>
>> route-map SOO-IN permit 10
>> set extcommunity soo 1:100
>>
>> 2. Route map is applied:
>>
>> router bgp 65001
>> !
>> address-family ipv4 vrf CB
>> neighbor 10.1.45.5 route-map SOO-IN in
>> neighbor 10.1.100.5 route-map SOO-IN in
>>
>> AT THIS POINT the problem is solved. R5 does not contain it's own
>> route back from R4:
>>
>> R5#sh ip bgp | b Network
>> Network Next Hop Metric LocPrf Weight Path
>> *> 5.0.0.0 0.0.0.0 0 32768 i
>>
>> HOWEVER the workbook goes extra few steps and confiures additional
>> filtering on PE OUT to CE:
>>
>> ip extcommunity-list 1 permit soo 1:105
>> route-map SOO-OUT deny 10
>> match extcommunity 1
>> route-map SOO-OUT permit 99
>> !
>> router bgp 65001
>> !
>> address-family ipv4 vrf CB
>> neighbor 10.1.45.5 route-map SOO-OUT out
>> neighbor 10.1.100.5 route-map SOO-OUT out
>>
>> My question is why second route-map OUT is configured on PE. It looks
>> like only marking on PE incoming routes with ext community soo works
>> OK.
>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>>
>>
>>
>>
>>
>>
>>
>
>
>
> --
> Narbik Kocharians
> CCSI#30832, CCIE# 12410 (R&S, SP, Security)
> www.MicronicsTraining.com
> Sr. Technical Instructor
> YES! We take Cisco Learning Credits!
> Training And Remote Racks available

Blogs and organic groups at http://www.ccie.net
Received on Fri Sep 10 2010 - 14:01:28 ART

This archive was generated by hypermail 2.2.0 : Fri Oct 01 2010 - 05:58:05 ART