On the DocCD, check out the Creating User-Defined Event Triggers section of the
Configuring Auto Smartports Macros chapter in the 3750 config guide...
Switch(config)# shell trigger MP_EVENT mediaplayer
Switch(config)# macro auto execute MP_EVENT {
if [[ $LINKUP -eq YES ]]; then
conf t
interface $INTERFACE
macro description $TRIGGER
switchport access vlan 1
switchport mode access
switchport port-security
switchport port-security maximum 1
switchport port-security violation restrict
switchport port-security aging time 2
switchport port-security aging type inactivity
spanning-tree portfast
spanning-tree bpduguard enable
exit
fi
if [[ $LINKUP -eq NO ]]; then
conf t
interface $INTERFACE
no macro description $TRIGGER
no switchport access vlan 1
if [[ $AUTH_ENABLED -eq NO ]]; then
no switchport mode access
fi
no switchport port-security
no switchport port-security maximum 1
no switchport port-security violation restrict
no switchport port-security aging time 2
no switchport port-security aging type inactivity
no spanning-tree portfast
no spanning-tree bpduguard enable
exit
fi
}
Switch(config)# end
On Thu, Aug 12, 2010 at 3:55 PM, Grammer, Christopher
<cgrammer_at_essilorusa.com> wrote:
>
> I am using 3750s to study with, but I can not find a way to use the "macro
> name" to create a macro.
>
> SW1(config)#macro ?
> auto Macro autoexecution settings
> global Enter global macro configuration
>
> I seem to be missing something or the feature is not available.
> I checked CCO, but 3750 macro guide does not show anything special to enable
> the macro creation feature.
>
> show ver
> ...
> System image file is "flash:/c3750-ipservicesk9-mz.122-53.SE2.bin"
> cisco WS-C3750-48P (PowerPC405) processor (revision L0) with 131072K bytes
> of memory.
> ...
>
> I found a few forums on google discussing the problem, but no answer to
> resolve the problem.
>
>
> I have 1 3550 running a few revisions older IOS and the "macro name" command
> works fine.
>
> thanks in advance,
>
> Chris
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Thu Aug 12 2010 - 16:04:59 ART
This archive was generated by hypermail 2.2.0 : Wed Sep 01 2010 - 11:20:52 ART