Re: FRoMPLS Query

From: Adam Booth <adam.booth_at_gmail.com>
Date: Tue, 10 Aug 2010 18:20:46 +1000

Hi Nagendra,

1) Both the CE and PE can have the physical interface type as either DTE or
DCE since this is layer 1, though the general rule is that the SP device
(Frame Switch) should be the DCE
2) Since you have a Frame-Relay Switch and you probably have a UNI (User
Network Interface) facing both the CE and PE routers, both routers would
have a frame-relay intf-type of dte
3) Your pseudowires need to have the same VC-ID at each endpoint (the VC-ID
is of point-to-point signficance between PEs)

I have a config below that I put together which I think mimics what you were
describing. CE1 PVC 101 is crossconnected to CE2 PVC 202 between the PE
routers.

CE1----F1----PE1====PE2---F2---CE2

###Router CE1
hostname CE1
interface Serial2/1
 description To F1 S2/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial2/1.101 point-to-point
 ip address 192.168.1.1 255.255.255.252
 cdp enable
 frame-relay interface-dlci 101
!

###Frame Switch F1 as implemented on a router
hostname F1
frame-relay switching
interface Serial2/1
 description CE1 S2/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 128000
 frame-relay intf-type dce
 frame-relay route 101 interface Serial2/2 101
!
interface Serial2/2
 description PE1 S2/2
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 128000
 frame-relay intf-type dce
 frame-relay route 101 interface Serial2/1 101
!

###PE1 performing FR transport over MPLS
hostname PE1
mpls label protocol ldp
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.100.1 255.255.255.252
 duplex auto
 speed auto
 mpls ip
!
interface Serial2/2
 description To F1 S2/2
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 192.168.100.0 0.0.0.255 area 0
!
connect FRoMPLS Serial2/2 101 l2transport
 xconnect 2.2.2.2 1 encapsulation mpls
 !
!

###PE2 performing FR transport over MPLS
hostname PE2
mpls label protocol ldp
interface Loopback1
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.100.2 255.255.255.252
 duplex auto
 speed auto
 mpls ip
!
interface Serial2/2
 description To F2 S2/2
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 192.168.100.0 0.0.0.255 area 0
!
connect FRoMPLS Serial2/2 202 l2transport
 xconnect 1.1.1.1 1 encapsulation mpls
 !
!

###Frame Switch F2 as implemented on a router
hostname F2
frame-relay switching
interface Serial2/1
 description CE2 S2/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 128000
 frame-relay intf-type dce
 frame-relay route 202 interface Serial2/2 202
!
interface Serial2/2
 description PE2 S2/2
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 128000
 frame-relay intf-type dce
 frame-relay route 202 interface Serial2/1 202
!

###Router CE2
hostname CE2
interface Serial2/1
 description To F2 S2/1
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
!
interface Serial2/1.202 point-to-point
 ip address 192.168.1.2 255.255.255.252
 cdp enable
 frame-relay interface-dlci 202
!

PE1#show xconnect all
Legend: XC ST=Xconnect State, S1=Segment1 State, S2=Segment2 State
UP=Up, DN=Down, AD=Admin Down, IA=Inactive, NH=No Hardware
XC ST Segment 1 S1 Segment
2 S2
------+---------------------------------+--+---------------------------------+--
UP ac Se2/2:101(FR DLCI) UP mpls 2.2.2.2:1
UP

PE2#sh xconnect all
Legend: XC ST=Xconnect State, S1=Segment1 State, S2=Segment2 State
UP=Up, DN=Down, AD=Admin Down, IA=Inactive, NH=No Hardware
XC ST Segment 1 S1 Segment
2 S2
------+---------------------------------+--+---------------------------------+--
UP ac Se2/2:202(FR DLCI) UP mpls 1.1.1.1:1
UP

F1#show frame-relay pvc 101 | inc STATUS
DLCI = 101, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE =
Serial2/1
DLCI = 101, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE =
Serial2/2

F2#sh frame-relay pvc 202 | inc STATUS
DLCI = 202, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE =
Serial2/1
DLCI = 202, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE =
Serial2/2

CE1#sh cdp ne
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID
CE2 Ser 2/1.101 125 R 7206VXR Ser
2/1.202

CE1#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/17/28 ms

Below is the dynamips .net file for the topology

autostart = false
ghostios = true

[localhost]
        workingdir = /home/adam/cisco/work_lab1
        [[7200]]
                image =
/opt/ios/unzipped/c7200-adventerprisek9-mz.124-24.T.bin
                npe = npe-225
                ram = 160
                idlepc = 0x6307ad74
                disk0 = 128

        [[ROUTER CE1]]
                model = 7200
                console = 2001
                slot0 = PA-C7200-IO-2FE
                slot2 = PA-4T
                s2/1 = F1 s2/1

        [[ROUTER PE1]]
                model = 7200
                console = 2002
                slot0 = PA-C7200-IO-2FE
                slot2 = PA-4T
                f0/0 = PE2 f0/0
                s2/2 = F1 s2/2

        [[ROUTER PE2]]
                model = 7200
                console = 2003
                slot0 = PA-C7200-IO-2FE
                slot2 = PA-4T
                s2/2 = F2 s2/2

        [[ROUTER CE2]]
                model = 7200
                console = 2004
                slot0 = PA-C7200-IO-2FE
                slot2 = PA-4T
                s2/1 = F2 s2/1

        [[ROUTER F1]]
                model = 7200
                console = 2005
                slot0 = PA-C7200-IO-2FE
                slot2 = PA-4T

        [[ROUTER F2]]
                model = 7200
                console = 2006
                slot0 = PA-C7200-IO-2FE
                slot2 = PA-4T

I hope that's of some help.

Cheers,
Adam

On Tue, Aug 10, 2010 at 4:17 PM, NN Kumar <nagendra.cisco_at_gmail.com> wrote:

> Hi,
>
> Can someone please let me know the way to configure FRoMPLS with FR switch
> between PE and CE?.
>
> When PE-CE is back to back connected thru serial intf, we can enable
> frame-relay switching on PE and make the intf as DCE. But when we have
> frame-relay switch in between PE and CE, we cannot change the intf as DCE
> on
> PE.
>
> I tried making the intf as DTE and configure "frame-relay interface-dlci <>
> switched" and then configure layer2 connect, But the VC is still down.
>
> I am sure, I am missing something here to bring the VC up. Can someone
> please point me what I am missing?. Any pointers will be of great help.
>
>
> Regards,
> Nagendra
>
>
> On Mon, Aug 9, 2010 at 8:02 PM, NN Kumar <nagendra.cisco_at_gmail.com> wrote:
>
> > Hi,
> >
> > Can someone please point me the config required @ PE side when there is
> > frame-relay switch between PE and CE as below,
> >
> >
> > CE1-----FRSW-----PE1-----P------PE2----FRSW-----CE2
> >
> >
> > Regards,
> > Nagendra
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Tue Aug 10 2010 - 18:20:46 ART

This archive was generated by hypermail 2.2.0 : Wed Sep 01 2010 - 11:20:52 ART