Re: Doubts in IP Unnumbered!!!

From: Narbik Kocharians <narbikk_at_gmail.com>
Date: Fri, 6 Aug 2010 11:24:18 -0700

Sorry for the long post, the following shows the configuration of IP
unnumbered for RIPv2, Eigrp and OSPF; i think this will give you what you
were asking to start with. You will see that the behavior does NOT change
between the routing protocols as long as we have a P2P connection and we are
running PPP:

*Topology:*

R4 (S0/1) -------------------------------- (S0/1) R5

*IP addresses:*
**

On R4

Lo0 = 4.4.4.4 /8

Lo1 = 200.1.1.4 /24

On R5

Lo0 = 5.5.5.5 /8

*The S0/1 interface of both routers are configured with IP unnumbered Lo0*

Now lets see the entire configuration:

*On R4*

*interface Loopback0*

* ip address 4.4.4.4 255.0.0.0*

!

interface Loopback1

 ip address 200.1.1.4 255.255.255.0

!

interface Serial0/1

 ip unnumbered Loopback0

 encapsulation ppp

 clock rate 64000

!

router rip

 version 2

 network 4.0.0.0

 network 200.1.1.0

 no auto-summary

*On R5*

*interface Loopback0*

* ip address 5.5.5.5 255.0.0.0*

!

interface Serial0/1

 ip unnumbered Loopback0

 encapsulation ppp

!

router rip

 version 2

 network 5.0.0.0

 no auto-summary

*Lets check RIPv2s behavior:*

* *

*On R5*

*R5#Show ip route rip*

     4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

R 4.0.0.0/8 [120/1] via 4.4.4.4, 00:00:04, Serial0/1

R 200.1.1.0/24 [120/1] via 4.4.4.4, 00:00:04, Serial0/1

*To test the configuration:*

* *

*On R5*

* *

*R5#**Ping** 200.1.1.4*

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 200.1.1.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms

*R5#**Ping** 4.4.4.4*

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms

* So you see when the ip unnumbered command is used the sanity check is
bypassed. Regardless of what IP addressing you assign to the Loopback 0
interfaces.*

*Now lets see Eigrps behavior:*

*On Both Routers:*

Rx(config)#*no router rip*

*Lets configure Eigrp:*

*On R4*

R4(config)#Router Eigrp 100

R4(config-router)#no au

R4(config-router)#Net 200.1.1.4 0.0.0.0

R4(config-router)#Net 4.4.4.4 0.0.0.0

*On R5*

R5(config)#Router Eigrp 100

R5(config-router)#No au

R5(config-router)#Netw 5.5.5.5 0.0.0.0

*You should see the following console messages:*

*%DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 4.4.4.4 (Serial0/1) is up: new
adjacency*

*To test the configuration:*

* *

*On R5*

*R5#Show ip route eigrp*

     4.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D 4.0.0.0/8 [90/2297856] via 4.4.4.4, 00:01:23, Serial0/1

D 200.1.1.0/24 [90/2297856] via 4.4.4.4, 00:01:23, Serial0/1

*R5#**Ping** 200.1.1.4*

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 200.1.1.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms

*R5#**Ping** 4.4.4.4*

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms

*Lets check OSPFs behavior:*

*On Both Routers:*

Rx(config)#*NO Router Eigrp 100*

* *

* *

*To configure OSPF:*

* *

*On R5*

R5(config)#Router ospf 1

R5(config-router)#Netw 5.5.5.5 0.0.0.0 area 0

*On R4*

R4(config)#Router ospf 1

R4(config-router)#Netw 200.1.1.4 0.0.0.0 area 0

R4(config-router)#Netw 4.4.4.4 0.0.0.0 area 0

*You should see the following console message:*

*%OSPF-5-ADJCHG: Process 1, Nbr 5.5.5.5 on Serial0/1 from LOADING to FULL,
Loading Done*

*To test the configuration:*

* *

*On R5*

*R5#Show ip rou ospf*

     200.1.1.0/32 is subnetted, 1 subnets

O 200.1.1.4 [110/65] via 4.4.4.4, 00:00:55, Serial0/1

*R5#**Ping** 200.1.1.4*

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 200.1.1.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms

*R5#**Ping** 4.4.4.4*

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/28 ms

I hope this helped.

On Fri, Aug 6, 2010 at 2:16 AM, sundeep sadhwani <sundeep.sadhwani_at_gmail.com
> wrote:

> Ok..
>
> Now tell us in detail what kind of information you want from us.
> The behaviour of IP Unnumbered is different for different protocols.
>
> Definiton of IP Unumbered: It is borrowing of IP from other interface of
> same router.
>
> Working of IP Unnumbered with different protocols:
>
> RIPv2 : If u use IP Unnumbered on two routers runnning RIP and borrowed IPs
> are not in same subnet you need to do switch off the sanity check. By
> default Source should be in same subnet for RIP to work.
>
> OSPF : When you use IP Unnumbered on two router running OSPF and borrowed
> IPs are not in the same subnet, Still the OSPF adjaceny comes up. This is
> due to the fact When OSPF sees the interface as IP unnumbered it will not
> send Subnet Mask information in Hellos and hence the adjaceny is up.
>
> In case of frame relay you need to use PPPoFR if the ip address borrowed
> are
> not from the same subnet Or you use a ip to DLCI mapping.
>
> I hope this clears your doubt. Also correct me if i am wrong.
>
> Regards
> Sundeep Sadhwani
> CCIE # 26228
>
> On Thu, Aug 5, 2010 at 10:55 PM, CCIE KID <eliteccie_at_gmail.com> wrote:
>
> > hey sundeep this group study is to help and not to criticise people who
> > are askin doubts
> >
> >
> > On Thu, Aug 5, 2010 at 2:43 PM, sundeep sadhwani <
> > sundeep.sadhwani_at_gmail.com> wrote:
> >
> >> Hi hemanth
> >>
> >> Why dont you try to do it practically and then let us
> >> know the outcome. I think the best way to learn anything is to try it
> >> first
> >> and only when you dont' understand you should ask. This way you will
> >> remember things for a longer time.
> >>
> >> Regards
> >> Sundeep Sadhwani
> >> CCIE # 26228 (RnS)
> >>
> >> On Thu, Aug 5, 2010 at 2:06 PM, HEMANTH RAJ <hemanthrj_at_gmail.com>
> wrote:
> >>
> >> > Hey i have sum doubts in ip unnumbered
> >> > Wat are the caveats when using ipunnumbered in FRAMRELAY and BGP
> >> >
> >> > Can anyone explain me clearly where ip unnumbered is used and how it
> >> will
> >> > act in frame relay multipoint and point to point circuits??
> >> >
> >> >
> >> >
> >> > --
> >> > Problems arise Bcoz we talk,prblms r not solve bcoz we dont talk So
> gud
> >> r
> >> > bad talk to ur affectionate one's freely
> >> >
> >> > Urs Friendly,
> >> > HP HEMANTH RAJ
> >> >
> >> >
> >> > Blogs and organic groups at http://www.ccie.net
> >> >
> >> >
> _______________________________________________________________________
> >> > Subscription information may be found at:
> >> > http://www.groupstudy.com/list/CCIELab.html
> >>
> >>
> >> Blogs and organic groups at http://www.ccie.net
> >>
> >> _______________________________________________________________________
> >> Subscription information may be found at:
> >> http://www.groupstudy.com/list/CCIELab.html
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >
> >
> > --
> > With Warmest Regards,
> >
> > CCIE KID
> > IN PURSUIT OF CCIE
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
>
>
>
>

--
Narbik Kocharians
CCSI#30832, CCIE# 12410 (R&S, SP, Security)
www.MicronicsTraining.com
Sr. Technical Instructor
YES! We take Cisco Learning Credits!
Training And Remote Racks available
Blogs and organic groups at http://www.ccie.net
Received on Fri Aug 06 2010 - 11:24:18 ART

This archive was generated by hypermail 2.2.0 : Wed Sep 01 2010 - 11:20:52 ART