Multicast Configuration

From: Garth Bryden <hacked.the.planet.on.28.8k.dialup_at_gmail.com>
Date: Mon, 2 Aug 2010 12:01:53 +0800

Hello Group,

I have encountered some strange behaviour with two of my Routers Multicast
Configuration.

I was setting up a lab to test out the MSDP scenarios in Routing TCP/IP
Volume 2, on page 619. My Topology is exactly the same except I added an
additional router onto Kong with IP Routing disabled to simulate a multicast
client.

I went to test connectivity between Kong and R5 but just as I hit enter I
remembered I did not enable PIM on that interface and therefore IGMP would
not be enabled on the interface either.. I was surprised when the ping
worked! I am not sure why it worked, I'm wondering if it is a GNS3 issue or
have I missed something.

If you dont have the above book the topology is pretty simply for this part
of the network

( Kong ) ---- ( R5 )

The link between the two devices is on the 10.1.1.0/30 subnet.

The configuration is as per the below

KONG
-----------
Kong#show run
Building configuration...
Current configuration : 1465 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Kong
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip multicast-routing
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
interface Loopback254
 ip address 10.254.254.1 255.255.255.255
 ip pim sparse-mode
!
interface FastEthernet0/0
 ip address 192.168.1.5 255.255.255.252
 speed 100
 full-duplex
!
interface FastEthernet0/1
 ip address 192.168.1.9 255.255.255.252
 speed 100
 full-duplex
!
interface FastEthernet1/0
 ip address 10.1.1.1 255.255.255.252
 speed 100
 full-duplex
!
router bgp 300
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 192.168.1.6 remote-as 100
 neighbor 192.168.1.10 remote-as 100
 !
 address-family ipv4
  neighbor 192.168.1.6 activate
  no auto-summary
  no synchronization
  network 10.1.1.0 mask 255.255.255.252
  network 10.254.254.1 mask 255.255.255.255
 exit-address-family
 !
 address-family ipv4 multicast
  neighbor 192.168.1.10 activate
  no auto-summary
  no synchronization
 exit-address-family
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
ip pim rp-address 10.254.254.1
ip msdp peer 192.168.1.10
ip msdp cache-rejected-sa 10
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end
Kong#

R5
------

R5#show run
Building configuration...
Current configuration : 778 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip cef
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.1.1.2 255.255.255.252
 no ip route-cache
 ip igmp join-group 239.0.0.1
 speed 100
 full-duplex
!
interface FastEthernet0/1
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
ip default-gateway 10.1.1.1
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

R5#
Here is the output from my testing

Kong#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.0.1.40), 00:06:25/00:02:05, RP 10.254.254.1, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback254, Forward/Sparse, 00:06:25/00:02:05
Kong#

Kong#show ip igmp interface fa1/0
FastEthernet1/0 is up, line protocol is up
  Internet address is 10.1.1.1/30
* IGMP is disabled on interface*
  Multicast routing is disabled on interface
  Multicast TTL threshold is 0
  No multicast groups joined by this system
Kong#

Kong#ping 239.0.0.1
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.0.0.1, timeout is 2 seconds:
*Reply to request 0 from 10.1.1.2, 8 ms*
Kong#

Kong#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 239.0.0.1), 00:00:05/stopped, RP 10.254.254.1, flags: SP
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list: Null
(10.254.254.1, 239.0.0.1), 00:00:05/00:02:54, flags: PTA
  Incoming interface: Loopback254, RPF nbr 0.0.0.0
* Outgoing interface list: Null*
(*, 224.0.1.40), 00:06:34/00:01:56, RP 10.254.254.1, flags: SJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback254, Forward/Sparse, 00:06:34/00:01:56
Kong#

If I enabled PIM on the interface, I get two replies from 10.1.1.2 ! I'm
confused, if a router goes to ping a multicast group does it just flood the
ICMP out all interfaces, no matter whether IGMP is enabled or not?

Cheers,

Garth

Blogs and organic groups at http://www.ccie.net
Received on Mon Aug 02 2010 - 12:01:53 ART

This archive was generated by hypermail 2.2.0 : Wed Sep 01 2010 - 11:20:52 ART