RE: Arp not getting resolved in case of Bridging over

From: Sonu Khandelwal (sokhande) <sokhande_at_cisco.com>
Date: Sun, 1 Aug 2010 20:44:52 +0530

Hi Keith,
Yes, it works. Thanks a lot for help.

BTW, to fix I had to following.

A) do a no keep on serial links of both router.
B) remove local policy from R1, which was changing next hop.
C) remove control plane policing from R2 which was dropping all control
packets.

Thanks,
Sonu

-----Original Message-----
From: Keith Barker [mailto:kbarker_at_ine.com]
Sent: Sunday, August 01, 2010 1:24 AM
To: Sonu Khandelwal (sokhande)
Cc: ccielab_at_groupstudy.com
Subject: Re: Arp not getting resolved in case of Bridging over
frame-relay

Hello Sonu -

Here is a working configuration for you.

Simply modify the interface numbers and IP addresses to protect the
innocent. :)

R1

conf t

default int ser 0/0

frame-relay switching

bridge 1 protocol ieee

int ser 0/0

no shut

no keep

clock rate 64000

encapsulation frame-relay

serial restart-delay 0

frame-relay map bridge 16 broadcast

frame-relay interface-dlci 16

frame-relay intf-type dce

bridge-group 1

exit

bridge irb

bridge 1 route ip

interface BVI1

ip address 10.0.0.1 255.0.0.0

end

R2

conf t

default int ser 0/0

frame-relay switching

bridge 1 protocol ieee

int ser 0/0

no shut

no keep

clock rate 64000

encapsulation frame-relay

serial restart-delay 0

frame-relay map bridge 16 broadcast

frame-relay interface-dlci 16

frame-relay intf-type dce

bridge-group 1

exit

bridge irb

bridge 1 route ip

interface BVI1

ip address 10.0.0.2 255.0.0.0

end

Best wishes,

Keith H. Barker, CCIE #6783
Instructor
kbarker_at_ine.com
Internetwork Expert, Inc.
http://ine.com
Toll Free: 877-224-8987
Outside US: 775-826-4344

On Jul 31, 2010, at 12:26 AM, Sonu Khandelwal (sokhande) wrote:

> Hi All,
> I have back to back connected routers like this:
>
> R1(se2/0)----(se2/0)R2
>
> I have configured bridging over frame-relay cloud. Its some how not
> working for me. When I try back to back ping for BVI interface, it
> fails. While debugging more I see that arp does not get resolved. On
> enabling debug arp I see following messages. Seems like somehow R2 is
> not getting arp reply which R1 sent.
>
> say I send ping from R2:
>
> message at R2:
>
> R2#ping 60.1.1.1
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 60.1.1.1, timeout is 2 seconds:
>
> *Jul 31 07:08:57.055: IP ARP: creating incomplete entry for IP
address:
> 60.1.1.1 interface BVI1
> *Jul 31 07:08:57.055: IP ARP: sent req src 60.1.1.2 0000.0c48.04b0,
> dst 60.1.1.1 0000.0000.0000 BVI1.
> *Jul 31 07:08:59.059: IP ARP: sent req src 60.1.1.2 0000.0c48.04b0,
> dst 60.1.1.1 0000.0000.0000 BVI1.
> *Jul 31 07:09:01.059: IP ARP: sent req src 60.1.1.2 0000.0c48.04b0,
> dst 60.1.1.1 0000.0000.0000 BVI1.
> *Jul 31 07:09:03.059: IP ARP: sent req src 60.1.1.2 0000.0c48.04b0,
> dst 60.1.1.1 0000.0000.0000 BVI1.
> *Jul 31 07:09:05.059: IP ARP: sent req src 60.1.1.2 0000.0c48.04b0,
> dst 60.1.1.1 0000.0000.0000 BVI1.
> Success rate is 0 percent (0/5)
> R2#
>
>
> Message at R1:
>
> R1#
> *Jul 31 07:08:57.211: IP ARP: rcvd req src 60.1.1.2 0000.0c48.04b0,
> dst
> 60.1.1.1 BVI1
> *Jul 31 07:08:57.211: IP ARP: creating entry for IP address: 60.1.1.2,
> hw: 0000.0c48.04b0
> *Jul 31 07:08:57.211: IP ARP: sent rep src 60.1.1.1 0000.0c31.0448,
> dst 60.1.1.2 0000.0c48.04b0 BVI1 R1# *Jul 31
> 07:08:59.211: IP ARP: rcvd req src 60.1.1.2 0000.0c48.04b0, dst
> 60.1.1.1 BVI1
> *Jul 31 07:08:59.211: IP ARP: sent rep src 60.1.1.1 0000.0c31.0448,
> dst 60.1.1.2 0000.0c48.04b0 BVI1 R1# *Jul 31
> 07:09:01.211: IP ARP: rcvd req src 60.1.1.2 0000.0c48.04b0, dst
> 60.1.1.1 BVI1
> *Jul 31 07:09:01.211: IP ARP: sent rep src 60.1.1.1 0000.0c31.0448,
> dst 60.1.1.2 0000.0c48.04b0 BVI1 R1# *Jul 31
> 07:09:03.211: IP ARP: rcvd req src 60.1.1.2 0000.0c48.04b0, dst
> 60.1.1.1 BVI1
> *Jul 31 07:09:03.211: IP ARP: sent rep src 60.1.1.1 0000.0c31.0448,
> dst 60.1.1.2 0000.0c48.04b0 BVI1 R1# *Jul 31
> 07:09:05.211: IP ARP: rcvd req src 60.1.1.2 0000.0c48.04b0, dst
> 60.1.1.1 BVI1
> *Jul 31 07:09:05.211: IP ARP: sent rep src 60.1.1.1 0000.0c31.0448,
> dst 60.1.1.2 0000.0c48.04b0 BVI1 R1#
>
>
> configs from R1:
>
> R1#sh run int se 2/0
> Building configuration...
>
> Current configuration : 233 bytes
> !
> interface Serial2/0
> no ip address
> encapsulation frame-relay
> ipv6 ospf network broadcast
> serial restart-delay 0
> frame-relay map bridge 16 broadcast
> frame-relay interface-dlci 16
> frame-relay intf-type dce
> bridge-group 1
> end
>
> R1#sh run | sec bridge
> bridge irb
> frame-relay map bridge 16 broadcast
> bridge-group 1
> bridge 1 protocol ieee
> bridge 1 route ip
> R1#
>
> R1#sh run int bv1
> Building configuration...
>
> Current configuration : 57 bytes
> !
> interface BVI1
> ip address 60.1.1.1 255.255.255.0
> end
>
> R1#
>
> configs from R2:
>
> R2#sh run int se 2/0
> Building configuration...
>
> Current configuration : 208 bytes
> !
> interface Serial2/0
> no ip address
> encapsulation frame-relay
> serial restart-delay 0
> frame-relay map bridge 16 broadcast
> frame-relay interface-dlci 16
> frame-relay interface-dlci 17
> bridge-group 1
> end
>
> R2#sh run | sec bridge
> bridge irb
> frame-relay map bridge 16 broadcast
> bridge-group 1
> bridge 1 protocol ieee
> R2#
>
> R2#sh run int bvi1
> Building configuration...
>
> Current configuration : 57 bytes
> !
> interface BVI1
> ip address 60.1.1.2 255.255.255.0
> end
>
> R2#
>
>
> Frame-relay Map:
>
> R1#sfm
> Serial2/0 (up): bridge dlci 16(0x10,0x400), static,
> broadcast,
> CISCO, status defined, active
> R1#
>
> R2#sfm
> Serial2/0 (up): bridge dlci 16(0x10,0x400), static,
> broadcast,
> CISCO, status defined, active
> R2#
>
>
> Blogs and organic groups at http://www.ccie.net
>
>
Received on Sun Aug 01 2010 - 20:44:52 ART

This archive was generated by hypermail 2.2.0 : Wed Sep 01 2010 - 11:20:51 ART