Marko
I did lab it up before posting the question but it does not work for me.
If you could take a look at my configs I would really appreciate it.
The virtual link is up on one side and down on the other.
My topology similar to yours
area0
|
R2---(area 45)---R4---(unnumbered area 45)--- R5 ---(area 45) ---R6---(area
0)
---------------------------R4
interface Loopback0
ip address 150.1.4.4 255.255.255.255
interface FastEthernet1/0
desc Conn to R2
ip address 155.1.1.4 255.255.255.0
interface Serial2/0
desc Conn to R5
ip unnumbered FastEthernet1/0
router ospf 1
router-id 4.4.4.4
area 45 virtual-link 6.6.6.6
network 150.1.4.4 0.0.0.0 area 0
network 155.1.1.4 0.0.0.0 area 45
----------------------------R5
interface Loopback0
ip address 150.1.5.5 255.255.255.255
interface FastEthernet1/1
desc Conn to R6
ip address 155.1.2.5 255.255.255.0
interface Serial2/0
desc Conn to R4
ip unnumbered FastEthernet1/1
router ospf 1
router-id 5.5.5.5
network 150.1.5.5 0.0.0.0 area 45
network 155.1.2.5 0.0.0.0 area 45
------------------------------R6
interface Loopback0
ip address 150.1.6.6 255.255.255.255
interface FastEthernet1/0
ip address 155.1.2.6 255.255.255.0
router ospf 1
router-id 6.6.6.6
area 45 virtual-link 4.4.4.4
network 150.1.6.6 0.0.0.0 area 0
network 155.1.2.6 0.0.0.0 area 45
Thanks!
On Thu, Jul 15, 2010 at 7:20 PM, Marko Milivojevic <markom_at_ipexpert.com>wrote:
> There is nothing stopping you from running virtual link with
> unnembered serial interfaces in the transit area. You can look-up if
> your virtual link works by using "show ip ospf neighbor" command.
>
> When in doubt... lab it up.
>
> R2---{area 0}---R4---{area 45, unnumbered}---R5---{area 0}---R6
>
>
> ! ------------------------------8<------------------------------
> ! R2:
> ! --------------------------------------------------------------
> interface Loopback0
> ip address 2.2.2.2 255.255.255.255
> !
> interface Serial0/1/0
> no ip address
> encapsulation frame-relay
> no frame-relay inverse-arp
> !
> interface Serial0/1/0.204 point-to-point
> ip address 24.24.24.2 255.255.255.0
> frame-relay interface-dlci 204
> !
> router ospf 1
> router-id 2.2.2.2
> log-adjacency-changes
> network 2.2.2.2 0.0.0.0 area 0
> network 24.24.24.2 0.0.0.0 area 0
> !
> ! ------------------------------8<------------------------------
> ! R4:
> ! --------------------------------------------------------------
> interface Loopback0
> ip address 4.4.4.4 255.255.255.255
> !
> interface Serial0/0/0
> no ip address
> encapsulation frame-relay
> no frame-relay inverse-arp
> !
> interface Serial0/0/0.402 point-to-point
> ip address 24.24.24.4 255.255.255.0
> frame-relay interface-dlci 402
> !
> interface Serial0/1/0
> ip unnumbered Loopback0
> !
> router ospf 1
> router-id 4.4.4.4
> log-adjacency-changes
> area 45 virtual-link 5.5.5.5
> network 4.4.4.4 0.0.0.0 area 45
> network 24.24.24.4 0.0.0.0 area 0
> !
> ! ------------------------------8<------------------------------
> ! R5:
> ! --------------------------------------------------------------
> interface Loopback0
> ip address 5.5.5.5 255.255.255.255
> !
> interface Serial0/0/0
> ip unnumbered Loopback0
> !
> interface Serial0/1/0
> no ip address
> encapsulation frame-relay
> no frame-relay inverse-arp
> !
> interface Serial0/1/0.56 point-to-point
> ip address 56.56.56.5 255.255.255.0
> frame-relay interface-dlci 506
> !
> router ospf 1
> router-id 5.5.5.5
> log-adjacency-changes
> area 45 virtual-link 4.4.4.4
> network 5.5.5.5 0.0.0.0 area 45
> network 56.56.56.5 0.0.0.0 area 0
> !
> ! ------------------------------8<------------------------------
> ! R6:
> ! --------------------------------------------------------------
> interface Loopback0
> ip address 6.6.6.6 255.255.255.255
> !
> interface Serial0/1/0
> no ip address
> encapsulation frame-relay
> no frame-relay inverse-arp
> !
> interface Serial0/1/0.56 point-to-point
> ip address 56.56.56.6 255.255.255.0
> frame-relay interface-dlci 605
> !
> router ospf 1
> router-id 6.6.6.6
> log-adjacency-changes
> network 6.6.6.6 0.0.0.0 area 0
> network 56.56.56.6 0.0.0.0 area 0
> !
> ------------------------------8<------------------------------
>
> R2#ping 6.6.6.6 source Loopback 0
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
> Packet sent with a source address of 2.2.2.2
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 24/27/28 ms
>
> R4#show ip ospf neighbor
>
> Neighbor ID Pri State Dead Time Address Interface
> 5.5.5.5 0 FULL/ - - 5.5.5.5 OSPF_VL0
> 2.2.2.2 0 FULL/ - 00:00:31 24.24.24.2
> Serial0/0/0.402
> 5.5.5.5 0 FULL/ - 00:00:34 5.5.5.5
> Serial0/1/0
>
> R5#show ip ospf neighbor
>
> Neighbor ID Pri State Dead Time Address Interface
> 4.4.4.4 0 FULL/ - - 4.4.4.4 OSPF_VL0
> 6.6.6.6 0 FULL/ - 00:00:33 56.56.56.6
> Serial0/1/0.56
> 4.4.4.4 0 FULL/ - 00:00:34 4.4.4.4
> Serial0/0/0
>
> R6#ping 2.2.2.2 source Loopback0
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
> Packet sent with a source address of 6.6.6.6
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 24/27/28 ms
>
> --
> Marko Milivojevic - CCIE #18427
> Senior Technical Instructor - IPexpert
>
> YES! We include 400 hours of REAL rack
> time with our Blended Learning Solution!
>
> Mailto: markom_at_ipexpert.com
> Telephone: +1.810.326.1444
> Fax: +1.810.454.0130
> Web: http://www.ipexpert.com/
>
> On Thu, Jul 15, 2010 at 13:43, Yaseen Mirza <yaseengs_at_gmail.com> wrote:
> > Hi
> >
> > I have been trying to run a virtual-link whilst having an unnumbered
> serial
> > link in the transit area for the VL.
> > Having read about this in more detail I have found that this is not
> actually
> > possible.
> > Can somebody please confirm this? Is there any way round this?
> >
> > Also I am in some doubt about standard virtual links. When I create a
> > virtual-link, it is created on the router-id.
> > How do we find out where the VL neighbor actually exists. e.g.
> >
> > area 1 virtual-link 1.1.1.1
> >
> > If I look in the ospf database it shows me that 1.1.1.1 is known by
> > advertising router 1.1.1.1
> > So how do I find out where 1.1.1.1 is from the ospf database?
Blogs and organic groups at http://www.ccie.net
Received on Thu Jul 15 2010 - 20:31:03 ART
This archive was generated by hypermail 2.2.0 : Sun Aug 01 2010 - 19:19:15 ART