Hi,
I modified one of Antonio's configurations to test out PBR.
As Scott mentioned you won't see a reference to using the Tunnel in
the RIB because you are using PBR. The tunnel does come up and gets a
label assigned.
On R1 I have a static route pointing to R2 for 77.77.77.77(loop1) on R7.
R2 uses PBR to forward 77.77.77.77 through the tunnel - there is no
other routing for 77.77.77.77
Actually I have a question - how else can we see this label other then
showing "sh mpls traffic-eng tunnels"?
-Rich
After a ping from R1
R2#sh route-map
route-map PBR, permit, sequence 10
Match clauses:
ip address (access-lists): 100
Set clauses:
interface Tunnel27
Policy routing matches: 15 packets, 1710 bytes
route-map PBR, permit, sequence 20
Match clauses:
Set clauses:
Policy routing matches: 0 packets, 0 bytes
R2#sh ip rou
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
34.0.0.0/24 is subnetted, 1 subnets
i L2 34.34.34.0 [115/20] via 23.23.23.3, FastEthernet1/0
1.0.0.0/32 is subnetted, 1 subnets
i L2 1.1.1.1 [115/20] via 12.12.12.1, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
i L2 3.3.3.3 [115/20] via 23.23.23.3, FastEthernet1/0
4.0.0.0/32 is subnetted, 1 subnets
i L2 4.4.4.4 [115/30] via 23.23.23.3, FastEthernet1/0
23.0.0.0/24 is subnetted, 1 subnets
C 23.23.23.0 is directly connected, FastEthernet1/0
7.0.0.0/32 is subnetted, 1 subnets
i L2 7.7.7.7 [115/40] via 23.23.23.3, FastEthernet1/0
12.0.0.0/24 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, FastEthernet0/0
47.0.0.0/24 is subnetted, 1 subnets
i L2 47.47.47.0 [115/30] via 23.23.23.3, FastEthernet1/0
R2#
R2#
R2#
R2#sh run
Building configuration...
hostname R2
!
ip cef
!
!
!
mpls traffic-eng tunnels
!
!
!
!
!
no file verify auto
!
!
!
interface Tunnel27
ip unnumbered Loopback0
tunnel destination 7.7.7.7
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng path-option 1 dynamic
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip router isis
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
ip router isis
ip policy route-map PBR
duplex half
!
interface FastEthernet1/0
ip address 23.23.23.2 255.255.255.0
ip router isis
duplex half
mpls traffic-eng tunnels
no clns route-cache
ip rsvp bandwidth
!
router isis
net 49.9999.0000.0000.0002.00
is-type level-2-only
metric-style wide
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
!
ip classless
!
no ip http server
!
!
access-list 100 permit ip any host 77.77.77.77
!
route-map PBR permit 10
match ip address 100
set interface Tunnel27
!
route-map PBR permit 20
!
!
!
control-plane
!
!
!
dial-peer cor custom
!
d
R2# sh ip ce
R2# sh ip cef 77.77.77.77
0.0.0.0/0
no route
R2#sh mpls traffic-eng tunnels
Name: R2_t27 (Tunnel27) Destination: 7.7.7.7
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type dynamic (Basis for Setup, path weight 30)
Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: disabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
InLabel : -
OutLabel : FastEthernet1/0, 17
RSVP Signalling Info:
Src 2.2.2.2, Dst 7.7.7.7, Tun_Id 27, Tun_Instance 7
RSVP Path Info:
My Address: 23.23.23.2
Explicit Route: 23.23.23.3 34.34.34.3 34.34.34.4 47.47.47.4
47.47.47.7 7.7.7.7
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
History:
Tunnel:
Time since created: 16 minutes, 22 seconds
Time since path change: 15 minutes, 33 seconds
Current LSP:
Uptime: 15 minutes, 33 seconds
LSP Tunnel R7_t27 is signalled, connection is up
InLabel : FastEthernet1/0, implicit-null
OutLabel : -
RSVP Signalling Info:
Src 7.7.7.7, Dst 2.2.2.2, Tun_Id 27, Tun_Instance 9
RSVP Path Info:
My Address: 0.0.0.0
Explicit Route: NONE
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
R2#
On Mon, May 24, 2010 at 10:27 AM, Prakash Kalsaria
<kalsaria.prakash_at_gmail.com> wrote:
> Is this scenario possilbe
>
> or not
>
> if yes please provide me the guidance and the source where can i find
> information or documentation
>
> http://prakashkalsaria.wordpress.com
>
>
>
>
> On Mon, May 24, 2010 at 7:52 PM, Prakash Kalsaria <
> kalsaria.prakash_at_gmail.com> wrote:
>
>> R2 loopback 100.2.2.2
>> R1 loopback 100.1.1.1
>>
>> For 100.2.2.2.2 {Lo of r2}
>>
>> R2# sh ip cef detail | in 100.2.2.2
>> 100.2.2.2/32, version 16, epoch 0, connected, receive
>> on R1
>> sh ip cef detail 100.2.2.2
>> its not on the table
>>
>> *do i have to configure a explicit path or not *
>> *????*
>>
>> R2#sh ip route 100.2.2.2
>> Routing entry for 100.2.2.2/32
>> Known via "connected", distance 0, metric 0 (connected, via interface)
>> Routing Descriptor Blocks:
>> * directly connected, via Loopback1
>> Route metric is 0, traffic share count is 1
>>
>> On Mon, May 24, 2010 at 7:45 PM, Scott Morris <swm_at_emanon.com> wrote:
>>
>>> If you are seeing it in your label table though the OTHER side has it in
>>> its routing table and is generating a lab (17 from Fa0/1) here. I thought
>>> by your original message that it would be further away and nobody in between
>>> had information for it.
>>>
>>> So on your local router, what does "show ip route 100.2.2.2" show? or
>>> "show ip cef detail" for that route?
>>>
>>> You appear to have an explicit path set as well which has multiple hops,
>>> so something is allowing you to access it already to set the tunnel up.
>>>
>>>
>>>
>>>
>>> Prakash Kalsaria wrote:
>>>
>>> If i dont have that loopback in my routing table , no where
>>> how do i get my tuneel UP UP , where in here this case i have my tunnel up
>>>
>>> crazzy things going on
>>>
>>>
>>> R2#sh ip int bri
>>> Interface IP-Address OK? Method
>>> Status Protocol
>>> FastEthernet0/0 12.12.12.2 YES NVRAM
>>> up up
>>> FastEthernet0/1 23.23.23.2 YES NVRAM
>>> up up
>>> Loopback0 2.2.2.2 YES NVRAM
>>> up up
>>> Loopback1 100.2.2.2 YES NVRAM
>>> up up
>>> *Tunnel12 100.2.2.2 YES TFTP
>>> up up *
>>> **
>>> R2#sh mpls traffic-eng tunnels
>>> *Name: R2_t12* (Tunnel12) Destination:
>>> 100.1.1.1
>>> Status:
>>> *Admin: up Oper: up Path: valid* Signalling:
>>> connected
>>> path option 1, type explicit 12 (Basis for Setup, path weight 20)
>>> Config Parameters:
>>> Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity:
>>> 0x0/0xFFFF
>>> Metric Type: TE (default)
>>> AutoRoute: disabled LockDown: disabled Loadshare: 0 bw-based
>>> auto-bw: disabled
>>> InLabel : -
>>> OutLabel : FastEthernet0/1, 17
>>> RSVP Signalling Info:
>>> Src 100.2.2.2, Dst 100.1.1.1, Tun_Id 12, Tun_Instance 11
>>> RSVP Path Info:
>>> My Address: 23.23.23.2
>>> Explicit Route: 23.23.23.3 13.13.13.3 13.13.13.1 100.1.1.1
>>> Record Route: NONE
>>> Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
>>> RSVP Resv Info:
>>> Record Route: NONE
>>> Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
>>> History:
>>> Tunnel:
>>> Time since created: 12 minutes, 4 seconds
>>> Time since path change: 10 minutes, 58 seconds
>>> Current LSP:
>>> Uptime: 10 minutes, 58 seconds
>>> *LSP Tunnel R1_t12 is signalled, connection is up
>>> InLabel : FastEthernet0/1, implicit-null
>>> OutLabel : -
>>> * RSVP Signalling Info:
>>> Src 100.1.1.1, Dst 100.2.2.2, Tun_Id 12, Tun_Instance 13
>>> RSVP Path Info:
>>> My Address: 100.2.2.2
>>> Explicit Route: NONE
>>> Record Route: NONE
>>> Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
>>> RSVP Resv Info:
>>> Record Route: NONE
>>> Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
>>>
>>>
>>> http://prakashkalsaria.wordpress.com
>>>
>>> On Mon, May 24, 2010 at 7:35 PM, Prakash Kalsaria <
>>> kalsaria.prakash_at_gmail.com> wrote:
>>>
>>>> Well in this case loopbacks is not in routing table
>>>> R1#sh ip cef 100.1.1.1
>>>> 100.1.1.1/32, version 16, epoch 0, connected, receive
>>>> tag information set
>>>> local tag: implicit-null
>>>>
>>>> loopback is not in label table and no in routing table
>>>> so how should i work around to get this functionall
>>>>
>>>> crazy scenario
>>>>
>>>> http://prakashkalsaria.wordpress.com
>>>> On Mon, May 24, 2010 at 7:22 PM, Scott Morris <swm_at_emanon.com> wrote:
>>>>
>>>>> Once you HAVE your TE tunnel, you can use PBR in order to direct traffic
>>>>> to it.
>>>>>
>>>>> but if the loopback doesn't exist in the routing/CEF table/label table,
>>>>> you cannot use PBR in order to actually build a TE tunnel to begin with.
>>>>>
>>>>> HTH,
>>>>>
>>>>> Scott
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> kalsaria.prakash_at_gmail.com wrote:
>>>>>
>>>>> How can we perform A MPLS TE with PBR
>>>>> a tunnel to establish through loopback which is not advertised in IGP and not
>>>>> even static is configured
>>>>>
>>>>> is it possible though PBR
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> _____________________________________________________
>>>>> Prakash Kalsaria
>>>>> http://prakashkalsaria.wordpress.com
>>>>>
>>>>>
>>>>> Blogs and organic groups at http://www.ccie.net
>>>>>
>>>>> _______________________________________________________________________
>>>>> Subscription information may be found at: http://www.groupstudy.com/list/CCIELab.html
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Mon May 24 2010 - 14:06:54 ART
This archive was generated by hypermail 2.2.0 : Tue Jun 01 2010 - 07:09:53 ART