Your current config does not have a lease period specified in the
configuration, so the lease is set at infinity.. . DHCP protocol has the
client renew it's lease @ 1/2 the lease period. To make the transition, I
would do the following:
add a secondary address to the VLAN; kill the first dhcp scope and create a
new one.
Then wait for your dhcp clients to change over (should happen during a
reboot on most clients)
On Wed, Apr 21, 2010 at 7:25 PM, Naufal Jamal <naufalccie_at_yahoo.in> wrote:
> Hi All,
>
> I need to migrate DHCP pool to completely new pool without restarting the
> end
> user systems.Is that possible?
>
> My approach was:
> make the lease of existing pool as 1 second.
> clear ip dhcp binding *
> clear arp
> make arp timeout 0 on the interface
> the pc will send a new arp request and it will get address from the new
> pool
> This is the present config:
> ip dhcp excluded-address 3.3.3.1
> !
> ip dhcp pool TEST
> network 3.3.3.0 255.255.255.0
> default-router 3.3.3.3
> dns-server 4.2.2.2
> int vlan 3
> ip address 3.3.3.3 255.255.255.0
> I changed it to:
> ip dhcp excluded-address 1.1.1.1
> !
> int vlan 3
> ip address 1.1.1.1 255.255.255.0
> ip dhcp pool TEST
> lease 0 0 1
> ip dhcp pool TEST
> lease 1
> network 1.1.1.0 255.255.255.0
> default-router 1.1.1.1
> dns-server 4.2.2.2
> int vlan 3
> arp timeout 0
> clear ip dhcp bindin *
> clear arp.
> I dont see any binding on the switch but pc still has an old pool address.
> Does the PC maintains its
> own arp-cache which could be cleared by only by restartig or power cycling
> the
> NIC ? Any other way?
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Thu Apr 22 2010 - 00:46:47 ART
This archive was generated by hypermail 2.2.0 : Sat May 01 2010 - 09:49:57 ART