Re: OSPF and secondary addresses

From: Marko Milivojevic <markom_at_ipexpert.com>
Date: Tue, 23 Mar 2010 13:09:16 +0000

On Tue, Mar 23, 2010 at 12:43, Marc La Porte <marc.a.laporte_at_gmail.com> wrote:
> Hi,
>
> According to Doyle (page 418): "OSPF will advertise a secondary network or
> subnet only if it is also running on the primary network or subnet".
>
> This means that in order to advertise a secondary network/subnet, the
> primary network/subnet also needs to be advertised in OSPF. Removing the
> primary advertisement basically means disabling the secondary advertisement.
>
> Do both have to be in the same OSPF process? Or can this be on different
> OSPF processes?

They both must be in the same process, as you can't have more than one
process active on the interface.

Here's the quick lablet (is that a word - I like it?).

Let's give it a test

{Fa0/1}--R1----R2

R1:
interface FastEthernet0/0
 ip address 12.12.12.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 1.1.1.1 255.255.255.0
 ip address 11.11.11.11 255.255.255.0 secondary
!
router ospf 1
 router-id 12.12.12.1
 network 11.11.11.11 0.0.0.0 area 0
 network 12.12.12.1 0.0.0.0 area 0
!

R2:
interface GigabitEthernet0/0
 ip address 12.12.12.2 255.255.255.0
!
router ospf 1
 router-id 12.12.12.2
 log-adjacency-changes
 network 12.12.12.2 0.0.0.0 area 0
!

Let's see if R2 has 11.11.11.0/24:

ProctorLabs-R2#show ip ospf database router 12.12.12.1

            OSPF Router with ID (12.12.12.2) (Process ID 1)

                Router Link States (Area 0)

  LS age: 198
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 12.12.12.1
  Advertising Router: 12.12.12.1
  LS Seq Number: 80000004
  Checksum: 0xF7A2
  Length: 36
  Number of Links: 1

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 12.12.12.2
     (Link Data) Router Interface address: 12.12.12.1
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

It's not there. Let's add primary address of R1's Fa0/1 to OSPF and
observe then:

R1:
router ospf 1
 network 1.1.1.1 0.0.0.0 area 0
!

ProctorLabs-R2#show ip ospf database router 12.12.12.1

            OSPF Router with ID (12.12.12.2) (Process ID 1)

                Router Link States (Area 0)

  LS age: 5
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 12.12.12.1
  Advertising Router: 12.12.12.1
  LS Seq Number: 80000005
  Checksum: 0xE66C
  Length: 60
  Number of Links: 3

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 1.1.1.0
     (Link Data) Network Mask: 255.255.255.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 11.11.11.0
     (Link Data) Network Mask: 255.255.255.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 12.12.12.2
     (Link Data) Router Interface address: 12.12.12.1
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

It's there. Let's remove the secondary network from R1 and create new
OSPF 2 process to see if we can activate it on secondary address on
R1. We'll need to have one more interface.

R1:
interface Loopback1
 ip address 111.111.111.111 255.255.255.0
!
router ospf 2
 network 111.111.111.111 0.0.0.0 area 0
 network 11.11.11.11 0.0.0.0 area 0
!

ProctorLabs-R1#show ip ospf 2 data router 111.111.111.111

            OSPF Router with ID (111.111.111.111) (Process ID 2)

                Router Link States (Area 0)

  LS age: 73
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 111.111.111.111
  Advertising Router: 111.111.111.111
  LS Seq Number: 80000001
  Checksum: 0xB246
  Length: 36
  Number of Links: 1

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 111.111.111.111
     (Link Data) Network Mask: 255.255.255.255
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

It's obviously not there - it's still a secondary address. Let's add
the primary address to OSPF 2 and see what happens:

router ospf 2
 network 1.1.1.1 0.0.0.0 area 0
!

ProctorLabs-R1#show ip ospf 1 database router 12.12.12.1

            OSPF Router with ID (12.12.12.1) (Process ID 1)

                Router Link States (Area 0)

  LS age: 229
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 12.12.12.1
  Advertising Router: 12.12.12.1
  LS Seq Number: 80000006
  Checksum: 0xF3A4
  Length: 36
  Number of Links: 1

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 12.12.12.2
     (Link Data) Router Interface address: 12.12.12.1
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

ProctorLabs-R1#show ip ospf 2 database router 111.111.111.111

            OSPF Router with ID (111.111.111.111) (Process ID 2)

                Router Link States (Area 0)

  LS age: 79
  Options: (No TOS-capability, DC)
  LS Type: Router Links
  Link State ID: 111.111.111.111
  Advertising Router: 111.111.111.111
  LS Seq Number: 80000002
  Checksum: 0x5C55
  Length: 60
  Number of Links: 3

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 111.111.111.111
     (Link Data) Network Mask: 255.255.255.255
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 1.1.1.0
     (Link Data) Network Mask: 255.255.255.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 11.11.11.0
     (Link Data) Network Mask: 255.255.255.0
      Number of TOS metrics: 0
       TOS 0 Metrics: 1

What has happened is that primary network of Fa0/1 has been removed
from OSPF 1 and was moved to OSPF 2. Don't be confused by
running-config - it is going to lie to you:

ProctorLabs-R1#show running-config | section router ospf
router ospf 1
 router-id 12.12.12.1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 11.11.11.11 0.0.0.0 area 0
 network 12.12.12.1 0.0.0.0 area 0
router ospf 2
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 11.11.11.11 0.0.0.0 area 0
 network 111.111.111.111 0.0.0.0 area 0

Hope this helps...

--
Marko Milivojevic - CCIE #18427
Senior Technical Instructor - IPexpert
YES! We include 400 hours of REAL rack
time with our Blended Learning Solution!
Mailto: markom_at_ipexpert.com
Telephone: +1.810.326.1444
Fax: +1.810.454.0130
Web: http://www.ipexpert.com/
Blogs and organic groups at http://www.ccie.net
Received on Tue Mar 23 2010 - 13:09:16 ART

This archive was generated by hypermail 2.2.0 : Thu Apr 01 2010 - 07:26:35 ART