No, bridging does work. I am using your .net file. See below:
CE1----Frame Switch----PE1----PE2----CE2
CE1:
bridge irb
bridge 1 protocol ieee
bridge 1 route ip
interface Serial1/0
no ip address
encapsulation frame-relay
frame-relay map bridge 101 broadcast
interface BVI1
ip address 10.10.10.1 255.255.255.0
no clns route-cache
PE1:
pseudowire-class INTERWORKING
encapsulation mpls
interworking ethernet
interface Serial1/0
no ip address
encapsulation frame-relay
connect FR-VLAN-IW Serial1/0 101 l2transport
xconnect 2.2.2.2 100 pw-class INTERWORKING
PE2:
pseudowire-class l2inter
encapsulation mpls
interworking ethernet
interface FastEthernet2/0.100
encapsulation dot1Q 100
no cdp enable
xconnect 1.1.1.1 100 pw-class l2inter
CE2:
interface FastEthernet1/0.100
encapsulation dot1Q 100
ip address 10.10.10.2 255.255.255.0
Verification:
PE1#show mpl l2transport vc de
Local interface: Se1/0 up, line protocol up, FR DLCI 101 up
MPLS VC type is Ethernet, interworking type is Ethernet <---- Bridged
Destination address: 2.2.2.2, VC ID: 100, VC status: up
Output interface: Se1/1, imposed label stack {16}
Preferred path: not configured
Default path: active
Tunnel label: imp-null, next hop point2point
Create time: 00:02:50, last status change time: 00:01:41
Signaling protocol: LDP, peer 2.2.2.2:0 up
MPLS VC labels: local 17, remote 16
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 0, send 29
byte totals: receive 0, send 1856
packet drops: receive 0, send 0
CE1#ping 10.10.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 20/43/68 ms
CE1#
On Tue, Jan 12, 2010 at 10:12 PM, Service Provider <
service.providersa_at_gmail.com> wrote:
> HI guys,
>
> I've verified all that and unfortunately bridging does not work. I have
> converted this to routed and it's working fine. No bridging on CE1 and the
> 2
> PEs are interworking IP.
>
> On Wed, Jan 13, 2010 at 6:11 AM, Satinder Singh <satinder.iitd_at_gmail.com
> >wrote:
>
> > Hi Service provider,
> >
> > To me some configuration missing/inconsistency look on the PE router and
> > CE1 router.
> >
> > Few of them are.
> >
> > One the CE1 i am not able to find the interface with address
> 10.1.12.1/24
> > so to which interface address you are pinging from CE2... pls clarify the
> > same.
> >
> > On the PE1 and PE2 in pseudowire class remove the " interworking
> ethernet"
> > and add " interworking ip" for interworking to work.
> >
> > In addition it is recoomended to add "ip local interfac address
> <address>"
> > in the pseudowire class.
> >
> > Pls check and let me know if it is working.
> >
> > Thanks
> > Satinder
> >
> > On Wed, Jan 13, 2010 at 12:37 AM, Service Provider <
> > service.providersa_at_gmail.com> wrote:
> >
> >> Hi all
> >>
> >> I have setup FR-VLAN Interworking and my l2 tunnel is up but cannot ping
> >> between CE sites.
> >>
> >>
> >>
> CE1-----FRSW-------PE1-----------------PE2---------------------VLAN100--------------------CE2
> >>
> >> Configs below, please help....tx.
> >>
> >> CE1#
> >> CE1#sh run
> >> Building configuration...
> >>
> >> Current configuration : 1912 bytes
> >> !
> >> version 12.0
> >> service timestamps debug uptime
> >> service timestamps log uptime
> >> no service password-encryption
> >> !
> >> hostname CE1
> >> !
> >> boot-start-marker
> >> boot-end-marker
> >> !
> >> enable password cisco
> >> !
> >> ip subnet-zero
> >> !
> >> !
> >> ip cef
> >> no ip domain-lookup
> >> ip ssh time-out 120
> >> ip ssh authentication-retries 3
> >> no mpls traffic-eng auto-bw timers frequency 0
> >> bridge irb
> >> !
> >> !
> >> !
> >> interface FastEthernet0/0
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> no clns route-cache
> >> !
> >> interface Serial1/0
> >> no ip address
> >> no ip directed-broadcast
> >> encapsulation frame-relay
> >> serial restart-delay 0
> >> no clns route-cache
> >> frame-relay map bridge 101 broadcast
> >> frame-relay map bridge 100 broadcast
> >> no frame-relay inverse-arp
> >> bridge-group 1
> >> !
> >> interface Serial1/1
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> no clns route-cache
> >> !
> >> interface Serial1/2
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> no clns route-cache
> >> !
> >> interface Serial1/3
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> no clns route-cache
> >> !
> >> interface Serial1/4
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> no clns route-cache
> >> !
> >> interface Serial1/5
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> no clns route-cache
> >> !
> >> interface Serial1/6
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> no clns route-cache
> >> !
> >> interface Serial1/7
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> no clns route-cache
> >> !
> >> interface BVI1
> >> ip address 10.10.10.1 255.255.255.0
> >> no ip directed-broadcast
> >> no clns route-cache
> >> !
> >> ip classless
> >> !
> >> !
> >> !
> >> control-plane
> >> !
> >> bridge 1 protocol ieee
> >> bridge 1 route ip
> >> !
> >> line con 0
> >> exec-timeout 0 0
> >> privilege level 15
> >> logging synchronous
> >> stopbits 1
> >> line aux 0
> >> exec-timeout 0 0
> >> privilege level 15
> >> stopbits 1
> >> line vty 0 4
> >> password cisco
> >> login
> >> !
> >> no cns aaa enable
> >> end
> >>
> >>
> >> ce2#
> >> ce2#sh run
> >> Building configuration...
> >>
> >> Current configuration : 810 bytes
> >> !
> >> version 12.0
> >> service timestamps debug uptime
> >> service timestamps log uptime
> >> no service password-encryption
> >> !
> >> hostname ce2
> >> !
> >> boot-start-marker
> >> boot-end-marker
> >> !
> >> !
> >> ip subnet-zero
> >> !
> >> !
> >> ip cef
> >> ip ssh time-out 120
> >> ip ssh authentication-retries 3
> >> !
> >> !
> >> !
> >> interface FastEthernet0/0
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> !
> >> interface FastEthernet1/0
> >> no ip address
> >> no ip directed-broadcast
> >> duplex half
> >> speed auto
> >> !
> >> interface FastEthernet1/0.100
> >> encapsulation dot1Q 100
> >> ip address 10.1.12.2 255.255.255.0
> >> no ip directed-broadcast
> >> !
> >> interface FastEthernet1/1
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> duplex half
> >> speed auto
> >> !
> >> ip classless
> >> !
> >> !
> >> !
> >> control-plane
> >> !
> >> !
> >> line con 0
> >> exec-timeout 0 0
> >> logging synchronous
> >> stopbits 1
> >> line aux 0
> >> stopbits 1
> >> line vty 0 4
> >> login
> >> !
> >> no cns aaa enable
> >> end
> >>
> >> PE1#sh run
> >> Building configuration...
> >>
> >> Current configuration : 2311 bytes
> >> !
> >> version 12.0
> >> service timestamps debug uptime
> >> service timestamps log uptime
> >> no service password-encryption
> >> !
> >> hostname PE1
> >> !
> >> boot-start-marker
> >> boot-end-marker
> >> !
> >> enable password cisco
> >> !
> >> ip subnet-zero
> >> !
> >> !
> >> ip cef
> >> no ip domain-lookup
> >> ip ssh time-out 120
> >> ip ssh authentication-retries 3
> >> mpls label protocol ldp
> >> no mpls traffic-eng auto-bw timers frequency 0
> >> frame-relay switching
> >> !
> >> !
> >> pseudowire-class l2inter
> >> encapsulation mpls
> >> interworking ethernet
> >> !
> >> pseudowire-class INTERWORKING
> >> encapsulation mpls
> >> interworking ethernet
> >> !
> >> !
> >> interface Loopback0
> >> ip address 1.1.1.1 255.255.255.255
> >> no ip directed-broadcast
> >> no clns route-cache
> >> !
> >> interface Loopback1
> >> no ip address
> >> no ip directed-broadcast
> >> !
> >> interface FastEthernet0/0
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> no clns route-cache
> >> !
> >> interface Serial1/0
> >> no ip address
> >> no ip directed-broadcast
> >> encapsulation frame-relay
> >> serial restart-delay 0
> >> no clns route-cache
> >> !
> >> interface Serial1/1
> >> ip address 150.1.12.1 255.255.255.0
> >> no ip directed-broadcast
> >> mpls label protocol ldp
> >> tag-switching ip
> >> serial restart-delay 0
> >> no clns route-cache
> >> !
> >> interface Serial1/2
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> no clns route-cache
> >> !
> >> interface Serial1/3
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> no clns route-cache
> >> !
> >> interface Serial1/4
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> no clns route-cache
> >> !
> >> interface Serial1/5
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> no clns route-cache
> >> !
> >> interface Serial1/6
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> no clns route-cache
> >> !
> >> interface Serial1/7
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> no clns route-cache
> >> !
> >> router ospf 1
> >> router-id 1.1.1.1
> >> log-adjacency-changes
> >> network 1.1.1.1 0.0.0.0 area 0
> >> network 13.13.13.1 0.0.0.0 area 0
> >> network 0.0.0.0 255.255.255.255 area 0
> >> !
> >> ip classless
> >> !
> >> !
> >> connect FR-VLAN-IW Serial1/0 101 l2transport
> >> xconnect 2.2.2.2 100 pw-class INTERWORKING
> >> !
> >> !
> >> !
> >> control-plane
> >> !
> >> !
> >> line con 0
> >> exec-timeout 0 0
> >> privilege level 15
> >> logging synchronous
> >> stopbits 1
> >> line aux 0
> >> exec-timeout 0 0
> >> privilege level 15
> >> stopbits 1
> >> line vty 0 4
> >> password cisco
> >> login
> >> !
> >> no cns aaa enable
> >> end
> >>
> >>
> >>
> >> pe2#sh run
> >> Building configuration...
> >>
> >> Current configuration : 1997 bytes
> >> !
> >> version 12.0
> >> service timestamps debug uptime
> >> service timestamps log uptime
> >> no service password-encryption
> >> !
> >> hostname pe2
> >> !
> >> boot-start-marker
> >> boot-end-marker
> >> !
> >> !
> >> ip subnet-zero
> >> !
> >> !
> >> ip cef
> >> no ip domain-lookup
> >> ip ssh time-out 120
> >> ip ssh authentication-retries 3
> >> !
> >> !
> >> pseudowire-class l2inter
> >> encapsulation mpls
> >> interworking ethernet
> >> !
> >> !
> >> interface Loopback0
> >> ip address 150.1.2.2 255.255.255.255
> >> no ip directed-broadcast
> >> !
> >> interface Loopback2
> >> ip address 2.2.2.2 255.255.255.255
> >> no ip directed-broadcast
> >> !
> >> interface FastEthernet0/0
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> !
> >> interface Serial1/0
> >> ip address 150.1.12.2 255.255.255.0
> >> no ip directed-broadcast
> >> mpls label protocol ldp
> >> tag-switching ip
> >> serial restart-delay 0
> >> !
> >> interface Serial1/1
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> !
> >> interface Serial1/2
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> !
> >> interface Serial1/3
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> !
> >> interface Serial1/4
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> !
> >> interface Serial1/5
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> !
> >> interface Serial1/6
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> !
> >> interface Serial1/7
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> serial restart-delay 0
> >> !
> >> interface FastEthernet2/0
> >> no ip address
> >> no ip directed-broadcast
> >> no keepalive
> >> duplex half
> >> speed auto
> >> !
> >> interface FastEthernet2/0.100
> >> encapsulation dot1Q 100
> >> no ip directed-broadcast
> >> xconnect 1.1.1.1 100 pw-class l2inter
> >> !
> >> interface FastEthernet2/1
> >> no ip address
> >> no ip directed-broadcast
> >> shutdown
> >> duplex half
> >> speed auto
> >> !
> >> router ospf 1
> >> log-adjacency-changes
> >> network 0.0.0.0 255.255.255.255 area 0
> >> !
> >> ip classless
> >> !
> >> !
> >> !
> >> control-plane
> >> !
> >> !
> >> line con 0
> >> exec-timeout 0 0
> >> logging synchronous
> >> stopbits 1
> >> line aux 0
> >> stopbits 1
> >> line vty 0 4
> >> login
> >> !
> >> no cns aaa enable
> >> end
> >>
> >>
> >> Blogs and organic groups at http://www.ccie.net
> >>
> >> _______________________________________________________________________
> >> Subscription information may be found at:
> >> http://www.groupstudy.com/list/CCIELab.html
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >
> >
> > --
> > Satinder Singh
> > mobile 09980075998
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
>
>
>
>
-- Bryan Bartik CCIE #23707 (R&S, SP), CCNP Sr. Support Engineer - IPexpert, Inc. URL: http://www.IPexpert.com Blogs and organic groups at http://www.ccie.netReceived on Wed Jan 13 2010 - 08:29:47 ART
This archive was generated by hypermail 2.2.0 : Thu Feb 04 2010 - 20:28:41 ART