Hey amigo,
I hope your evening is going well.
Last I tried something like this, I used the config guides and you can
almost copy and paste. The only thing to keep in mind is that the question
may ask you to configure a specific group and port number. Will there be a
RP for this group? Does this group 'fit into' your network configs ok?
Chances are that it does. Config guide:
I seem to recall a former email with someone suggesting to test this with a
dns lookup. This way you ping a host name on one router, and you can see
the bcast on the remote router. You might choose to search the archives for
this example ... as I remember, it was a very well thought out config
example and how to test. Your example seems good too, and you have even
thought of things like the subnet check that RIP does ... cool stuff man.
In your configs, you joined R4 to the group 224.1.1.1 via the join command;
there is no reason for the router to forward anything since this group is
local. The router will answer to that. This is not what you want.
Normally this would make for good testing, however ... not what you want for
this config example.
I would revisit your configs. If you have BSR, running then this is cool.
Make sure all the routers know who is the RP, etc ... etc ... etc ... Also,
you may want to test these mcast configs first, and make sure this is rock
solid and all works as expected. Then move on to forwarding RIP bcasts ...
After this I would suggest to configure the mcast helper-map. If possible,
I would check the configs via the config guide and make only the changes
required by the question you are given. Perhaps I remember it wrong,
however, as I recall ... the config guides are pretty good WRT this config
example
HTH and have a great night!
Andrew Lee Lissitz
On Sat, Nov 14, 2009 at 1:51 PM, Nate Lee <natetlee_at_gmail.com> wrote:
> I am having an issue getting the ip helper-map to work and after going over
> my configs 3 or 4 times am still not sure what the problem is. Any hints
> or
> pointers in the right direction would be greatly appreciated. I am trying
> to get one router to send a RIPv2 broadcast which should be picked up by
> another router, translated using the multicast helper-map to 224.1.1.1 and
> then sent across an OSPF domain where it is converted back to a broadcast
> at
> the other side and received by another RIP router.
>
> *The setup:*
>
> I have 5 routers setup in a straight line R1 <> R2 <> R3 <> R4 <> R5.
> Multicast routing is enabled on R2, R3 and R4.
>
> R2, R3 and R4 are all running PIM sparse mode on their loopbacks and their
> interfaces facing each other.
>
> R1 and R5 are speaking RIPv2 and R2, R3 and R4 are using OSPF. I am trying
> to get R5 to receive RIP routes from R1.
>
> R1 has the v2-broadcast turned on on its interface facing R2. R2 is able
> to
> see these broadcasts with a packet debug.
>
> R2 is the BSR and RP for the three routers running OSPF, multicast routing
> is not enabled on R1 or R5.
>
> The helper map is configured on R2's interface fa0/0 which is facing R1 and
> should take RIP broadcasts and convert them to the 224.1.1.1 group.
>
> There is another helper-map on R4's fa0/1 interface which faces R3 and is
> configured to receive the 224.1.1.1 group and send a broadcast to
> 10.1.45.255.
>
> IP Directed-broadcast is enabled on R4's fa0/0 interface facing R5.
>
> R5 is configured with no validate-update-source to prevent it from dropping
> any packets that appear from R1's 10.1.12.1 address.
>
> *The problem:*
>
> When I debug IP mpacket and debug IP packet on R2, I am able to see the RIP
> broadcasts from R1, but it appears that they are never sent out as the
> 224.1.1.1 multicast address
>
> R5 never receives any packets from R1, a debug IP mpacket on R2 R3 and R4
> show no packets to 224.1.1.1 ever being sent anywhere.
>
> *The configs:
> *
> R1:
>
> interface FastEthernet0/0
> ip address 10.1.12.1 255.255.255.0
> ip rip v2-broadcast
>
> router rip
> version 2
> network 1.0.0.0
> network 10.0.0.0
> no auto-summary
>
> R2:
>
> interface FastEthernet0/0
> ip address 10.1.12.2 255.255.255.0
> ip multicast helper-map broadcast 224.1.1.1 100 ttl 4
> !
> interface FastEthernet0/1
> ip address 10.1.23.2 255.255.255.0
> ip pim sparse-mode
> !
> router ospf 100
> network 2.2.2.2 0.0.0.0 area 0
> network 10.1.23.2 0.0.0.0 area 0
> !
> ip forward-protocol udp rip
> !
> ip pim bsr-candidate Loopback0 0
> ip pim rp-candidate Loopback0
> !
> access-list 100 permit udp any any eq rip
>
> R3:
>
> interface FastEthernet0/0
> ip address 10.1.23.3 255.255.255.0
> ip pim sparse-mode
> !
> interface FastEthernet0/1
> ip address 10.1.34.3 255.255.255.0
> ip pim sparse-mode
> !
> router ospf 100
> network 0.0.0.0 255.255.255.255 area 0
>
> R4:
>
> interface FastEthernet0/0
> ip address 10.1.45.4 255.255.255.0
> ip directed-broadcast
> ip igmp join-group 224.1.1.1
> !
> interface FastEthernet0/1
> ip address 10.1.34.4 255.255.255.0
> ip pim sparse-mode
> ip multicast helper-map 224.1.1.1 10.1.45.255 100
> !
> router ospf 100
> network 4.4.4.4 0.0.0.0 area 0
> network 10.1.34.4 0.0.0.0 area 0
> !
> ip forward-protocol nd
> ip forward-protocol udp rip
>
> R5:
>
> interface FastEthernet0/0
> ip address 10.1.45.5 255.255.255.0
> !
> router rip
> version 2
> no validate-update-source
> network 10.0.0.0
> no auto-summary
>
> *The shows and debugs:
>
> *
> From R2 with debug ip packet and mpacket enabled, notice no packets to
> 224.1.1.1 are ever sent:
>
> *Mar 1 01:29:53.599: IP: s=10.1.12.1 (FastEthernet0/0), d=255.255.255.255,
> len 52, rcvd 2
> *Mar 1 01:29:53.603: UDP src=520, dst=520
>
> From R4:
>
> R4(config-if)#*do sh ip mroute*
>
> IP Multicast Routing Table
> <output omitted>
>
> (*, 224.1.1.1), 01:21:43/00:02:57, RP 2.2.2.2, flags: SJCL
> Incoming interface: FastEthernet0/1, RPF nbr 10.1.34.3
> Outgoing interface list:
> FastEthernet0/0, Forward/Sparse, 00:41:58/00:02:54
>
> (*, 224.0.1.40), 01:24:27/00:02:52, RP 0.0.0.0, flags: DCL
> Incoming interface: Null, RPF nbr 0.0.0.0
> Outgoing interface list:
> Loopback0, Forward/Sparse, 01:24:27/00:02:52
>
>
> R4(config-if)#*do sh ip pim rp map 224.1.1.1*
>
> PIM Group-to-RP Mappings
>
> Group(s) 224.0.0.0/4
> RP 2.2.2.2 (?), v2
> Info source: 2.2.2.2 (?), via bootstrap, priority 0, holdtime 150
> Uptime: 01:24:07, expires: 00:01:48
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
>
>
>
>
-- Andrew Lee Lissitz all.from.nj_at_gmail.com Blogs and organic groups at http://www.ccie.netReceived on Sat Nov 14 2009 - 19:45:19 ART
This archive was generated by hypermail 2.2.0 : Tue Dec 01 2009 - 06:36:29 ART