Configurations.
Hi
Below are the configurations. I have made R2 the MA but still R3 cannot get
auto-rp announcement.
R1#sh run
Building configuration...
Current configuration : 952 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
!
!
ip multicast-routing
ip ssh time-out 120
ip ssh authentication-retries 3
!
!
!
interface Loopback0
ip address 150.1.1.1 255.255.255.0
no ip directed-broadcast
ip pim sparse-mode
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
!
interface FastEthernet1/0
ip address 150.1.12.1 255.255.255.0
no ip directed-broadcast
ip pim sparse-mode
duplex half
speed auto
!
interface FastEthernet1/1
no ip address
no ip directed-broadcast
shutdown
duplex half
speed auto
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!
ip pim send-rp-announce Loopback0 scope 20
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
no cns aaa enable
end
R1#
R2#sh run
Building configuration...
Current configuration : 985 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
!
!
ip multicast-routing
ip ssh time-out 120
ip ssh authentication-retries 3
!
!
!
interface Loopback0
ip address 150.1.2.2 255.255.255.0
no ip directed-broadcast
ip pim sparse-mode
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
!
interface FastEthernet1/0
ip address 150.1.12.2 255.255.255.0
no ip directed-broadcast
ip pim sparse-mode
duplex half
speed auto
!
interface FastEthernet1/1
ip address 150.1.23.2 255.255.255.0
no ip directed-broadcast
ip pim sparse-mode
duplex half
speed auto
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!
ip pim send-rp-discovery Loopback0 scope 20
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
no cns aaa enable
end
R2#
R3#sh run
Building configuration...
Current configuration : 942 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
!
!
ip multicast-routing
ip ssh time-out 120
ip ssh authentication-retries 3
!
!
!
interface Loopback0
ip address 150.1.3.3 255.255.255.0
no ip directed-broadcast
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
shutdown
!
interface FastEthernet1/0
ip address 150.1.23.3 255.255.255.0
no ip directed-broadcast
ip pim sparse-mode
ip igmp join-group 227.7.7.7
duplex half
speed auto
!
interface FastEthernet1/1
no ip address
no ip directed-broadcast
shutdown
duplex half
speed auto
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!
ip pim autorp listener
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
no cns aaa enable
end
R3#
Thanks.
On Sat, Nov 7, 2009 at 9:20 AM, Amr Masoud <amr.eng_at_gmail.com> wrote:
> Make sure that:
>
>
> - You have PIM Sparse-Mode enabled between R2,R3, and there is PIM
> adjacency
> - R3 has reach ability to R1's LB, via R2.
>
> Regards,
> Amr Masoud
Blogs and organic groups at http://www.ccie.net
Received on Sat Nov 07 2009 - 09:55:04 ART
This archive was generated by hypermail 2.2.0 : Tue Dec 01 2009 - 06:36:28 ART