Not able to ping loopback interface

From: Cisco Fanatic <ebay_products_at_hotmail.com>
Date: Tue, 6 Oct 2009 12:15:49 -0700

All, I have configured MPLS VRF on the interfaces. But, I am not able to ping
the loopback interfaces. Can someone let me know as why? Am I missing
something here.

Thanks,
-Yuri

R2
++
!
mpls label protocol ldp
!
ip vrf R2_VRF_24
 rd 24:24
!
ip vrf R2_VRF_42
 rd 42:42
!
interface Loopback0
 ip address 150.1.2.2 255.255.255.255
!
interface Loopback24
 ip vrf forwarding R2_VRF_24
 ip address 150.1.124.2 255.255.255.255
!
interface Loopback42
 ip vrf forwarding R2_VRF_42
 ip address 150.1.142.2 255.255.255.255
!
interface Ethernet0/0
 ip address 150.1.24.2 255.255.255.0
 mpls ip
!
interface Ethernet0/0.24
 encapsulation dot1Q 24
 ip vrf forwarding R2_VRF_24
 ip address 150.1.24.2 255.255.255.0
!
interface Ethernet0/0.42
 encapsulation dot1Q 42
 ip vrf forwarding R2_VRF_42
 ip address 150.1.42.2 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 150.1.2.2 0.0.0.0 area 0
 network 150.1.24.2 0.0.0.0 area 0
 network 150.1.124.2 0.0.0.0 area 0
 network 150.1.142.2 0.0.0.0 area 0
!

R4
++
!
mpls label protocol ldp
!
ip vrf R4_VRF_24
 rd 24:24
!
ip vrf R4_VRF_42
 rd 42:42
!
interface Loopback0
 ip address 150.1.4.4 255.255.255.255
!
interface Loopback24
 ip vrf forwarding R4_VRF_24
 ip address 150.1.124.4 255.255.255.255
!
interface Loopback42
 ip vrf forwarding R4_VRF_42
 ip address 150.1.142.4 255.255.255.255
!
interface Ethernet0/0
 no ip address
 mpls ip
!
interface Ethernet0/0.24
 encapsulation dot1Q 24
 ip vrf forwarding R4_VRF_24
 ip address 150.1.24.4 255.255.255.0
!
interface Ethernet0/0.42
 encapsulation dot1Q 42
 ip vrf forwarding R4_VRF_42
 ip address 150.1.42.4 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 150.1.4.4 0.0.0.0 area 0
 network 150.1.24.4 0.0.0.0 area 0
 network 150.1.45.4 0.0.0.0 area 0
 network 150.1.124.4 0.0.0.0 area 0
 network 150.1.142.4 0.0.0.0 area 0
!

Success rate is 0 percent (0/5)
R2#ping vrf R2_VRF_24 150.1.24.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.1.24.4, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/4 ms

R2#ping vrf R2_VRF_42 150.1.42.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.1.42.4, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/4 ms

R2#ping vrf R2_VRF_24 150.1.124.4 <--

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.1.124.4, timeout is 2 seconds:
.....

R2#sh ip vrf int
Interface IP-Address VRF
Protocol
Lo24 150.1.124.2 R2_VRF_24 up
Et0/0.24 150.1.24.2 R2_VRF_24 up
Lo42 150.1.142.2 R2_VRF_42 up
Et0/0.42 150.1.42.2 R2_VRF_42 up

R4#sh ip vrf int
Interface IP-Address VRF
Protocol
Lo24 150.1.124.4 R4_VRF_24 up
Et0/0.24 150.1.24.4 R4_VRF_24 up
Lo42 150.1.142.4 R4_VRF_42 up
Et0/0.42 150.1.42.4 R4_VRF_42 up

                                               
Received on Tue Oct 06 2009 - 12:15:49 ART

This archive was generated by hypermail 2.2.0 : Sun Nov 01 2009 - 07:50:59 ART