Re: PPPoE with IPv6

From: Rich Collins <nilsi2002_at_gmail.com>
Date: Mon, 28 Sep 2009 13:02:42 -0400

Hi,

I did get a ipv6 dhcp version of this to work - I referenced this
link: https://www.cisco.com/en/US/products/ps6553/products_white_paper09186a00801e199d.shtml

Perhaps there is a way to refine this configuration but it did work for me.

R1#sh ver
Cisco IOS Software, 3700 Software (C3725-ADVENTERPRISEK9-M), Version
12.4(15)T7, RELEASE SOFTWARE (fc3)

R1#sh run
Building configuration...

Current configuration : 2540 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
no ip domain lookup
ip multicast-routing
ipv6 unicast-routing
!
!
vpdn enable
!
!
!
!
bba-group pppoe global
!
!
interface FastEthernet0/0
 no ip address
 speed auto
 full-duplex
 ipv6 address DH-PREFIX 0:0:0:1::/64 eui-64
 ipv6 enable
 pppoe enable group global
 pppoe-client dial-pool-number 1
 no clns route-cache
!
!
interface Dialer1
 no ip address
 ip mtu 1492
 ip pim sparse-mode
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 ipv6 address autoconfig
 no ipv6 nd ra suppress
 ipv6 dhcp client pd DH-PREFIX
 no peer neighbor-route
!
ip forward-protocol nd
!
!
ipv6 route ::/0 Dialer1
!

R1#

R2#
R2#sh run
Building configuration...

Current configuration : 3342 bytes
!
version 12.4
!
hostname R2
!
aaa session-id common
memory-size iomem 5
ip cef
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
ipv6 dhcp pool foo
 prefix-delegation 2001:7:7::/48 0003000100055FAF2C08
 prefix-delegation 2001:8:8::/48 0003000100055FAC1808
 prefix-delegation 2001:8:9::/48 000E0001
 prefix-delegation 2001:8:A::/48 00030001C20020310000
!
!
!
!
bba-group pppoe global
 virtual-template 1
!
!
interface Loopback0
 ipv6 address 2001:2:2:2::2/64
 ipv6 enable
!
interface FastEthernet2/0
 no ip address
 speed auto
 full-duplex
 ipv6 enable
 pppoe enable group global
!
interface Virtual-Template1
 no ip address
 ipv6 address 2001:8:A::1/48
 ipv6 enable
 no ipv6 nd ra suppress
 ipv6 dhcp server foo
!
!
no ip forward-protocol nd

R2#

R1#sh pppoe session interface fastEthernet 0/0
     1 client session

Uniq ID PPPoE RemMAC Port VT VA State
           SID LocMAC VA-st
    N/A 19 c201.2031.0020 Fa0/0 Di1 Vi2 UP
                c200.2031.0000 UP
R1#

R2#sh ipv6 dhcp binding
Client: FE80::C000:20FF:FE31:0
  DUID: 00030001C20020310000
  Interface : Virtual-Access2.1
  IA PD: IA ID 0x000E0001, T1 302400, T2 483840
    Prefix: 2001:8:A::/48
            preferred lifetime 604800, valid lifetime 2592000
            expires at Mar 31 2002 01:36 AM (2591347 seconds)
R2#

R1#ping ipv6 2001:2:2:2::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:2:2:2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms
R1#

Hints:

R1# clear pppoe all
R1#clear ipv6 dhcp client dialer 1 (to flush the dhcp address 
necessary even after clearing pppoe session)

R1#sh ipv6 dhcp interface
Dialer1 is in client mode
  State is OPEN
  Renew will be sent in 3d11h
  List of known servers:
    Reachable via address: FE80::C001:20FF:FE31:0

    DUID: 00030001C20120310000 >>>>>>use this for dhcp pool in server<<<<<<

    Preference: 0
    Configuration parameters:
      IA PD: IA ID 0x000E0001, T1 302400, T2 483840
        Prefix: 2001:8:A::/48
                preferred lifetime 604800, valid lifetime 2592000
                expires at Mar 31 2002 01:36 AM (2591811 seconds)
      Information refresh time: 0
  Prefix name: DH-PREFIX
  Rapid-Commit: disabled
R1#

-Rich

On Sat, Sep 26, 2009 at 6:41 PM, Joe Astorino <jastorino_at_ipexpert.com> wrote:
> Did anybody ever get IPv6 to function properly over a PPPoE link? If so,
> can you please share ?
>
> On Wed, Sep 2, 2009 at 2:10 AM, Joe Astorino <jastorino_at_ipexpert.com> wrote:
>
>> Has anybody successfully set this up?
>>
>> Basically, on the PPPoE server side, when I assign my ipv6 address to the
>> virtual-template interface you can see it , but the router never adds a
>> route for it in the routing table. On the client end of the PPPoE things
>> seem to work fine using the dialer interface. Interestingly enough, I see
>> IPv6CP negotiating OK in the debugs, and I can actually see the link-local
>> address of the other side in "show ipv6 neighbor" but no ping to the other
>> side global address. I've even tried ipv6 unnumbered with no luck.
>>
>> Also, it works totally fine for IPv4...I have enabled ipv6 unicast-routing
>> of course, and also ipv6 cef just in case. I am running 12.4(24)T1 and have
>> also tried this on 12.4(3a)
>>
>> basically I have below:
>>
>> Server
>> ----------
>>
>> vpdn enable
>> bba-group pppoe global
>> virtual-template 1
>>
>> interface FastEthernet0/0
>> no ip address
>> duplex auto
>> speed auto
>> pppoe enable group global
>>
>> interface Virtual-Template1
>> mtu 1492
>> ip address 141.41.67.6 255.255.255.0
>> ipv6 address 2001:0:0:67::6/64
>> ipv6 enable
>>
>>
>> Client
>> --------
>>
>> interface FastEthernet0/0
>> no ip address
>> duplex auto
>> speed auto
>> pppoe enable group global
>> pppoe-client dial-pool-number 1
>>
>> interface Dialer1
>> mtu 1492
>> ip address dhcp
>> encapsulation ppp
>> dialer pool 1
>> dialer idle-timeout 0
>> dialer persistent
>> ipv6 address FE80::7 link-local
>> ipv6 address 2001:0:0:67::7/64
>> ipv6 enable
>>
>>
>> so check this out...
>>
>> R6(config-if)#do sh run int virtual-template1
>> Building configuration...
>>
>> Current configuration : 128 bytes
>> !
>> interface Virtual-Template1
>> mtu 1492
>> ip address 141.41.67.6 255.255.255.0
>> ipv6 address 2001:0:0:67::6/64
>> ipv6 enable
>> end
>>
>> R6(config-if)#do sh ipv6 route
>> IPv6 Routing Table - Default - 10 entries
>> Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
>> B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
>> I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
>> EX - EIGRP external
>> O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
>> ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
>> R 2001::2/128 [120/2]
>> via FE80::2, Serial0/1/0
>> R 2001::5/128 [120/3]
>> via FE80::2, Serial0/1/0
>> LC 2001::6/128 [0/0]
>> via Loopback6, receive
>> C 2001::256:0/125 [0/0]
>> via Serial0/1/0, directly connected
>> L 2001::256:6/128 [0/0]
>> via Serial0/1/0, receive
>> C 2001:0:0:69::/64 [0/0]
>> via Serial0/2/0, directly connected
>> L 2001:0:0:69::6/128 [0/0]
>> via Serial0/2/0, receive
>> C 2001:0:0:70::/64 [0/0]
>> via Serial0/2/1, directly connected
>> L 2001:0:0:70::6/128 [0/0]
>> via Serial0/2/1, receive
>> L FF00::/8 [0/0]
>> via Null0, receive
>>
>> R6(config-if)#do ping 2001:0:0:67::7
>>
>> Type escape sequence to abort.
>> Sending 5, 100-byte ICMP Echos to 2001:0:0:67::7, timeout is 2 seconds:
>>
>> % No valid route for destination
>> Success rate is 0 percent (0/1)
>>
>> --
>> Regards,
>>
>> Joe Astorino - CCIE #24347 R&S
>> Technical Instructor - IPexpert, Inc.
>> Cell: +1.586.212.6107
>> Fax: +1.810.454.0130
>> Mailto: jastorino_at_ipexpert.com
>>
>
>
>
> --
> Regards,
>
> Joe Astorino - CCIE #24347 R&S
> Technical Instructor - IPexpert, Inc.
> Cell: +1.586.212.6107
> Fax: +1.810.454.0130
> Mailto: jastorino_at_ipexpert.com
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Mon Sep 28 2009 - 13:02:42 ART

This archive was generated by hypermail 2.2.0 : Sun Oct 04 2009 - 07:42:04 ART