Hi Molomo,
Yes that will work just fine.
You can lab it yourself with just 3 routers:
R2----area 1---R5---area 0 (loopback 0)---area 1-----R4
I took a break out of the exciting world of multicast to lab it myself:
R2:
interface Loopback0
ip address 2.2.2.2 255.0.0.0
!
interface Serial0/0
no ip address
encapsulation frame-relay
no dce-terminal-timing-enable
!
interface Serial0/0.25 point-to-point
ip address 10.1.25.2 255.255.255.0
ip pim sparse-mode
frame-relay interface-dlci 205
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 1
end
R5:
interface Loopback0
ip address 5.5.5.5 255.0.0.0
!
interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.52 point-to-point
ip address 10.1.25.5 255.255.255.0
ip pim sparse-mode
frame-relay interface-dlci 502
!
!
interface Serial0/0.54 point-to-point
ip address 10.1.45.5 255.255.255.0
ip pim sparse-mode
frame-relay interface-dlci 504
!
router ospf 1
log-adjacency-changes
network 5.5.5.5 0.0.0.0 area 0
network 10.0.0.0 0.255.255.255 area 1
end
R4:
interface Loopback0
ip address 4.4.4.4 255.0.0.0
!
interface Serial0/0
no ip address
encapsulation frame-relay
no dce-terminal-timing-enable
!
interface Serial0/0.45 point-to-point
ip address 10.1.45.4 255.255.255.0
ip pim sparse-mode
frame-relay interface-dlci 405
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 1
end
The end result is area 0 on a stick :)
R5#show ip os ne
Neighbor ID Pri State Dead Time Address Interface
4.4.4.4 0 FULL/ - 00:00:32 10.1.45.4
Serial0/0.54
2.2.2.2 0 FULL/ - 00:00:37 10.1.25.2
Serial0/0.52
R5#show ip route ospf
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/65] via 10.1.25.2, 00:07:09, Serial0/0.52
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/65] via 10.1.45.4, 00:07:09, Serial0/0.54
R2#show ip route ospf
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/129] via 10.1.25.5, 00:07:38, Serial0/0.25
5.0.0.0/32 is subnetted, 1 subnets
O IA 5.5.5.5 [110/65] via 10.1.25.5, 00:07:38, Serial0/0.25
10.0.0.0/24 is subnetted, 2 subnets
O 10.1.45.0 [110/128] via 10.1.25.5, 00:07:38, Serial0/0.25
R2#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 112/127/176 ms
R4#show ip route ospf
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/129] via 10.1.45.5, 00:08:18, Serial0/0.45
5.0.0.0/32 is subnetted, 1 subnets
O IA 5.5.5.5 [110/65] via 10.1.45.5, 00:08:18, Serial0/0.45
10.0.0.0/24 is subnetted, 2 subnets
O 10.1.25.0 [110/128] via 10.1.45.5, 00:08:18, Serial0/0.45
Also check out this Cisco link:
http://www.cisco.com/en/US/tech/tk365/technologies_q_and_a_item09186a0080094704.shtml
regards Andy
Molomo wrote:
> Experts,
>
> I would like to know if the setup below is valid, and whether R1 & R4 will
> be able to reach each other.
>
>
> R1---area 1-----R2---area 0-----R3----area 1-----R4
>
>
> Regards,
> Molomo
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Sat Sep 05 2009 - 20:22:08 ART
This archive was generated by hypermail 2.2.0 : Sun Oct 04 2009 - 07:42:02 ART