Re: PPPoE with IPv6

From: Marcel Lammerse <m.lammerse_at_mac.com>
Date: Thu, 03 Sep 2009 09:01:09 +1000

Hi Joe,

interesting problem... this is what I've got so far.

For an ipv6 ppp sesssion, the auto-negotiated address is a link-local address only. Global prefixes are not communicated during the ppp ipcp negotiaton phase. In order to advertise ipv6 prefixes, you would need to enable ipv6 router advertisements, which are suppressed by default.

So first step is un-suppress the RA.

Then you need to configure one side of the link to accept the RA with the ivp6 autoconfigure command.

R1

interface Virtual-Template1
 mtu 1492
 no ip address
 ipv6 address autoconfig
 ipv6 enable

R2

interface Dialer1
 mtu 1492
 no ip address
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 ipv6 address 2001:0:0:67::7/64
 ipv6 enable
 no ipv6 nd ra suppress

R1#ping 2001:0:0:67::7

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:0:0:67::7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/30/104 ms
R1#

R1#sh ipv6 interface virtual-access 1.1
Virtual-Access1.1 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::C800:3FF:FED8:8
  No Virtual link-local address(es):
  Stateless address autoconfig enabled
  Global unicast address(es):
    2001::67:C800:3FF:FED8:8, subnet is 2001:0:0:67::/64 [EUI/CAL/PRE]
      valid lifetime 2591810 preferred lifetime 604610
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FFD8:8
  MTU is 1492 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds (using 42866)
  Hosts use stateless autoconfig for addresses.

I tried to reverse this by having the server advertise the prefix, instead of the client. But that doesn't seem to work, because when the virtual-access interface is cloned from the template, it doesn't copy the global ipv6 prefix from the template for some reason.

Any idea why?

On Wednesday, 02 September, 2009, at 04:10PM, "Joe Astorino" <jastorino_at_ipexpert.com> wrote:
>Has anybody successfully set this up?
>
>Basically, on the PPPoE server side, when I assign my ipv6 address to the
>virtual-template interface you can see it , but the router never adds a
>route for it in the routing table. On the client end of the PPPoE things
>seem to work fine using the dialer interface. Interestingly enough, I see
>IPv6CP negotiating OK in the debugs, and I can actually see the link-local
>address of the other side in "show ipv6 neighbor" but no ping to the other
>side global address. I've even tried ipv6 unnumbered with no luck.
>
>Also, it works totally fine for IPv4...I have enabled ipv6 unicast-routing
>of course, and also ipv6 cef just in case. I am running 12.4(24)T1 and have
>also tried this on 12.4(3a)
>
>basically I have below:
>
>Server
>----------
>
>vpdn enable
>bba-group pppoe global
> virtual-template 1
>
>interface FastEthernet0/0
> no ip address
> duplex auto
> speed auto
> pppoe enable group global
>
>interface Virtual-Template1
> mtu 1492
> ip address 141.41.67.6 255.255.255.0
> ipv6 address 2001:0:0:67::6/64
> ipv6 enable
>
>
>Client
>--------
>
>interface FastEthernet0/0
> no ip address
> duplex auto
> speed auto
> pppoe enable group global
> pppoe-client dial-pool-number 1
>
>interface Dialer1
> mtu 1492
> ip address dhcp
> encapsulation ppp
> dialer pool 1
> dialer idle-timeout 0
> dialer persistent
> ipv6 address FE80::7 link-local
> ipv6 address 2001:0:0:67::7/64
> ipv6 enable
>
>
>so check this out...
>
>R6(config-if)#do sh run int virtual-template1
>Building configuration...
>
>Current configuration : 128 bytes
>!
>interface Virtual-Template1
> mtu 1492
> ip address 141.41.67.6 255.255.255.0
> ipv6 address 2001:0:0:67::6/64
> ipv6 enable
>end
>
>R6(config-if)#do sh ipv6 route
>IPv6 Routing Table - Default - 10 entries
>Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
> B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
> I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
> EX - EIGRP external
> O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
> ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
>R 2001::2/128 [120/2]
> via FE80::2, Serial0/1/0
>R 2001::5/128 [120/3]
> via FE80::2, Serial0/1/0
>LC 2001::6/128 [0/0]
> via Loopback6, receive
>C 2001::256:0/125 [0/0]
> via Serial0/1/0, directly connected
>L 2001::256:6/128 [0/0]
> via Serial0/1/0, receive
>C 2001:0:0:69::/64 [0/0]
> via Serial0/2/0, directly connected
>L 2001:0:0:69::6/128 [0/0]
> via Serial0/2/0, receive
>C 2001:0:0:70::/64 [0/0]
> via Serial0/2/1, directly connected
>L 2001:0:0:70::6/128 [0/0]
> via Serial0/2/1, receive
>L FF00::/8 [0/0]
> via Null0, receive
>
>R6(config-if)#do ping 2001:0:0:67::7
>
>Type escape sequence to abort.
>Sending 5, 100-byte ICMP Echos to 2001:0:0:67::7, timeout is 2 seconds:
>
>% No valid route for destination
>Success rate is 0 percent (0/1)
>
>--
>Regards,
>
>Joe Astorino - CCIE #24347 R&S
>Technical Instructor - IPexpert, Inc.
>Cell: +1.586.212.6107
>Fax: +1.810.454.0130
>Mailto: jastorino_at_ipexpert.com
>
>
>Blogs and organic groups at http://www.ccie.net
>
>_______________________________________________________________________
>Subscription information may be found at:
>http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Thu Sep 03 2009 - 09:01:09 ART

This archive was generated by hypermail 2.2.0 : Sun Oct 04 2009 - 07:42:02 ART