Hi guys,
I just started my lab journey, I'm sorry if I ask any questions that has
been asked before.
I'm doing IEWB 4.1 vol 2 Lab 1 BGP section using dynamips. Although it's not
on the task but I have a question about the route-reflector-client
configuration to clarify my knowledge.
From the topology requirement, R5 is the Route Reflector for R3, R4, R6 for
AS 100. R3 & R6 are connected to AS 54. The task mainly to configure local
preference to advertise from R6 & BB3 link. The question is, why I can't see
the route advertised from R6 with local preference 200 at R4? Is this my
miss configuration or it is how the Route Reflector work? Or is this due to
I'm using dynamips?
Thank you very much for all comments in advance. Any comment is much
appreciated.
Cheers,
rpratikno
BB1 -- R3 --- R5 -- R6 -- BB3
|
R4
Rack1R3#sh run | begin bgp
router bgp 100
no synchronization
bgp router-id 150.1.3.3
bgp log-neighbor-changes
neighbor 183.1.0.5 remote-as 100
neighbor 183.1.123.2 remote-as 200
neighbor 204.12.1.254 remote-as 54
no auto-summary
Rack1R4#sh run | begin bgp
router bgp 100
no synchronization
bgp router-id 150.1.4.4
bgp log-neighbor-changes
neighbor 150.1.5.5 remote-as 100
neighbor 150.1.5.5 update-source Loopback0
no auto-summary
Rack1R5#sh run | begin bgp
router bgp 100
no synchronization
bgp router-id 150.1.5.5
bgp log-neighbor-changes
neighbor 150.1.4.4 remote-as 100
neighbor 150.1.4.4 update-source Loopback0
neighbor 150.1.4.4 route-reflector-client
neighbor 150.1.6.6 remote-as 100
neighbor 150.1.6.6 update-source Loopback0
neighbor 150.1.6.6 route-reflector-client
neighbor 183.1.0.3 remote-as 100
neighbor 183.1.0.3 route-reflector-client
neighbor 183.1.0.3 next-hop-self
neighbor 183.1.105.10 remote-as 200
no auto-summary
Rack1R6#sh run | begin bgp
router bgp 100
no synchronization
bgp router-id 150.1.6.6
bgp log-neighbor-changes
neighbor 54.1.1.254 remote-as 54
neighbor 54.1.1.254 route-map AS-54 in
neighbor 150.1.5.5 remote-as 100
neighbor 150.1.5.5 update-source Loopback0
no auto-summary
!
ip as-path access-list 54 permit _54$
!
!
route-map CONNECTED_VLAN6 permit 10
match interface Ethernet0/1
!
route-map AS-54 permit 10
match as-path 54
set local-preference 200
!
route-map AS-54 permit 1000
Rack1R6#sh ip bgp
BGP table version is 16, local router ID is 150.1.6.6
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 28.119.16.0/24 54.1.1.254 200 0 54 i
* i 204.12.1.254 0 100 0 54 i
*> 28.119.17.0/24 54.1.1.254 200 0 54 i
* i 204.12.1.254 0 100 0 54 i
* i112.0.0.0 204.12.1.254 0 100 0 54 50 60 i
*> 54.1.1.254 0 0 54 50 60 i
* i113.0.0.0 204.12.1.254 0 100 0 54 50 60 i
*> 54.1.1.254 0 0 54 50 60 i
* i114.0.0.0 204.12.1.254 0 100 0 54 i
*> 54.1.1.254 0 200 0 54 i
* i115.0.0.0 204.12.1.254 0 100 0 54 i
*> 54.1.1.254 0 200 0 54 i
* i116.0.0.0 204.12.1.254 0 100 0 54 i
*> 54.1.1.254 0 200 0 54 i
* i117.0.0.0 204.12.1.254 0 100 0 54 i
*> 54.1.1.254 0 200 0 54 i
* i118.0.0.0 204.12.1.254 0 100 0 54 i
*> 54.1.1.254 0 200 0 54 i
* i119.0.0.0 204.12.1.254 0 100 0 54 i
*> 54.1.1.254 0 200 0 54 i
*>i205.90.31.0 183.1.105.10 0 100 0 200 254 ?
*>i220.20.3.0 183.1.105.10 0 100 0 200 254 ?
*>i222.22.2.0 183.1.105.10 0 100 0 200 254 ?
Rack1R5#sh ip bgp
BGP table version is 14, local router ID is 150.1.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
* i28.119.16.0/24 54.1.1.254 0 200 0 54 i
*>i 204.12.1.254 0 100 0 54 i
* i28.119.17.0/24 54.1.1.254 0 200 0 54 i
*>i 204.12.1.254 0 100 0 54 i
*>i112.0.0.0 204.12.1.254 0 100 0 54 50 60 i
* i 54.1.1.254 0 100 0 54 50 60 i
*>i113.0.0.0 204.12.1.254 0 100 0 54 50 60 i
* i 54.1.1.254 0 100 0 54 50 60 i
*>i114.0.0.0 204.12.1.254 0 100 0 54 i
* i 54.1.1.254 0 200 0 54 i
*>i115.0.0.0 204.12.1.254 0 100 0 54 i
* i 54.1.1.254 0 200 0 54 i
*>i116.0.0.0 204.12.1.254 0 100 0 54 i
* i 54.1.1.254 0 200 0 54 i
*>i117.0.0.0 204.12.1.254 0 100 0 54 i
* i 54.1.1.254 0 200 0 54 i
*>i118.0.0.0 204.12.1.254 0 100 0 54 i
* i 54.1.1.254 0 200 0 54 i
*>i119.0.0.0 204.12.1.254 0 100 0 54 i
* i 54.1.1.254 0 200 0 54 i
* i205.90.31.0 183.1.123.2 0 100 0 200 254 ?
*> 183.1.105.10 0 200 254 ?
* i220.20.3.0 183.1.123.2 0 100 0 200 254 ?
*> 183.1.105.10 0 200 254 ?
* i222.22.2.0 183.1.123.2 0 100 0 200 254 ?
*> 183.1.105.10 0 200 254 ?
Rack1R4#sh ip bgp
BGP table version is 20, local router ID is 150.1.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i28.119.16.0/24 204.12.1.254 0 100 0 54 i
*>i28.119.17.0/24 204.12.1.254 0 100 0 54 i
*>i112.0.0.0 204.12.1.254 0 100 0 54 50 60 i
*>i113.0.0.0 204.12.1.254 0 100 0 54 50 60 i
*>i114.0.0.0 204.12.1.254 0 100 0 54 i
*>i115.0.0.0 204.12.1.254 0 100 0 54 i
*>i116.0.0.0 204.12.1.254 0 100 0 54 i
*>i117.0.0.0 204.12.1.254 0 100 0 54 i
*>i118.0.0.0 204.12.1.254 0 100 0 54 i
*>i119.0.0.0 204.12.1.254 0 100 0 54 i
*>i205.90.31.0 183.1.105.10 0 100 0 200 254 ?
*>i220.20.3.0 183.1.105.10 0 100 0 200 254 ?
*>i222.22.2.0 183.1.105.10 0 100 0 200 254 ?
Blogs and organic groups at http://www.ccie.net
Received on Thu Aug 06 2009 - 11:29:47 ART
This archive was generated by hypermail 2.2.0 : Tue Sep 01 2009 - 05:43:56 ART