Hello Rich & Bryan,
Thank you so much for considering my question.
I found the issue. Though the source interface is specified as 10.1.7.7, the
rpf check is performed against the outgoing interface 10.1.37.7.
R2#
04:50:02: IP(0): s=10.1.37.7 (Serial2/0.1) d=224.78.78.78 id=51, ttl=252,
prot=1, len=104(100), RPF lookup failed for source
04:50:02: IP(0): s=10.1.37.7 (Serial2/0.1) d=224.78.78.78 id=51, ttl=252,
prot=1, len=104(100), not RPF interface
04:50:03: IP(0): s=10.1.37.7 (Serial2/0.1) d=224.78.78.78 id=52, ttl=252,
prot=1, len=104(100), not RPF interface
R2#sh ip rpf 10.1.37.7
RPF information for ? (10.1.37.7) failed, no route exists
R2#sh ip rpf 10.1.7.7
RPF information for ? (10.1.7.7)
RPF interface: Serial2/0.1
RPF neighbor: ? (150.1.12.1)
RPF route/mask: 10.1.7.0/24
RPF type: mbgp
So I advertised 10.1.37.0 network on R1 in BGP. But this requirement is not
given in the question. I am not sure if this is mandatory.
On R1
router bgp 1
!
address-family ipv4
network 10.1.37.0 mask 255.255.255.0
exit-address-family
!
address-family ipv4 multicast
network 10.1.37.0 mask 255.255.255.0
exit-address-family
SW1#ping 224.78.78.78 source 10.1.7.7 repeat 2
Type escape sequence to abort.
Sending 2, 100-byte ICMP Echos to 224.78.78.78, timeout is 2 seconds:
Packet sent with a source address of 10.1.7.7
Reply to request 0 from 10.1.68.8, 1652 ms
Reply to request 1 from 10.1.68.8, 608 ms
R2#
04:57:28: IP(0): s=10.1.37.7 (Serial2/0.1) d=224.78.78.78 (FastEthernet0/0)
id=53, ttl=252, prot=1, len=100(100), mforward
R2#
04:57:39: IP(0): s=10.1.37.7 (Serial2/0.1) d=224.78.78.78 (FastEthernet0/0)
id=54, ttl=252, prot=1, len=100(100), mforward
I am not sure if that is a weird situation but everything works fine after
publishing 10.1.37.0 network on R1 in BGP.
--- On Fri, 24/7/09, Bryan Bartik <bbartik_at_ipexpert.com> wrote:
From: Bryan Bartik <bbartik_at_ipexpert.com>
Subject: Re: Multicast BGP - INE Vol1
To: "Rich Collins" <nilsi2002_at_gmail.com>
Cc: "Vignesh Sethuraman" <sethuvignesh_at_gmail.com>, "Cisco certification"
<ccielab_at_groupstudy.com>, "vignesh sethuraman" <sethuvignesh_at_yahoo.co.in>
Date: Friday, 24 July, 2009, 10:51 PM
Do you have PIM on the interface with the join command?
On Fri, Jul 24, 2009 at 8:01
AM, Rich Collins <nilsi2002_at_gmail.com> wrote:
Hi,
I don't have that lab workbook but was thinking that you could try
some debugging (debug ip mpacket) on R2. Also you might want to run
some more pings or multicast traffic since the ip mroute count is just
1.
-Rich
On Wed, Jul 22, 2009 at 4:43 PM, Vignesh
Sethuraman<sethuvignesh_at_gmail.com> wrote:
> Hello Experts,
>
> I am not able to pass multicast traffic from SW1 to SW2. My unicast
routing
> is working perfectly.
>
> *SW1#ping 10.1.8.8 source 10.1.7.7*
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 10.1.8.8, timeout is 2 seconds:
> Packet sent with a source address of 10.1.7.7
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 168/375/936 ms
>
> * But multicast traffic is not working with Multicast BGP*.
>
> SW2(config)#interface FastEthernet1/6
> ip igmp join-group 224.1.1.1
>
>
> *SW1#ping 224.1.1.1 source 10.1.7.7 *
>
> Type escape sequence to abort.
> Sending 1, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:
> Packet sent with a source address of 10.1.37.7
> *.
> SW1#*
>
> The following is my configuration.
>
> *R1*:
> hostname R1
> !
> interface Loopback0
> ip address 150.1.1.1 255.255.255.255
> no clns route-cache
> !
> interface FastEthernet0/0
> ip address 150.1.15.1 255.255.255.0
> duplex full
> no clns route-cache
> !
> interface Serial2/0
> no ip address
> encapsulation frame-relay
> serial restart-delay 0
> no frame-relay inverse-arp
> no clns route-cache
> !
> interface Serial2/0.1 point-to-point
> ip address 150.1.12.1 255.255.255.0
> ip pim dense-mode
> frame-relay interface-dlci 102
> !
> interface Serial2/1
> ip address 150.1.13.1 255.255.255.0
> ip pim dense-mode
> serial restart-delay 0
> clockrate 64000
> no clns route-cache
> !
> router ospf 1
> router-id 150.1.1.1
> log-adjacency-changes
> network 150.1.1.1 0.0.0.0 area 0
> network 150.1.13.0 0.0.0.255 area 0
> default-information originate always
> !
> router bgp 1
> bgp log-neighbor-changes
> neighbor 150.1.12.2 remote-as 2
> neighbor 150.1.15.5 remote-as 3
> !
> address-family ipv4
> neighbor 150.1.12.2 activate
> neighbor 150.1.15.5 activate
> no auto-summary
> no synchronization
> network 10.1.7.0 mask 255.255.255.0
> exit-address-family
> !
> address-family ipv4 multicast
> neighbor 150.1.12.2 activate
> no auto-summary
> network 10.1.7.0 mask 255.255.255.0
> exit-address-family
>
> *R2*:
> hostname R2
> !
> interface Loopback0
> ip address 150.1.2.2 255.255.255.255
> no clns route-cache
> !
> interface FastEthernet0/0
> ip address 150.1.24.2 255.255.255.0
> ip pim dense-mode
> duplex full
> no clns route-cache
> !
> interface Serial2/0
> no ip address
> encapsulation frame-relay
> serial restart-delay 0
> no frame-relay inverse-arp
> no clns route-cache
> !
> interface Serial2/0.1 point-to-point
> ip address 150.1.12.2 255.255.255.0
> ip pim dense-mode
> frame-relay interface-dlci 201
> !
> router bgp 2
> bgp log-neighbor-changes
> neighbor 150.1.12.1 remote-as 1
> neighbor 150.1.24.4 remote-as 2
> !
> address-family ipv4
> neighbor 150.1.12.1 activate
> neighbor 150.1.24.4 activate
> neighbor 150.1.24.4 next-hop-self
> no auto-summary
> no synchronization
> exit-address-family
> !
> address-family ipv4 multicast
> neighbor 150.1.12.1 activate
> neighbor 150.1.24.4 activate
> neighbor 150.1.24.4 next-hop-self
> no auto-summary
> exit-address-family
>
> *R3*:
> hostname R3
> !
> interface Loopback0
> ip address 150.1.3.3 255.255.255.255
> !
> interface Ethernet0/0
> ip address 10.1.37.3 255.255.255.0
> ip pim dense-mode
> full-duplex
> !
> interface Serial1/2
> ip address 150.1.13.3 255.255.255.0
> ip pim dense-mode
> serial restart-delay 0
> !
> interface Serial1/3
> no ip address
> shutdown
> serial restart-delay 0
> !
> router ospf 1
> router-id 150.1.3.3
> log-adjacency-changes
> network 10.1.37.0 0.0.0.255 area 0
> network 150.1.0.0 0.0.255.255 area 0
>
> *R4*:
> hostname R4
> !
> interface Loopback0
> ip address 150.1.4.4 255.255.255.255
> !
> interface Ethernet0/0
> ip address 150.1.24.4 255.255.255.0
> ip pim dense-mode
> full-duplex
> !
> interface Serial1/0
> no ip address
> encapsulation frame-relay
> serial restart-delay 0
> no frame-relay inverse-arp
> !
> interface Serial1/0.1 point-to-point
> ip address 150.1.45.4 255.255.255.0
> ip pim dense-mode
> frame-relay interface-dlci 405
> !
> router bgp 2
> bgp log-neighbor-changes
> neighbor 150.1.24.2 remote-as 2
> neighbor 150.1.45.5 remote-as 3
> !
> address-family ipv4
> neighbor 150.1.24.2 activate
> neighbor 150.1.24.2 next-hop-self
> neighbor 150.1.45.5 activate
> no auto-summary
> no synchronization
> exit-address-family
> !
> address-family ipv4 multicast
> neighbor 150.1.24.2 activate
> neighbor 150.1.24.2 next-hop-self
> neighbor 150.1.45.5 activate
> no auto-summary
> no synchronization
> exit-address-family
>
> *R5*:
> hostname R5
> !
> interface Loopback0
> ip address 150.1.5.5 255.255.255.255
> !
> interface Ethernet0/0
> ip address 150.1.56.5 255.255.255.0
> ip pim dense-mode
> full-duplex
> !
> interface Ethernet0/1
> ip address 150.1.15.5 255.255.255.0
> full-duplex
> !
> interface Serial1/0
> no ip address
> encapsulation frame-relay
> serial restart-delay 0
> no frame-relay inverse-arp
> !
> interface Serial1/0.1 point-to-point
> ip address 150.1.45.5 255.255.255.0
> ip pim dense-mode
> frame-relay interface-dlci 504
> !
> router ospf 1
> router-id 150.1.5.5
> log-adjacency-changes
> network 150.1.5.5 0.0.0.0 area 0
> network 150.1.45.0 0.0.0.255 area 0
> network 150.1.56.0 0.0.0.255 area 0
> default-information originate always
> !
> router bgp 3
> bgp log-neighbor-changes
> neighbor 150.1.15.1 remote-as 1
> neighbor 150.1.45.4 remote-as 2
> !
> address-family ipv4
> neighbor 150.1.15.1 activate
> neighbor 150.1.45.4 activate
> no auto-summary
> no synchronization
> network 10.1.8.0 mask 255.255.255.0
> exit-address-family
> !
> address-family ipv4 multicast
> neighbor 150.1.45.4 activate
> no auto-summary
> no synchronization
> exit-address-family
>
>
> *R6*:
> hostname R6
> !
> interface Loopback0
> ip address 150.1.6.6 255.255.255.255
> !
> interface Ethernet0/0
> ip address 150.1.56.6 255.255.255.0
> ip pim dense-mode
> full-duplex
> !
> interface Ethernet0/1
> ip address 10.1.68.6 255.255.255.0
> ip pim dense-mode
> full-duplex
> !
> router ospf 1
> router-id 150.1.6.6
> log-adjacency-changes
> network 10.1.68.0 0.0.0.255 area 0
> network 150.1.0.0 0.0.255.255 area 0
>
> *The issue am facing is RPF check is failing on R2*.
>
> *R2#sh ip mroute count *
> Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
>
> Group: 224.1.1.1, Source count: 1, Packets forwarded: 0, Packets received:
1
> Source: 10.1.37.7/32, Forwarding: 0/0/0/0, *Other: 1/1/0*
>
> Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets
received:
>
> *R2#sh ip bgp ipv4 multicast *
> BGP table version is 2, local router ID is 150.1.2.2
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal,
> r RIB-failure, S Stale
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> **> 10.1.7.0/24 150.1.12.1 75 0 1 i*
>
> *R2#sh ip bgp ipv4 unicast *
> BGP table version is 4, local router ID is 150.1.2.2
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal,
> r RIB-failure, S Stale
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> **> 10.1.7.0/24 150.1.12.1 75 0 1 i*
> *>i10.1.8.0/24 150.1.24.4 21 100 0 3 i
> * 150.1.12.1 0 1 3 i
>
> *R2#sh ip rpf 10.1.7.7*
> RPF information for ? (10.1.7.7)
> * RPF interface: Serial2/0.1
> RPF neighbor: ? (150.1.12.1)
> RPF route/mask: 10.1.7.0/24
> RPF type: mbgp*
> RPF recursion count: 0
> Doing distance-preferred lookups across tables
>
> *R2#sh ip mroute 224.1.1.1*
> IP Multicast Routing Table
> Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C -
Connected,
> L - Local, P - Pruned, R - RP-bit set, F - Register flag,
> T - SPT-bit set, J - Join SPT, M - MSDP created entry,
> X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
> U - URD, I - Received Source Specific Host Report, Z - Multicast
> Tunnel
> Y - Joined MDT-data group, y - Sending to MDT-data group
> Outgoing interface flags: H - Hardware switched, A - Assert winner
> Timers: Uptime/Expires
> Interface state: Interface, Next-Hop or VCD, State/Mode
>
> (*, 224.1.1.1), 00:00:24/stopped, RP 0.0.0.0, flags: D
> Incoming interface: Null, RPF nbr 0.0.0.0
> Outgoing interface list:
> FastEthernet0/0, Forward/Dense, 00:00:24/00:00:00
> Serial2/0.1, Forward/Dense, 00:00:24/00:00:00
>
> *(10.1.37.7, 224.1.1.1), 00:00:24/00:02:35, flags:
> Incoming interface: Null, RPF nbr 0.0.0.0
> Outgoing interface list:*
> Serial2/0.1, Forward/Dense, 00:00:24/00:00:00
> FastEthernet0/0, Forward/Dense, 00:00:24/00:00:00
>
> I am not sure why the RPF check is failing on R2 and incoming interface is
> showing Null.
>
> Could you please someone help me in solving this issue.
>
> Thanks,
> Vignesh
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Sat Jul 25 2009 - 01:56:37 ART
This archive was generated by hypermail 2.2.0 : Sat Aug 01 2009 - 13:10:23 ART