Re: PIM Neighbor

From: Anantha Subramanian Natarajan <anantha.natarajan_at_gravitant.com>
Date: Wed, 8 Jul 2009 13:39:47 -0500

Hi Andre Browning,

  Thanks for the response.Sorry couldn't clearly explain you the topology in
the earlier email.Here by attaching an hand drawn topology diagram.Hopefully
this may add soem information on the topology to you.Yes verified the
frame-realy connectivity as far as I saw.Here by providing the configuration
which I was done for this scenario.Unfortunately didn't have "show
frame-relay map" output to verify your point at this moment.But hopefully
will try to recreate the same and test it.Meantime provding you the relavent
configuration done .

*R2*

interface Loopback0
 ip address 150.1.2.2 255.255.255.0
 ip pim sparse-dense-mode
!
interface FastEthernet0/0
 ip address 183.1.28.2 255.255.255.0
 ip pim sparse-dense-mode
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 183.1.123.2 255.255.255.0
 ip accounting precedence input
 ip accounting precedence output
 ip pim sparse-dense-mode
 encapsulation frame-relay
 no ip split-horizon eigrp 100
 frame-relay map ip 183.1.123.1 201 broadcast
 frame-relay map ip 183.1.123.3 203 broadcast
 no frame-relay inverse-arp
!
ip pim send-rp-discovery Loopback0 scope 16

*R3*

interface Loopback0
 ip address 150.1.3.3 255.255.255.0
 ip pim sparse-dense-mode
!
interface Ethernet0/0
 ip address 204.12.1.3 255.255.255.0
 ip pim sparse-dense-mode
 ip nat outside
 ip virtual-reassembly
 half-duplex
!
interface Serial1/0
 ip address 183.1.123.3 255.255.255.0
 ip accounting precedence input
 ip accounting precedence output
 ip pim sparse-dense-mode
 ip nat inside
 ip virtual-reassembly
 encapsulation frame-relay
 frame-relay map ip 183.1.123.1 302
 frame-relay map ip 183.1.123.2 302 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial1/1
 ip address 183.1.0.3 255.255.255.0
 ip pim sparse-dense-mode
 ip nat inside
 ip virtual-reassembly
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf dead-interval minimal hello-multiplier 3
 ip ospf priority 0
 frame-relay map ip 183.1.0.4 315 broadcast
 frame-relay map ip 183.1.0.5 315 broadcast
 no frame-relay inverse-arp
!
ip pim send-rp-announce Loopback0 scope 16

*R5*
**
interface Ethernet0/0
 ip address 183.1.105.5 255.255.255.0
 ip pim sparse-dense-mode
 half-duplex
 ipv6 address 2001:CC1E:1:505::/64 eui-64
 ipv6 rip CISCO enable
 standby 1 ip 183.1.105.254
 standby 1 preempt
 standby 1 track Serial0/0 100
!
interface Serial0/0
 ip address 183.1.0.5 255.255.255.0
 ip pim sparse-dense-mode
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf dead-interval minimal hello-multiplier 3
 ip ospf priority 255
 frame-relay map ip 183.1.0.3 513 broadcast
 frame-relay map ip 183.1.0.4 504 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco

Kindly let me know,if you see any issue on the above config or any clarity
on the issue.

Thanks for the assistance

Regards
Anantha Subramanian Natarajan

On Wed, Jul 8, 2009 at 11:17 AM, Aundra Browning <
aundra.browning_at_earthlink.net> wrote:

> Can't really make out the topology below, but have you verified your
> frame-relay connectivity? Are you sure you haven't left unnecessary
> frame-relay mappings in place that could have been learned with inverse
> ARP?
>
> Aundra (Andre) Browning
> CCIE #21901 (R&S)
>
> -----Original Message-----
> From: nobody_at_groupstudy.com [mailto:nobody_at_groupstudy.com] On Behalf Of
> Anantha Subramanian Natarajan
> Sent: Wednesday, July 08, 2009 12:02 AM
> To: Cisco certification
> Subject: PIM Neighbor
>
> Hi All,
>
> I have a question based on the lab exercise task which I was doing.The
> physical topology looks like below
>
>
> R1
> |
> R2(Hub-183.1.123.2/24) ---FR Cloud -------(
> 183.1.123.3/24)R3(183.1.0.3/24) ------------ FR Cloud ------
> -R5(Hub-183.1.0.5/24)
>
> |
>
> R4
>
> PIM sparse-dense-mode is configured on R2 ,R3 and R5 serial frame-relay
> interfaces in addition to enabling on R2,R3 loopback0 interface.R2 is
> asked
> to configure as Mapping agent fo auto-rp and R3 is asked to configure as
> auto-rp for all the multicast goup.Was able to test multicast by joining a
> groupon R5 ethernet interface which is also enabled for PIM by pinging from
> R2 ethernet interface enabled for PIM.
>
> The question is ,1) when I performed "show ip pim neighbor command" on R5,I
> see both R3 ip address 183.1.0.3 and R2 ip address 183.1.123.3.I am trying
> to understand,why it show the R2 ip address on it.
>
> Rack1R5#sh ip pim neighbor
> PIM Neighbor Table
> Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
> S - State Refresh Capable
> Neighbor Interface Uptime/Expires Ver DR
> Address
> Prio/Mode
> *183.1.123.2 Serial0/0 00:08:02/00:01:33 v2 1 / DR
> S
> *183.1.0.3 Serial0/0 00:08:12/00:01:23 v2 1 / S
>
> 2) Also on R3,the show ip pim neighbor o/p is as below
>
> Rack1R3#sh ip pim neighbor
> PIM Neighbor Table
> Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
> S - State Refresh Capable
> Neighbor Interface Uptime/Expires Ver DR
> Address
> Prio/Mode
> 183.1.123.2 Serial1/0 00:10:07/00:01:27 v2 1 / S
> 183.1.0.5 Serial1/1 00:07:20/00:01:29 v2 1 / S
> 183.1.123.2 Serial1/1 00:09:37/00:01:27 v2 1 / DR S
>
> I am not sure,why it showing 183.1.123.2 learned through both on S1/0 and
> S1/1.I ran debug ip pim hello and on the debug o/p,I am able to see hello
> received from 183.1.123.2 on both s1/1 and s1/0.I couldn't understand
> that.Any help is really appreciated.
>
>
> Rack1R3#debug ip pim hello
> PIM-HELLO debugging is on
> Rack1R3#
> *Mar 1 01:33:46.092: PIM(0): Received v2 hello on Serial1/0 from
> 183.1.123.2
> Mar 1 01:33:46.092: PIM(0): Neighbor (183.1.123.2) Hello GENID =
> 2740287763
> Mar 1 01:33:46.100: PIM(0): Received v2 hello on Serial1/1 from
> 183.1.123.2
> Mar 1 01:33:46.100: PIM(0): Neighbor (183.1.123.2) Hello GENID =
> 2740287763
> *Mar 1 01:33:48.372: PIM(0): Received v2 hello on Serial1/1 from 183.1.0.5
> Mar 1 01:33:48.376: PIM(0): Neighbor (183.1.0.5) Hello GENID = 706508139
> Mar 1 01:33:49.124: PIM(0): Send periodic v2 Hello on Serial1/0 with GenID
> = 2915304491
>
> Thanks for the help.
>
> Regards
> Anantha Subramanian Natarajan
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Wed Jul 08 2009 - 13:39:47 ART

This archive was generated by hypermail 2.2.0 : Sat Aug 01 2009 - 13:10:22 ART