RE: GRT to VRF Communication

From: Joseph L. Brunner <joe_at_affirmedsystems.com>
Date: Fri, 19 Jun 2009 15:09:05 -0400

The problem sir is you are trying GRT to VRF via broadcast interfaces :)

Try using my method of loopback to loopback;

-OSPF is neighboring between two tunnel interfaces on same router
-Both Tunnel interfaces sourced from GRT
-Both Tunnel interfaces destined to GRT
-One tunnel is in GRT
-One tunnel is in VRF
-Performance tested at 50Mbps+ on 3845 between GRT and VRF

ip vrf MCS
 rd 45301:100
 route-target export 45301:100
 route-target import 45301:100

router ospf 100 vrf MCS
 router-id 192.168.100.1
 log-adjacency-changes
 area 1 filter-list prefix filter-from-backbone-ospf in
 redistribute bgp 45301 subnets
 network 157.15.10.1 0.0.0.0 area 1
 network 172.23.254.254 0.0.0.0 area 0
 default-information originate always
!
router ospf 1
 router-id 172.24.1.1
 log-adjacency-changes
 network 172.23.1.1 0.0.0.0 area 0
 network 172.23.254.253 0.0.0.0 area 0
 network 172.24.1.1 0.0.0.0 area 0

interface Loopback0
 ip address 64.195.216.190 255.255.255.248
!
interface Loopback100
 ip address 172.24.1.1 255.255.255.255

interface Tunnel100
 description VRF_MCS_BRIDGE_TO_GLOBAL_ROUTING_TABLE
 bandwidth 50000
 ip vrf forwarding MCS
 ip address 172.23.254.254 255.255.255.252
 load-interval 30
 tunnel source Loopback0
 tunnel destination 172.24.1.1
!
interface Tunnel200
 description GLOBAL_ROUTING_TABLE_BRIDGE_TO_VRF_MCS
 bandwidth 50000
 ip address 172.23.254.253 255.255.255.252
 ip virtual-reassembly
 load-interval 30
 tunnel source Loopback100
 tunnel destination 64.195.216.190

-----Original Message-----
From: nobody_at_groupstudy.com [mailto:nobody_at_groupstudy.com] On Behalf Of Akhtar Rasool
Sent: Friday, June 19, 2009 2:06 PM
To: Cisco certification
Subject: GRT to VRF Communication

Hi,

I am stuck in enabling communication between GRT & VRF in 7609. I have tried
following thing but no success & I am stuck in a project migration b/c of
this. Any feedback would be appreciated.

RouterA:
int vlan10
ip add 1.1.1.1 255.255.255.0

int vlan 100
ip vrf forwarding CUST
ip add 2.2.2.2 255.255.255.0

ip route 2.2.2.2 255.255.255.255 vlan100
ip route vrf CUST 1.1.1.1 255.255.255.255 vlan10

arp 2.2.2.2 aa11.bb11.cc11 arpa
arp vrf SHARED 1.1.1.1 aa22.bb22.cc22 arpa

RouterA:
ping 2.2.2.2 source 1.1.1.1 (timeouts)
ping 1.1.1.1 source 2.2.2.2 (timeouts)

Regards,

Akhtar

Blogs and organic groups at http://www.ccie.net
Received on Fri Jun 19 2009 - 15:09:05 ART

This archive was generated by hypermail 2.2.0 : Wed Jul 01 2009 - 20:02:37 ART