RE: QoS interpretation

From: marina ferreira <marinalf_at_msn.com>
Date: Sat, 23 May 2009 15:04:25 +0000

question:

what if you have a 10MB link from your data center to the internet for
specific customer services (web page stress test, traffic simulation, etc) and
you have to reserve:

1MB - client A

2MB - client B

3MB - client C

so on....

All this is to simulate what an user can have at home and what the response
time is when accessing customer online resources as well as the link
utilization.

The traffic flow is: dedicated servers (robots) -------> SW1 ----
gi0/0.1___R1___gi0/0.2-------> ISP cloud --------> INTERNET

The policy is applied on both gi0/0.1 and gi0/0.2 as "input" matching packets
as follows:

ip access-list extended Client-A-IN
 permit ip any host 10.10.10.1

ip access-list extended Client-A-OUT

 permit ip host 10.10.10.1 any

class-map match-all Client-A-IN

 match access-group name Client-A-IN

class-map match-all Client-A-OUT
 match access-group name Client-A-OUT

policy-map class QoS_IN

class-map Client-A-IN
    police 1024000 conform-action transmit exceed-action drop
policy-map class QoS_OUT

class-map Client-A-OUT
    police 1024000 conform-action transmit exceed-action drop

interface gi0/0.1

service-policy input QOS_OUT

interface gi0/0.2

service-policy input QOS_IN

The policy is input on both (sub)interfaces LAN/WAN matching the flow in and
out, and there is no policy coming from the ISP for these customer services,
they are only policing the dedicated 10MB. Now, is this scenario a shaping out
matter or policing in is the way to go?

Thanks for your inputs.

> From: jscrivener_at_ipexpert.com
> To: ccieaz_at_googlemail.com; mail.to.gabriel_at_gmail.com
> CC: ccielab_at_groupstudy.com
> Subject: RE: QoS interpretation
> Date: Wed, 15 Apr 2009 00:28:32 -0400
>
> One of my simple rules of thumb is that if in doubt as to policing or
> shaping for a particular question: policing is normally inbound, whereas
> shaping is normally outbound (for the reasons provided earlier). Also, look
> for the particular measurement values or rates given in the question (i.e a
> reference to a Bc of 6000 or a PIR of 256kbps) as that can sometimes
> indicate one way or another which methods are available.
>
> Cheers,
>
> Jared Scrivener CCIE3 #16983 (R&S, Security, SP), CISSP
> Sr. Technical Instructor - IPexpert, Inc.
> Telephone: +1.810.326.1444
> Fax: +1.810.454.0130
> Mailto: jscrivener_at_ipexpert.com
>
>
> -----Original Message-----
> From: nobody_at_groupstudy.com [mailto:nobody_at_groupstudy.com] On Behalf Of
Nick
> Sent: Tuesday, 14 April 2009 9:49 PM
> To: Gabriel
> Cc: Cisco certification
> Subject: Re: QoS interpretation
>
> Thank you for you help. I see why shaping is used in this question now. :)
>
> Nick
>
>
>
> 2009/4/15 Gabriel <mail.to.gabriel_at_gmail.com>
>
> > You police as the provider, you shape as the customer. In these
> > examples, you are the customer and the owner of BBn is the provider,
> > so he is policing and you should shape.
> >
> > If you think about it, it makes sense this way: if you're the
> > provider, you don't care what happens to the customer's excess
> > traffic: you promised the customer X mbps and that's all he gets. If
> > you're the customer with a policed pipe, you want to do the best you
> > can to make good use of that X mbps for your most important traffic,
> > so you shape to fit the rate that's being policed by the provider.
> >
> > -Gabriel
> >
> > On Tue, Apr 14, 2009 at 6:24 PM, Nick <ccieaz_at_googlemail.com> wrote:
> > > Hi all,
> > >
> > > I still have trouble sometimes with QoS question interpretation.
> > >
> > > Take this example from IE lab 18
> > >
> > > ".... BB2 will only allow R5 to send traffic across this link at a
> > maximum
> > > of 2.5mpbs. BB3 will only allow R5 to send traffic into its network at
a
> > > maximum rate of 3mpbs"
> > >
> > > How should I interpret this?
> > >
> > > I think that you could do this with shaping, policing or bandwidth
> > > statement. But which is best and why?
> > >
> > > Any tips would be great.
> > >
> > > (SG uses shaping)
> > >
> > > Thanks
> > >
> > > Nick
> > >
> > >
> > > Blogs and organic groups at http://www.ccie.net
> > >
> > > _______________________________________________________________________
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Sat May 23 2009 - 15:04:25 ART

This archive was generated by hypermail 2.2.0 : Mon Jun 01 2009 - 07:04:43 ART