R0
interface Loopback0
ip address 100.100.0.100 255.255.255.0
!
interface Loopback1
ip address 100.100.1.100 255.255.255.0
!
interface Loopback2
ip address 100.100.2.100 255.255.255.0
!
interface Loopback3
ip address 100.100.3.100 255.255.255.0
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.252
serial restart-delay 0
!
interface Serial0/1
ip address 20.1.1.1 255.255.255.252
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
network 10.1.1.1 0.0.0.0 area 0
network 20.1.1.1 0.0.0.0 area 0
network 100.100.0.100 0.0.0.0 area 0
network 100.100.1.100 0.0.0.0 area 0
network 100.100.2.100 0.0.0.0 area 0
network 100.100.3.100 0.0.0.0 area 0
distance 90 1.1.0.0 0.0.0.255 SELECT_12.1.1.0_from_R1
!
ip http server
ip forward-protocol nd
!
!
!
!
ip access-list standard ONLY_R1_LOOPBACKS
permit 1.1.0.0
ip access-list standard SELECT_12.1.1.0_from_R1
permit 12.1.1.0
ip access-list standard SELECT_12.1.exit
!
!
r1
vinterface Loopback0
ip address 1.1.0.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
ip address 10.1.1.2 255.255.255.252
serial restart-delay 0
!
interface Serial0/1
ip address 12.1.1.1 255.255.255.252
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
router-id 1.1.0.1
log-adjacency-changes
network 1.1.0.1 0.0.0.0 area 0
network 10.1.1.2 0.0.0.0 area 0
network 12.1.1.1 0.0.0.0 area 0
!
ip http server
ip forward-protocol nd
!
!
R2
interface Loopback0
ip address 2.2.0.2 255.255.255.0
!
interface Serial0/0
ip address 20.1.1.2 255.255.255.252
serial restart-delay 0
!
interface Serial0/1
ip address 12.1.1.2 255.255.255.252
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
router-id 2.2.0.2
log-adjacency-changes
network 2.2.0.2 0.0.0.0 area 0
network 12.1.1.2 0.0.0.0 area 0
network 20.1.1.2 0.0.0.0 area 0
!
..
R0#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.0.2 0 FULL/ - 00:00:30 20.1.1.2 Serial0/1
1.1.0.1 0 FULL/ - 00:00:35 10.1.1.2 Serial0/0
R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.0.2 0 FULL/ - 00:00:38 12.1.1.2 Serial0/1
100.100.3.100 0 FULL/ - 00:00:37 10.1.1.1 Serial0/0
vR2#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
100.100.3.100 0 FULL/ - 00:00:34 20.1.1.1 Serial0/0
1.1.0.1 0 FULL/ - 00:00:39 12.1.1.1 Serial0/1
R2#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
100.100.3.100 0 FULL/ - 00:00:34 20.1.1.1 Serial0/0
1.1.0.1 0 FULL/ - 00:00:39 12.1.1.1 Serial0/1
Thanking You
Yours Sincerely
Divin Mathew John
divinjohn_at_gmail.com
divin_at_dide3d.com
http://www.dide3d.com
+91 9945430983
+91 9846697191
+974 5008916
PGP PUBLIC KEY BLOCK @ http://www.dide3d.com/divin_Public_PGP_key.txt
Sent from Bangalore, KA, India
On Fri, May 22, 2009 at 2:38 AM, Salah ElShekeil
<salah.elshekeil_at_gmail.com>wrote:
> it's not a bug
>
> hard code the router-id in router 2 to 12.1.1.1 then try again
>
>
> HTH
>
> On Thu, May 21, 2009 at 11:13 PM, Divin Mathew John <divinjohn_at_gmail.com>wrote:
>
>> I have this problem. i am trying to change the A.D of a particular path in
>> OSPF using distance command. My config is pasted below.
>> Topology
>>
>> R0
>> interface Loopback0
>> ip address 100.100.0.100 255.255.255.0
>> !
>> interface Loopback1
>> ip address 100.100.1.100 255.255.255.0
>> !
>> interface Loopback2
>> ip address 100.100.2.100 255.255.255.0
>> !
>> interface Loopback3
>> ip address 100.100.3.100 255.255.255.0
>> !
>> interface Serial0/0
>> ip address 10.1.1.1 255.255.255.252
>> serial restart-delay 0
>> !
>> interface Serial0/1
>> ip address 20.1.1.1 255.255.255.252
>> serial restart-delay 0
>> !
>>
>> router ospf 1
>> log-adjacency-changes
>> network 10.1.1.1 0.0.0.0 area 0
>> network 20.1.1.1 0.0.0.0 area 0
>> network 100.100.0.100 0.0.0.0 area 0
>> network 100.100.1.100 0.0.0.0 area 0
>> network 100.100.2.100 0.0.0.0 area 0
>> network 100.100.3.100 0.0.0.0 area 0
>> distance 90 12.1.1.1 0.0.0.0 SELECT_12.1.1.0_from_R1
>> !
>> ip access-list standard SELECT_12.1.1.0_from_R1
>> permit 12.1.1.0
>>
>> R0#show ip ospf neighbor
>>
>> Neighbor ID Pri State Dead Time Address
>> Interface
>> 20.1.1.2 0 FULL/ - 00:00:37 20.1.1.2
>> Serial0/1
>> 12.1.1.1 0 FULL/ - 00:00:33 10.1.1.2
>> Serial0/0
>>
>> R0#sir
>> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
>> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>> E1 - OSPF external type 1, E2 - OSPF external type 2
>> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
>> level-2
>> ia - IS-IS inter area, * - candidate default, U - per-user static
>> route
>> o - ODR, P - periodic downloaded static route
>>
>> Gateway of last resort is not set
>>
>> 1.0.0.0/24 is subnetted, 1 subnets
>> O 1.1.0.0 [110/65] via 10.1.1.2, 00:01:35, Serial0/0
>> 2.0.0.0/32 is subnetted, 1 subnets
>> O 2.2.0.2 [110/65] via 20.1.1.2, 00:01:35, Serial0/1
>> 100.0.0.0/24 is subnetted, 4 subnets
>> C 100.100.0.0 is directly connected, Loopback0
>> C 100.100.1.0 is directly connected, Loopback1
>> C 100.100.2.0 is directly connected, Loopback2
>> C 100.100.3.0 is directly connected, Loopback3
>> 20.0.0.0/30 is subnetted, 1 subnets
>> C 20.1.1.0 is directly connected, Serial0/1
>> 10.0.0.0/30 is subnetted, 1 subnets
>> C 10.1.1.0 is directly connected, Serial0/0
>> * 12.0.0.0/30 is subnetted, 1 subnets
>> O 12.1.1.0 [90/128] via 20.1.1.2, 00:01:36, Serial0/1
>> [90/128] via 10.1.1.2, 00:01:36, Serial0/0*
>>
>> according to my distance command only the route from R1 should have
>> changed
>> its A.D. but here even though i specified the ROUTER-ID of the router
>> whose
>> path i need to change the A.D it doesn't change that... it changes the A.D
>> of all paths to the destination..! is this a BUG?
>>
>>
>> Thanking You
>>
>> Yours Sincerely
>>
>> Divin Mathew John
>> divinjohn_at_gmail.com
>> divin_at_dide3d.com
>> http://www.dide3d.com
>> +91 9945430983
>> +91 9846697191
>> +974 5008916
>> PGP PUBLIC KEY BLOCK @ http://www.dide3d.com/divin_Public_PGP_key.txt
>> Sent from Bangalore, KA, India
>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>>
>>
>>
>>
>>
>>
>>
>>
>
>
> --
> Salah
> CCIE# 24207
Blogs and organic groups at http://www.ccie.net
Received on Fri May 22 2009 - 02:53:38 ART
This archive was generated by hypermail 2.2.0 : Mon Jun 01 2009 - 07:04:43 ART