On Mon, May 11, 2009 at 2:26 PM, WW)W WWWW W <eshedalonie_at_gmail.com>
wrote:
> There won't be loops - Due to Originator ID
>
> See My Output
>
> Client Switch 3750 Configured
> =========================
> interface Loopback0
> ip address 200.1.1.1 255.255.255.0
> end
>
> interface Vlan1
> ip address 172.20.1.1 255.255.255.0
>
> router bgp 64512
> no synchronization
> bgp log-neighbor-changes
> network 10.0.0.0
> neighbor 172.20.1.2 remote-as 64512
> neighbor 172.20.1.2 transport path-mtu-discovery
> neighbor 172.20.1.3 remote-as 64512
> neighbor 172.20.1.3 transport path-mtu-discovery
> no auto-summary
> !
> ip classless
> ip route 10.0.0.0 255.0.0.0 Null0 254
>
> 2 Routers - which 1 of them is 3550 and second is 1841 Reflectors
> ==================================================
>
> Router 1841
> =================================
> interface Loopback0
> ip address 200.10.10.10 255.255.255.0
> end
>
> interface FastEthernet0/0
> ip address 172.20.1.3 255.255.255.0
> duplex auto
> speed auto
> end
>
> router bgp 64512
> no synchronization
> bgp log-neighbor-changes
> network 20.0.0.0
> neighbor 172.20.1.1 remote-as 64512
> neighbor 172.20.1.1 route-reflector-client
> neighbor 172.20.1.2 remote-as 64512
> no auto-summary
> !
>
> 3550
> =============
> interface Loopback0
> ip address 200.20.20.20 255.255.255.0
> end
>
> interface Vlan1
> ip address 172.20.1.2 255.255.255.0
> end
>
> router bgp 64512
> no synchronization
> bgp log-neighbor-changes
> network 30.0.0.0
> neighbor 172.20.1.1 remote-as 64512
> neighbor 172.20.1.1 route-reflector-client
> neighbor 172.20.1.3 remote-as 64512
> no auto-summary
> !
> ip route 30.0.0.0 255.0.0.0 Null0 254
>
>
> OUTPUT
> ===================
>
> Switch# Debug ip bgp updates
>
> Switch# Clear ip bgp 64512
> 01:08:19: %BGP-5-ADJCHANGE: neighbor 172.20.1.2 Up
> 01:08:19: BGP(0): 172.20.1.2 send UPDATE (format) 10.0.0.0/8, next
> 172.20.1.1, metric 0, path Local
> 01:08:19: %BGP-5-ADJCHANGE: neighbor 172.20.1.3 Up
> 01:08:19: BGP(0): updgrp 1 - 172.20.1.2 updates replicated for neighbors:
> 01:08:19: BGP(0): 172.20.1.3 send UPDATE (format) 10.0.0.0/8, next
> 172.20.1.1, metric 0, path Local
> 01:08:19: BGP(0): updgrp 1 - 172.20.1.3 updates replicated for neighbors:
> 01:08:19: BGP(0): 172.20.1.2 rcvd UPDATE w/ attr: nexthop 172.20.1.2,
> origin i, localpref 100, metric 0
> 01:08:19: BGP(0): 172.20.1.2 rcvd 30.0.0.0/8
> 01:08:19: BGP(0): 172.20.1.2 rcvd UPDATE w/ attr: nexthop 172.20.1.3,
> origin i, localpref 100, metric 0, originator 200.10.10.10, clusterlist
> 200.20.20.20
> 01:08:19: BGP(0): 172.20.1.2 rcvd 20.0.0.0/8
> 01:08:19: BGP(0): Revise route installing 1 of 1 routes for 20.0.0.0/8 ->
> 172.20.1.3(main) to main IP table
> 01:08:19: BGP(0): Revise route installing 1 of 1 routes for 30.0.0.0/8 ->
> 172.20.1.2(main) to main IP table
> 01:08:19: BGP(0): updgrp 1 - 172.20.1.2 updates replicated for neighbors:
> 172.20.1.3
> 01:08:19: BGP(0): 172.20.1.3 rcvd UPDATE w/ attr: nexthop 172.20.1.3,
> origin i, localpref 100, metric 0
> 01:08:19: BGP(0): 172.20.1.3 rcvd 20.0.0.0/8
> 01:08:19: BGP(0): 172.20.1.3 rcvd UPDATE w/ attr: nexthop 172.20.1.2,
> origin i, localpref 100, metric 0, originator 200.20.20.20, clusterlist
> 200.10.10.10
> 01:08:19: BGP(0): 172.20.1.3 rcvd 30.0.0.0/8
> 01:08:19: BGP(0): Revise route installing 1 of 1 routes for 20.0.0.0/8 ->
> 172.20.1.3(main) to main IP table
> 01:08:19: BGP(0): updgrp 1 - 172.20.1.2 updates replicated for neighbors:
> 172.20.1.3
> Switch#
> Switch#
> Switch#
> Switch#telnet 172.20.1.2
> Trying 172.20.1.2 ... Open
>
>
> User Access Verification
>
> Username: cisco
> Password:
> 3550#clear ip bgp 6441 512
> 3550#telnet 172.
> 01:08:40: %BGP-5-ADJCHANGE: neighbor 172.20.1.2 Down Peer closed the
> session20.1.3
> Trying 172.20.1.3 ... Open
>
> Router#
> 01:08:40: BGP(0): Revise route installing 1 of 1 routes for 30.0.0.0/8 ->
> 172.20.1.2(main) to main IP table
> 01:08:40: BGP(0): updgrp 1 - 172.20.1.3 updates replicated for neighbors:
> 01:08:41: BGP(0): 172.20.1.3 rcv UPDATE about 30.0.0.0/8 -- withdrawn
> 01:08:41: BGP(0): no valid path for 30.0.0.0/8
> 01:08:41: BGP(0): nettable_walker 30.0.0.0/8 no best path
> 01:08:41: BGP(0): updgrp 1 - 172.20.1.3 updates replicated for
> neighbors:clear ip b
> 01:08:43: BGP(0): 172.20.1.3 rcvd UPDATE w/ attr: nexthop 172.20.1.2,
> origin i, localpref 100, metric 0, originator 200.20.20.20, clusterlist
> 200.10.10.10
> 01:08:43: BGP(0): 172.20.1.3 rcvd 30.0.0.0/8
> 01:08:43: BGP(0): Revise route installing 1 of 1 routes for 30.0.0.0/8 ->
> 172.20.1.2(main) to main IP table
> 01:08:43: BGP(0): updgrp 1 - 172.20.1.3 updates replicated for neighbors:
> 01:08:44: %BGP-5-ADJCHANGE: neighbor 172.20.1.2 Up
> 01:08:44: BGP(0): 172.20.1.2 rcvd UPDATE w/ attr: nexthop 172.20.1.2, gp
> origin i, localpref 100, metric 0
> 01:08:44: BGP(0): 172.20.1.2 rcvd 30.0.0.0/8
> 01:08:44: BGP: 172.20.1.2 Local router is the Originator; Discard update
> 01:08:44: BGP(0): 172.20.1.2 rcv UPDATE w/ attr: nexthop 172.20.1.2, origin
> i, localpref 100, metric 0, originator 172.20.1.1, clusterlist 200.20.20.20
> 200.10.10.10, path , community , extended community , SSA attribute
> 01:08:44: BGPSSA ssacount is 0
> 01:08:44: BGP(0): 172.20.1.2 rcv UPDATE about 10.0.0.0/8 -- DENIED due to:
> ORIGINATOR is us;
> 01:08:4464512
> Router#: BGP(0): 172.20.1.2 rcvd UPDATE w/ attr: nexthop 172.20.1.3, origin
> i, localpref 100, metric 0, originator 200.10.10.10, clusterlist
> 200.20.20.20
> 01:08:44: BGP(0): 172.20.1.2 rcvd 20.0.0.0/8
> 01:08:44: BGP(0): Revise route installing 1 of 1 routes for 30.0.0.0/8 ->
> 172.20.1.2(main) to main IP table
> 01:08:44: BGP(0): 172.20.1.2 send UPDATE (format) 10.0.0.0/8, next
> 172.20.1.1, metric 0, path Local
> 01:08:44: BGP(0): updgrp 1 - 172.20.1.2 updates replicated for neighbors:
> 01:08:44: BGP(0): updgrp 1 - 172.20.1.2 updates replicated for neighbors:
> 172.20.1.3
> 01:08:44: BGP(0): 172.20.1.2 rcv UPDATE about 10.0.0.0/8 -- withdrawn
> 01:08:46: BGP(0): 172.20.1.2 rcv UPDATE about 20.0.0.0/8 -- withdrawn
> 01:08:46: BGP(0): no valid path for 20.0.0.0/8
> 01:08:46: %BGP-5-ADJCHANGE: neighbor 172.20.1.3 Down Peer closed the
> session
> 01:08:46: BGP(0): nettable_walker 20.0.0.0/8 no best path
> 01:08:46: BGP(0): updgrp 1 - 172.20.1.2 updates replicated for neighbors:
> 01:08:46: %BGP-5-ADJCHANGE: neighbor 172.20.1.3 Up
> 01:08:46: BGP(0): 172.20.1.3 rcvd UPDATE w/ attr: nexthop 172.20.1.3,
> origin i, localpref 100, metric 0
> 01:08:46: BGP(0): 172.20.1.3 rcvd 20.0.0.0/8
> 01:08:46: BGP(0): Revise route installing 1 of 1 routes for 20.0.0.0/8 ->
> 172.20.1.3(main) to main IP table
> 01:08:46: BGP(0): 172.20.1.3 send UPDATE (format) 10.0.0.0/8, next
> 172.20.1.1, metric 0, path Local
> 01:08:46: BGP(0): updgrp 1 - 172.20.1.3 updates replicated for neighbors:
> 01:08:46: BGP(0): updgrp 1 - 172.20.1.3 updates replicated for neighbors:
> 172.20.1.2
> 01:08:46: BGP(0): 172.20.1.2 rcvd UPDATE w/ attr: nexthop 172.20.1.3,
> origin i, localpref 100, metric 0, originator 200.10.10.10, clusterlist
> 200.20.20.20
> 01:08:46: BGP(0): 172.20.1.2 rcvd 20.0.0.0/8
> 01:08:46: BGP: 172.20.1.3 Local router is the Originator; Discard update
> 01:08:46: BGP(0): 172.20.1.3 rcv UPDATE w/ attr: nexthop 172.20.1.3, origin
> i, localpref 100, metric 0, originator 172.20.1.1, clusterlist 200.10.10.10
> 200.20.20.20, path , community , extended community , SSA attribute
> 01:08:46: BGPSSA ssacount is 0
> 01:08:46: BGP(0): 172.20.1.3 rcv UPDATE about 10.0.0.0/8 -- DENIED due to:
> ORIGINATOR is us;
> 01:08:46: BGP(0): 172.20.1.3 rcvd UPDATE w/ attr: nexthop 172.20.1.2,
> origin i, localpref 100, metric 0, originator 200.20.20.20, clusterlist
> 200.10.10.10
> 01:08:46: BGP(0): 172.20.1.3 rcvd 30.0.0.0/8
> 01:08:46: BGP(0): 172.20.1.3 rcv UPDATE about 10.0.0.0/8 -- withdrawn
> Router#
> Router#
> Router#exi
>
> [Connection to 172.20.1.3 closed by foreign host]
>
>
>
>
> On Mon, May 11, 2009 at 12:52 PM, marish shah
<contactmarish_at_gmail.com>wrote:
>
>> Hi Experts,
>> One Q in bgp we use for loop prevention splithorzain That
>> ibgp cannot passed received routes to other ibgp .But when we use rout
>> reflector this rule failed.Then we have two options 1: originating ID 2:
>> Cluster ID
>> If we are using single route reflector then we use originating ID and if
>> we
>> have multiple route reflector then we use cluster ID to ovoid route
>> feedback.
>> Please correct me If I put any thing wrong.
>>
>> So my Q is if we have multiple route reflector and we are not using
>> cluster
>> ID then what happen there is loop or it use any other thing ?
>>
>>
>>
>> Thanks.
>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
Blogs and organic groups at http://www.ccie.net
Received on Mon May 11 2009 - 14:26:53 ART
This archive was generated by hypermail 2.2.0 : Mon Jun 01 2009 - 07:04:42 ART