You said previously that it was working back-to-back. It should work with the switch in the middle.
But looking to your configs, it seems you are mixing the old and the new way to configure PPPoE.
Look bellow the options you have and correct your configs accordingly.
1) PPPoE Server (new format-after 12.2(15)T)
!
bba-group pppoe global
virtual-template 1
!
interface Virtual-Template1
ip address 150.1.45.5 255.255.255.0
!
interface Ethernet1/1
pppoe enable group global
!
2) PPPoE Client (new format-after 12.2(13)T)
!
interface Dialer1
mtu 1492
ip address 150.1.45.4 255.255.255.0
encapsulation ppp
dialer pool 1
dialer persistent
!
interface Ethernet1/1
pppoe enable
pppoe-client dial-pool-number 1
!
3) PPPoE Server (old format-before 12.2(15)T)
R3:
interface Ethernet0/1
pppoe enable
!
interface Virtual-Template1
ip address 142.1.35.3 255.255.255.0
!
vpdn enable
!
vpdn-group PPPoE
accept-dialin
protocol pppoe
virtual-template 1
!
4) PPPoE Client (old format-before 12.2(13)T)
R5:
interface Ethernet0/0
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
mtu 1492
ip address 142.1.35.3 255.255.255.0
encapsulation ppp
dialer pool 1
!
vpdn enable
!
vpdn-group PPPoE
request-dialin
protocol pppoe
!
Regards,
Antonio Soares, CCIE #18473 (R&S)
amsoares_at_netcabo.pt
-----Original Message-----
From: nobody_at_groupstudy.com [mailto:nobody_at_groupstudy.com] On Behalf Of Dheven
Sent: sexta-feira, 8 de Maio de 2009 15:17
To: Hashiru Aminu
Cc: Divin Mathew John; Cisco certification
Subject: Re: PPPOE issue
But if i change the config to this:
R1:
vpdn enable
vpdn-group 1
request-dialin
protocol pppoe
interface fa0/1
ip address dhcp
pppoe enable group global
pppoe-client dial-pool-number 1
interface Dialer1
ip unnumered fa0/1
encapsulation ppp
dialer pool 1
ppp chap hostname cisco
ppp chap password cisco
R6:
username cisco password cisco
vpdn enable
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
ip dhcp excluded-address 172.10.16.2 172.10.16.254
ip dhcp pool PPPOE
network 172.10.16.0 255.255.255.0
interface fa0/1
ip address 172.10.16.6 255.255.255.0
pppoe enable group global
interface virtual-template 1
ip unnumbered fa0/1
no peer neighbor-route
I get allocated an ip address from DHCP server (R6) but my vpdn tunnel does
not come up.
Very strange
D
On Fri, May 8, 2009 at 3:57 PM, Hashiru Aminu <hashng_at_gmail.com> wrote:
> Dheven
>
> ppp uses 8 byte. U have to make the Mtu on the dialer 1492..
> Secondly, if I were you I will make sure my pppoe session is up before
> adding any authentication and other Advaced Features.
> 'Debug PPP negotiation' will help u know why.
> Hth
>
>
> Rgds
> Hash#16818 RS&SP
> Sent from my iPhone
>
>
> On May 8, 2009, at 4:33 PM, Divin Mathew John <divinjohn_at_gmail.com> wrote:
>
> yeah try incereasing the MTU on the switches or make the MTU on the
>> routers 1492
>> Thanking You
>>
>> Yours Sincerely
>>
>> Divin Mathew John
>> divinjohn_at_gmail.com
>> divin_at_dide3d.com
>> http://www.dide3d.com
>> +91 9945430983
>> +91 9846697191
>> +974 5008916
>> PGP PUBLIC KEY BLOCK @ http://www.dide3d.com/divin_Public_PGP_key.txt
>> Sent from Bangalore, KA, India
>>
>>
>> On Fri, May 8, 2009 at 7:02 PM, Dheven <dheven_at_gmail.com> wrote:
>>
>>> Hi Divin
>>>
>>> 1500
>>>
>>> On Fri, May 8, 2009 at 3:29 PM, Divin Mathew John <divinjohn_at_gmail.com>
>>> wrote:
>>>
>>>>
>>>> MTU on the switches?
>>>> Thanking You
>>>>
>>>> Yours Sincerely
>>>>
>>>> Divin Mathew John
>>>> divinjohn_at_gmail.com
>>>> divin_at_dide3d.com
>>>> http://www.dide3d.com
>>>> +91 9945430983
>>>> +91 9846697191
>>>> +974 5008916
>>>> PGP PUBLIC KEY BLOCK @ http://www.dide3d.com/divin_Public_PGP_key.txt
>>>>
>>>>
>>>>
>>>> On Fri, May 8, 2009 at 6:55 PM, Dheven <dheven_at_gmail.com> wrote:
>>>>
>>>>> Hi GS.
>>>>>
>>>>> I am having a problem setting up PPPOE.
>>>>>
>>>>> here is my setup:
>>>>>
>>>>> R1 --- SW1(fa0/1) ---- SW1(fa0/6) ---- R6
>>>>>
>>>>> I have tested this with just using back to back connections and it
>>>>> works
>>>>> but
>>>>> when i add the switch to the equation I cannot get this to work.
>>>>>
>>>>> any assistance will be greatly appreciated.
>>>>>
>>>>> R1:
>>>>>
>>>>> vpdn enable
>>>>>
>>>>> vpdn-group 1
>>>>> request-dialin
>>>>> protocol pppoe
>>>>>
>>>>> interface fa0/1
>>>>> no ip address
>>>>> pppoe enable group global
>>>>> pppoe-client dial-pool-number 1
>>>>>
>>>>> interface Dialer1
>>>>> ip address dhcp
>>>>> encapsulation ppp
>>>>> dialer pool 1
>>>>> ppp chap hostname cisco
>>>>> ppp chap password cisco
>>>>>
>>>>> R6:
>>>>> username cisco password cisco
>>>>>
>>>>> vpdn enable
>>>>>
>>>>> vpdn-group 1
>>>>> accept-dialin
>>>>> protocol pppoe
>>>>> virtual-template 1
>>>>>
>>>>> ip dhcp excluded-address 172.10.16.2 172.10.16.254
>>>>> ip dhcp pool PPPOE
>>>>> network 172.10.16.0 255.255.255.0
>>>>>
>>>>> interface fa0/1
>>>>> pppoe enable group global
>>>>>
>>>>>
>>>>> interface virtual-template 1
>>>>> ip address 172.10.16.6 255.255.255.0
>>>>> no peer neighbor-route
>>>>>
>>>>>
>>>>> I also tested with adding the "ip address dhcp" under the physical
>>>>> interface
>>>>> this works (i get an ip address from the dhcp server) but my vpdn
>>>>> tunnel
>>>>> does not come up.
>>>>>
>>>>>
>>>>> what am I doing wrong.
>>>>>
>>>>>
>>>>> D
>>>>> ---
>>>>> Always forgive your enemies - Nothing annoys them so much.
>>>>>
>>>>>
>>>>> Blogs and organic groups at http://www.ccie.net
>>>>>
>>>>> _______________________________________________________________________
>>>>>
>>>>
>
> Subscription information may be found at:
>>>>> http://www.groupstudy.com/list/CCIELab.html
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>
>>>
>>> --
>>> Always forgive your enemies - Nothing annoys them so much.
>>>
>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> _______________________________________________________________________
>>
>
>
> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>>
>>
>>
>>
>>
>>
>>
>>
-- Always forgive your enemies - Nothing annoys them so much. Blogs and organic groups at http://www.ccie.netReceived on Fri May 08 2009 - 16:09:28 ART
This archive was generated by hypermail 2.2.0 : Mon Jun 01 2009 - 07:04:42 ART