Re: set interface command under route-map

From: Divin Mathew John <divinjohn_at_gmail.com>
Date: Thu, 7 May 2009 00:11:08 +0530

R0#sh ip route
*Mar 1 01:00:16.283: %SYS-5-CONFIG_I: Configured from console by console
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     50.0.0.0/24 is subnetted, 1 subnets
C 50.50.50.0 is directly connected, Loopback12
     10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, FastEthernet0/0
     11.0.0.0/30 is subnetted, 1 subnets
C 11.1.1.0 is directly connected, FastEthernet1/0

Thanking You

Yours Sincerely

Divin Mathew John
divinjohn_at_gmail.com
divin_at_dide3d.com
http://www.dide3d.com
+91 9945430983
+91 9846697191
+974 5008916
PGP PUBLIC KEY BLOCK @ http://www.dide3d.com/divin_Public_PGP_key.txt
Sent from Bangalore, KA, India

On Wed, May 6, 2009 at 11:47 PM, Jared Scrivener
<jscrivener_at_ipexpert.com> wrote:
> Thanks for posting the output there, Divin. It does a great job of showing
> the relationship between your route tables and the CEF table (although R0's
> route table is probably the most important here and the one you left out of
> your information below).
>
> You'll see that because you have the route-cache entry for the FastEthernet
> 1/0 interface in your CEF table, your route-map worked - the router found
> that interface in the CEF table, can see the associated next hop (11.1.1.2)
> and therefore knew where to forward the default route (to R2 only).
>
> Some other cool things to observe (that I've never noticed before) are the
> "drop" entries - you'll notice that the router automatically has drop
> entries for the Class E range and other miscellaneous entries. I find that
> pretty interesting...
>
> Cheers,
>
> Jared Scrivener CCIE3 #16983 (R&S, Security, SP), CISSP
> Sr. Technical Instructor - IPexpert, Inc.
> Telephone: +1.810.326.1444
> Fax: +1.810.454.0130
> Mailto: jscrivener_at_ipexpert.com
>
>
> -----Original Message-----
> From: Divin Mathew John [mailto:divinjohn_at_gmail.com]
> Sent: Wednesday, 6 May 2009 10:55 AM
> To: Jared Scrivener
> Cc: Anantha Subramanian Natarajan; Cisco certification
> Subject: Re: set interface command under route-map
>
> I got it to work.. here's my config
> R0
> interface FastEthernet0/0
> ip address 10.1.1.1 255.255.255.252
> duplex auto
> speed auto
> !
> interface FastEthernet1/0
> ip address 11.1.1.1 255.255.255.252
> duplex auto
> speed auto
> !
> router rip
> version 2
> network 10.0.0.0
> network 11.0.0.0
> default-information originate route-map R0toR1DefaultRoute
> no auto-summary
> !
> ip http server
> ip forward-protocol nd
> !
> !
> !
> !
> route-map R0toR1DefaultRoute permit 10
> set interface FastEthernet1/0
> !
>
> R1#sh ip route
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2
> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
> ia - IS-IS inter area, * - candidate default, U - per-user static
> route
> o - ODR, P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 10.0.0.0/30 is subnetted, 1 subnets
> C 10.1.1.0 is directly connected, FastEthernet0/0
> 11.0.0.0/30 is subnetted, 1 subnets
> R 11.1.1.0 [120/1] via 10.1.1.1, 00:00:08, FastEthernet0/0
>
> R2#sh ip route
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2
> i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
> ia - IS-IS inter area, * - candidate default, U - per-user static
> route
> o - ODR, P - periodic downloaded static route
>
> Gateway of last resort is 11.1.1.1 to network 0.0.0.0
>
> 10.0.0.0/30 is subnetted, 1 subnets
> R 10.1.1.0 [120/1] via 11.1.1.1, 00:00:21, FastEthernet0/0
> 11.0.0.0/30 is subnetted, 1 subnets
> C 11.1.1.0 is directly connected, FastEthernet0/0
> R* 0.0.0.0/0 [120/1] via 11.1.1.1, 00:00:21, FastEthernet0/0
>
> R1, R2 have Ripv2 running .! i was able to do it.! my cef table on R0
>
> R0#sh ip cef
> Prefix Next Hop Interface
> 0.0.0.0/0 drop Null0 (default route handler entry)
> 0.0.0.0/8 drop
> 0.0.0.0/32 receive
> 10.1.1.0/30 attached FastEthernet0/0
> 10.1.1.0/32 receive
> 10.1.1.1/32 receive
> 10.1.1.2/32 10.1.1.2 FastEthernet0/0
> 10.1.1.3/32 receive
> 11.1.1.0/30 attached FastEthernet1/0
> 11.1.1.0/32 receive
> 11.1.1.1/32 receive
> 11.1.1.2/32 11.1.1.2 FastEthernet1/0
> 11.1.1.3/32 receive
> 127.0.0.0/8 drop
> 224.0.0.0/4 drop
> 224.0.0.0/24 receive
> 240.0.0.0/4 drop
> 255.255.255.255/32 receive
>
> i didnt tweak anything. the warning message did come.! but its working!
> fine.!
>
> Thanking You
>
> Yours Sincerely
>
> Divin Mathew John
> divinjohn_at_gmail.com
> divin_at_dide3d.com
> http://www.dide3d.com
> +91 9945430983
> +91 9846697191
> +974 5008916
> PGP PUBLIC KEY BLOCK @ http://www.dide3d.com/divin_Public_PGP_key.txt
>
>
>
> On Wed, May 6, 2009 at 10:37 PM, Jared Scrivener
> <jscrivener_at_ipexpert.com> wrote:
>> Hmmm... Well, based on your own description, do you have a route-cache
>> entry?
>>
>> Think CEF... Find the show command (most start with "sh ip cef") and see
> if
>> the entry is there. Then test the configuration and see if it works (based
>> on the route-cache entry you expect).
>>
>> Cheers,
>>
>> Jared Scrivener CCIE3 #16983 (R&S, Security, SP), CISSP
>> Sr. Technical Instructor - IPexpert, Inc.
>> Telephone: +1.810.326.1444
>> Fax: +1.810.454.0130
>> Mailto: jscrivener_at_ipexpert.com
>>
>>
>> -----Original Message-----
>> From: nobody_at_groupstudy.com [mailto:nobody_at_groupstudy.com] On Behalf Of
>> Anantha Subramanian Natarajan
>> Sent: Wednesday, 6 May 2009 9:54 AM
>> To: Cisco certification
>> Subject: set interface command under route-map
>>
>> Hi All,
>>
>> I am trying to solve the below requirement and stumbled on understanding
> a
>> command,which I am trying to use to acheive this requirement.One of the
> core
>> labworkbook IE lab scenario as something similar requirement as below
>>
>> The router running rip2(R2) should only send a default-route to a
> particular
>> neighbor(r3) and not to other.The solution considered is to use
>> default-information originate associated with a route-map under rip
> process
>> as beow
>>
>>
>>
>>
>> R1-Serial Link--R2 --Ethernet link ---R3
>>
>> router rip
>>
>> default-information originate route-map test
>>
>> !
>>
>> route-map test permit 10
>>
>> set interface Ethernetx/x
>>
>>
>>
>> Is the above solution would solve the requirement.If so,when I was
> referring
>> a cisco DOC,it mentions a statement "The *set interface* command is
>> supported only over a point-to-point link, unless a route-cache entry
> exists
>> using the same interface specified in the *set interface* command in the
>> route map".Since I am trying to send the deafult route only towards the
>> ethernet link(Which I am considering not as point-to-point),will this
>> soltion still work ??..May be I am mis-understanding or not knowing the
>> basic of point-to-point usage here ? ...Also couldn't under the verbage
>> "unless a route-cache entry exists using the same interface specified in
> the
>> *set interface* command in the route map" ..........Kindly let me know
> your
>> suggestions/comment.
>>
>>
>>
>> Thanks
>>
>>
>>
>> Regards
>>
>> Anantha Subramanian Natarajan
>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Thu May 07 2009 - 00:11:08 ART

This archive was generated by hypermail 2.2.0 : Mon Jun 01 2009 - 07:04:42 ART