Here is a configuration where R1 imports information from R3 using the
DHCP protocol.
In this scenario, R1 uses its own subnet for DHCP pool/default route,
but imports
DNS/WINS servers and Option 150 from R3.
R1:
interface Serial0/1
no ip address
encapsulation ppp
dialer in-band
dialer pool-member 1
!
interface Dialer1
ip address dhcp
dialer pool 1
!
ip dhcp pool LOCAL
import all
network 20.0.0.0 255.255.255.0
default-router 20.0.0.1
!
interface FastEthernet0/0
ip address 20.0.0.1 255.255.255.0
R3:
ip dhcp pool POOL
network 10.0.0.0 255.255.255.0
dns-server 10.0.0.100 10.0.0.200
netbios-name-server 10.0.0.100
option 150 ip 10.0.0.150
default-router 10.0.0.3
!
interface FastEthernet0/0
ip address 10.0.0.3 255.255.255.0
!
interface Serial1/2
ip unnumbered FastEthernet0/0
encapsulation ppp
clock rate 128000
R1#show ip dhcp pool
Pool LOCAL :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 254
Leased addresses : 0
Pending event : none
1 subnet is currently in the pool :
Current index IP address range Leased addresses
20.0.0.1 20.0.0.1 - 20.0.0.254 0
R1#show ip dhcp import
Address Pool Name: LOCAL
Domain Name Server(s): 10.0.0.100 10.0.0.200
NetBIOS Name Server(s): 10.0.0.100
TFTP Server Address Option: 10.0.0.150
R3#show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
10.0.0.2 0063.6973.636f.2d30. May 04 2009 10:21 AM Automatic
3030.642e.6564.6338.
2e34.6636.302d.4469.
31
HTH
-- Petr Lapukhov, petr_at_INE.com CCIE #16379 (R&S/Security/SP/Voice) Internetwork Expert, Inc. http://www.INE.com Toll Free: 877-224-8987 Outside US: 775-826-4344 2009/5/3 nowy1981 <freemaxis_at_gmail.com>: > Thanks Peter, > > so second question BTW, how exactly indside interface should be configured > to assigned IP addresses to the hosts based on the DHCP ODAP feature. > > Could you send me any example? > > Petr Lapukhov pisze: >> >> Hi, >> >> If you are referrering to the DHCP option 150, you should run DHCP >> over PPP, not IPCP. This is accomplished >> by using the command "ip address dhcp" on the PPP link instead of "ip >> address negotiated" and is available since IOS 12.2T AFAIR. >> Naturally, the DHCP pool in the server should be configured with >> option 150 (TFTP IP) enabled. However, the router will not get much >> use of the option, unless it import the option into the local DHCP >> pool (import all + origin dhcp). The only other use of DHCP option 150 >> by the router that comes to mind is AutoInstall over Ethernet. >> >> The number of IPCP options is very limited: IP address, DNS/WINS >> server IP, IP Compression Protocol, Subnet Mask (used by Cisco) and a >> few more. You may selectively enable some non-default options using >> the command "ppp ipcp" under the PPP interface configuration mode. >> You may use those options to seed the local DHCP pool as well (import >> all + origin ipcp) >> >> HTH > > > Blogs and organic groups at http://www.ccie.net > > _______________________________________________________________________ > Subscription information may be found at: > http://www.groupstudy.com/list/CCIELab.html Blogs and organic groups at http://www.ccie.netReceived on Sun May 03 2009 - 21:31:56 ART
This archive was generated by hypermail 2.2.0 : Mon Jun 01 2009 - 07:04:41 ART