Hi John,
I think that there are many things that you can test or review. Initially I
change some things in your configs as follows:
CORE
ip dhcp excluded-address 172.16.1.100
ip dhcp excluded-address 172.16.1.1 172.16.1.10
ip dhcp excluded-address 172.16.1.252
ip dhcp excluded-address 172.17.1.252
ip dhcp excluded-address 172.18.1.252
ip dhcp excluded-address 172.18.100.252
!
ip dhcp pool DATA
network 172.16.0.0 255.255.240.0
domain-name wr
default-router 172.16.1.252
lease infinite
!
ip dhcp pool VOICE
network 172.17.0.0 255.255.240.0
domain-name wr
default-router 172.17.1.252
lease infinite
!
interface Vlan10
ip address 172.16.1.252 255.255.240.0
!
interface Vlan20
ip address 172.17.1.252 255.255.240.0
Access-Switch for Data
interface FastEthernet0/46
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
no interface Vlan10
Access-Switch for Voice
interface FastEthernet0/46
switchport voice vlan 20
!
no interface Vlan20
You don't need redirect the DHCP requests to DHCP server, if this server is in
the same vlan that the clients, and so you don't need interface vlan in this
switches. Also I have some questions. In the voice vlan, do you have IP
Phones? Have you check that phones aren't preconfigured with any option
(forced voice vlan, dhcp disable, and so on)? What's the exactly problem in
voice vlan, the phones can not get IP?
I hope help you!!!
Regards.
---------------------
---------------------
Jose A. Arnau Alvarez
CCIE R&S #23051
---------------------
---------------------
> From: ciscoarabia_at_live.com
> To: ccielab_at_groupstudy.com
> Subject: DHCP Problem
> Date: Tue, 21 Apr 2009 07:20:23 +0000
>
> Hi All
>
> I have the network have an access switches connected through trunk to the
CORE
> and all switches able to ping and connectivity is 100%. I bit issue in
DHCP.I
> make a seperate vlan for DATA and VOICE, these DHCP scope define in the
core
> and once I connect to DATA network Switches -> will take the IP from the
data
> pool but for voice not working.....Dont know why ?
> There is not firewall or router to block any traffic, Could please help out
>
>
> CORE
>
> ip dhcp excluded-address 172.16.1.100
> ip dhcp excluded-address 172.16.1.1 172.16.1.10
> ip dhcp excluded-address 172.16.1.252
> ip dhcp excluded-address 172.17.1.252
> ip dhcp excluded-address 172.18.1.252
> ip dhcp excluded-address 172.18.100.252
> !
> ip dhcp pool DATA
> network 172.16.1.0 255.255.240.0
> domain-name wr
> default-router 172.16.1.252
> lease infinite
> !
> ip dhcp pool VOICE
> network 172.17.1.0 255.255.240.0
> domain-name wr
> default-router 172.17.1.252
> lease infinite
> !
> interface Vlan10
> ip address 172.16.1.252 255.255.240.0
> !
> interface Vlan20
> ip address 172.17.1.252 255.255.240.0
>
> Access-Switch for Data
> interface FastEthernet0/46
> switchport access vlan 10
> switchport mode access
> spanning-tree portfast
>
> interface Vlan10
> no ip address
> ip helper-address 172.16.1.252
>
> Access-Switch for Voice
> interface FastEthernet0/46
> switchport voice vlan 20
>
> interface Vlan20
> no ip address
> ip helper-address 172.17.1.252
>
>
> Regards
> John
> _________________________________________________________________
> Windows Live SkyDrive: Get 25 GB of free online storage.
> http://windowslive.com/online/skydrive?ocid=TXT_TAGLM_WL_skydrive_042009
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
>
>
>
>
Received on Tue Apr 21 2009 - 19:21:35 ART
This archive was generated by hypermail 2.2.0 : Mon May 04 2009 - 07:39:12 ART