Re: default-information originate route-map

From: Dale Shaw <dale.shaw_at_gmail.com>
Date: Sun, 19 Apr 2009 13:53:39 +1000

Hmmm yeah, that works. But I think this (using "track ip route
reachability") is a touch tidier:

track 1 ip route 0.0.0.0 0.0.0.0 reachability
!
ip route 1.1.1.1 255.255.255.255 Null0 track 1
!
access-list 72 permit 1.1.1.1
!
route-map BLAH
 match ip address 72
!
router rip
 default-information originate route-map BLAH

cheers,
Dale

On Sun, Apr 19, 2009 at 1:44 PM, Salah ElShekeil
<salah.elshekeil_at_gmail.com> wrote:
> try this
>
>
> route-map DEF permit 10
> mat ip add pr STATIC
>
>
> ip preifix-list STATIC permit 169.254.0.1/32
>
> ip route 169.254.0.1 255.255.255.255 null0 track 1
>
> *you can define any ip address here but this, but this one is link local
> ipv4 address !
>
> track 1 rtr 1
>
> then u have to configure SLA to wat ever ip address u want to track
>
> then under rip
>
> router rip
> default-information originate route-map DEF
>
> I tried it several times it works
>
> HTH
>
>
> SE
>
> On Sun, Apr 19, 2009 at 3:23 AM, Gavin Schokman <g_schokman_at_yahoo.com.au>wrote:
>
>> Different version on a different platform.
>> I guess the moral to the story is don't use 0.0.0.0/0 for conditional
>> default originate for RIP!
>>
>> Thanks all for your input.
>>
>> Cheers,
>> Gavin
>>
>> -----Original Message-----
>> From: Ryan West [mailto:rwest_at_zyedge.com]
>> Sent: 19 April 2009 01:14
>> To: Gavin Schokman; ccielab_at_groupstudy.com
>> Subject: RE: default-information originate route-map
>>
>> 12.4(23) on a 2801.
>>
>> -----Original Message-----
>> From: Gavin Schokman [mailto:g_schokman_at_yahoo.com.au]
>> Sent: Saturday, April 18, 2009 8:13 PM
>> To: Ryan West; ccielab_at_groupstudy.com
>> Subject: RE: default-information originate route-map
>>
>>
>> Thanks, Ryan - good to know it's not just me losing my marbles :)
>> Out of curiosity, what IOS version are you using?
>>
>> Cheers,
>> Gavin
>>
>> -----Original Message-----
>> From: Ryan West [mailto:rwest_at_zyedge.com]
>> Sent: 19 April 2009 00:44
>> To: Gavin Schokman; ccielab_at_groupstudy.com
>> Subject: RE: default-information originate route-map
>>
>> Gavin / Dale,
>>
>> Neither ACL / ip default-network / nor prefix-list (during the first test)
>> re-inserted the route after it's manually removed from the table and then
>> re-inserted. A clear ip route or modification to the route-map will cause
>> it to be re-read and then route is re-inserted. The combination of ACL and
>> ip default-network seem to provide the most consistent results and that
>> only
>> lasted for a little while. After removing and re-adding about 5 times, the
>> only way I could it to read the route-map again was to get into route-map
>> sub configuration:
>>
>> I tried to give it enough time to for any flush or hold down timers, but
>> that doesn't seem to matter.
>>
>> 23:30:20.457: -> re-added static route
>> 23:34:32.325: -> waited over 4 mins and then entered the route-map
>> configuration mode:
>>
>> Rack1R1(config-route-map)#route-map ADV_DEFAULT Rack1R1(config-route-map)#
>> *Apr 18 23:34:32.325: RIP-DB: adding 0.0.0.0/0 (metric 1) via 0.0.0.0 on
>> Null0 to RIP database *Apr 18 23:34:32.325: RIP-DB: add 0.0.0.0/0 (metric
>> 1)
>> via 0.0.0.0 on Null0 (donot_age) *Apr 18 23:34:32.325: RIP-DB: Adding new
>> rndb entry 0.0.0.0/0 *Apr 18 23:34:32.325: RIP-DB: Created rip ndb summary
>> entry for 0.0.0.0/0 *Apr 18 23:34:32.325: RIP-DB: Adding new rndb entry
>> 0.0.0.0/0
>>
>> Seems a little flaky :)
>>
>> -ryan
>>
>>
>> -----Original Message-----
>> From: Gavin Schokman [mailto:g_schokman_at_yahoo.com.au]
>> Sent: Saturday, April 18, 2009 7:07 PM
>> To: Ryan West; ccielab_at_groupstudy.com
>> Subject: RE: default-information originate route-map
>>
>>
>> Can you do me a favour and remove the static route and then re-insert it?
>> I'm not 100% confident it's not a bug.
>>
>> I'm using 3600 Software (C3640-JK9O3S-M), Version 12.4(10c)
>>
>> Cheers,
>> Gavin
>>
>>
>> -----Original Message-----
>> From: Ryan West [mailto:rwest_at_zyedge.com]
>> Sent: 18 April 2009 23:59
>> To: Gavin Schokman; ccielab_at_groupstudy.com
>> Subject: RE: default-information originate route-map
>>
>> Gavin,
>>
>> I just labbed it up:
>>
>> *Apr 18 23:01:25.669: RIP: received v2 update from 173.1.13.1 on Serial1/2
>> *Apr 18 23:01:25.669: 0.0.0.0/0 via 0.0.0.0 in 1 hops
>>
>> router rip
>> version 2
>> network 173.1.0.0
>> default-information originate route-map ADV_DEFAULT no auto-summary ip
>> route 0.0.0.0 0.0.0.0 Null0 ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0
>> route-map ADV_DEFAULT permit 10 match ip address prefix-list DEFAULT
>>
>> I will tell you that I have had problems with defaults being originated
>> while using RIP. I recently configured a lab with a Boolean OR with
>> multiple interfaces matched. My track list was UP, but the route would not
>> cooperate until both were up.
>>
>> What version of code are you on?
>>
>> -ryan
>>
>> -----Original Message-----
>> From: nobody_at_groupstudy.com [mailto:nobody_at_groupstudy.com] On Behalf Of
>> Gavin Schokman
>> Sent: Saturday, April 18, 2009 6:34 PM
>> To: ccielab_at_groupstudy.com
>> Subject: default-information originate route-map
>>
>> Evening brain-bank,
>>
>> I'm working through some IEWB lab stuff and come across an unexpected
>> behaviour (unexpected to me at least).
>>
>> I'm trying to conditionally originate a default route via RIP. The
>> condition
>> I'm using is "does 0.0.0.0/0 appear in local route table?".
>> If yes -> originate default, if not -> don't originate
>>
>> The problem is that when I use 0.0.0.0/0 in the condition, it doesn't
>> work.
>> If I use another (random) route as the condition, it works.
>> See config below:
>>
>> condition_route = 0.0.0.0/0 => doesn't work
>>
>> router rip
>> version 2
>> default-information originate route-map DEFAULT_MONITOR no auto-summary
>>
>> ip route 0.0.0.0 0.0.0.0 Null0
>>
>> ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0
>>
>> route-map DEFAULT_MONITOR permit 10
>> match ip address prefix-list DEFAULT
>>
>> ! static route exists on Rack1R6
>>
>> Rack1R6#sh ip route 0.0.0.0
>> Routing entry for 0.0.0.0/0, supernet
>> Known via "static", distance 1, metric 0 (connected), candidate default
>> path
>> Routing Descriptor Blocks:
>> * directly connected, via Null0
>> Route metric is 0, traffic share count is 1
>>
>> ! default is not originated and pushed via RIP to Rack1R4
>>
>> Rack1R4#sh ip route 0.0.0.0
>> % Network not in table
>>
>> condition_route = 1.1.1.1/32 => doesn't work
>>
>> router rip
>> version 2
>> default-information originate route-map ROUTE_WATCH no auto-summary
>>
>> ip route 1.1.1.1 255.255.255.255 Null0
>>
>> ip prefix-list ROUTE_WATCH seq 5 permit 1.1.1.1/32
>>
>> route-map ROUTE_WATCH permit 10
>> match ip address prefix-list ROUTE_WATCH
>>
>> ! static route exists on Rack1R6
>>
>> Rack1R6#sh ip route 0.0.0.0
>> Routing entry for 0.0.0.0/0, supernet
>> Known via "static", distance 1, metric 0 (connected), candidate default
>> path
>> Routing Descriptor Blocks:
>> * directly connected, via Null0
>> Route metric is 0, traffic share count is 1
>>
>> ! default IS originated and pushed via RIP to Rack1R4
>>
>> Rack1R4#sh ip route 0.0.0.0
>> Routing entry for 0.0.0.0/0, supernet
>> Known via "rip", distance 120, metric 1, candidate default path
>> Redistributing via rip
>> Last update from 155.1.146.6 on Ethernet0/1, 00:00:03 ago
>> Routing Descriptor Blocks:
>> * 155.1.146.6, from 155.1.146.6, 00:00:03 ago, via Ethernet0/1
>> Route metric is 1, traffic share count is 1
>>
>>
>> Seems to be something strange with 0.0.0.0/0. I know it is matching, see
>> below
>>
>> Rack1R6#sh ip prefix-list detail
>> ip prefix-list DEFAULT:
>> count: 1, range entries: 0, sequences: 5 - 5, refcount: 2
>> seq 5 permit 0.0.0.0/0 (hit count: 20, refcount: 1)
>>
>>
>> Any thoughts?
>>
>> Cheers,
>> Gavin
>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>>
>>
>> Blogs and organic groups at http://www.ccie.net
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

Blogs and organic groups at http://www.ccie.net
Received on Sun Apr 19 2009 - 13:53:39 ART

This archive was generated by hypermail 2.2.0 : Mon May 04 2009 - 07:39:12 ART